+ Responder ao Tópico



  1. #1

    Padrão DNS Dinâmico: ChangeIP.com...

    Bom galera, para quem estava com dificuldades assim como eu no Script para atualizar automaticamente o IP no changeIP.com, segue abaixo o LINK do Wiki Mikrotic onde tem Script para algumas versões.

    ----------------------LINK NO WIKI MIKROTIK
    Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki
    -----------------------------------------------------

    .... Abraço, espero ter ajudado.

  2. #2

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    Sempre uso

    /tool dns-update name= dominio address=127.0.0.255 key-name= user key=senha

    Ate hoje nao tive problemas, uma vez que sempre pega o ip que esta saindo a net, independente de qual interface esta usando!!



  3. #3

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    Bom vou testar, ele funciona como o script que esta descrito no wiki do site da mikrotik?
    Ele atualiza em quanto em quanto tempo?
    autaliza nos mais diversos sites de DNS dinâmico?
    É aceito em todas as versões MK?
    Obrigado por tirar minhas dúvidas.

  4. #4
    Avatar de ultralaser
    Ingresso
    May 2007
    Localização
    Presidente Prudente
    Posts
    176
    Posts de Blog
    1

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    Procure no meu blog aqui da Under que tem o script pronto pra utilizar também



  5. #5

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    O Script eu achei no Wiki do Mikrotik, é que o parceiro deu um código que atualiza o código de forma diferente da que vi no site do MK.
    Por isso perguntei tudo aquilo.
    Mas tá tudo blz...

  6. #6

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    Veja este, achei aqui no fórum... Uso em todas minhas RB e PC-ap

    /system script
    add name=ddns policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/tool dns-update name=conta no changeip address=127.0.0.255 key-n\
    ame=ddns criado key=\"senha da conta\""


    /system scheduler
    add disabled=no interval=10m name=ddns on-event=ddns policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-time=startup



  7. #7
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    aqui também tenho esse:
    Código :
    :global ddnsuser "usuario"
    :global ddnspass "senha"
    :global ddnshost "dominio.ddns.info"
    :global ddnsinterface "interface"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: Enviado UPDATE!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={ 
    :log info "DDNS: Nao Necessita Ser Alterado."
    }
    }
    # END OF SCRIPT
    que uso nas minhas rb's e funcionam perfeitamente

  8. #8

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    cria um script com eta linha de comando, depois so criar um agendamento onde vc seta de quanto em quanto tempoo quer que atualize, ate o momento so testei com o changeip!



  9. #9
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: DNS Dinâmico: ChangeIP.com...

    aqui também uso dyndns, no caso quando tenho mais de um link eu acesso pelos dois e prefiro usar contas em servidores separados, nunca se sabe se um dele para numa hora que tempo que acessar rsrs

    :local ddnsuser "usuario"
    :local ddnspass "senha"
    :local theinterface "interface"
    :local ddnshost "dominio.dyndns.org"
    :local ipddns [:resolve $ddnshost];
    :local ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
    :if ([ :typeof $ipfresh ] = nil ) do={
    :log info ("DynDNS: No ip address on $theinterface .")
    } else={
    :for i from=( [:len $ipfresh] - 1) to=0 do={
    :if ( [ick $ipfresh $i] = "/") do={
    :set ipfresh [ick $ipfresh 0 $i];
    }
    }

    :if ($ipddns != $ipfresh) do={
    :log info ("DynDNS: IP-DynDNS = $ipddns")
    :log info ("DynDNS: IP-Fresh = $ipfresh")
    :log info "DynDNS: Update IP needed, Sending UPDATE...!"
    :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
    /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
    :delay 1
    :local str [/file find name="DynDNS.$ddnshost"];
    /file remove $str
    :global ipddns $ipfresh
    :log info "DynDNS: IP alterado para $ipfresh!"
    } else={
    :log info "DynDNS: Nao Necessita Ser Alterado";
    }
    }
    aqui funciona blz