+ Responder ao Tópico



  1. #1

    Padrão Problemas com OSPFv2

    Aqui na rede da empresa, o roteamento e feito todo em OSPFv2, rodando em Mikrotik v.5.12, a estrutura é mais ou menos assim:


    ========== RB 1100 ( B ) = > RB 1100 ( G )
    BGP ( A ) < RB 1100 ( D ) => RB 450G ( E )
    ========== RB 1100 ( C ) => RB 1100 ( F )

    BGP e feito num servidor e esta tambem rodando OSPF para rede interna e esta com Mikrotik v. 5.12.

    Eu fecho o OSPF entre ( A ) e ( B ), usando um /30 de IP´s Publicos;
    Eu fecho o OSPF entre ( A ) e ( D ), usando um /30 de IP´s Publicos, os roteadores sao interligado por 1 par de radio frequencia fechada.
    Eu fecho o OSPF entre ( D ) e ( E ), usando um /29 de IP´s Publicos, os roteadores sao interligado com 1 par de Rocket M5com Airmax habilitado.

    Eu tenho uma interface de loopback em cada Roteador e que adicionei um IP Publico para cada interface de loopback, cada uma dela esta declarada no ID da Instacia do OSPF com seu respectivo Ip Publico.

    Todos eles rodam na mesma AREA do OSPF.
    Nao existem Bridge nas interfaces que rodam o OSPF.

    A configuracao do Roteador ( D ) esta assim:
    Código :
    /routing ospf instance
    set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 \
        metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
        redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
        router-id=0.0.0.0
    add disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 \
        metric-other-ospf=auto metric-rip=20 metric-static=20 name=rede out-filter=ospf-out redistribute-bgp=no \
        redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no redistribute-static=as-type-1 \
        router-id=xxx.xxx.183.4
    /routing ospf area
    set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=default type=default
    add area-id=x.9.9.x disabled=no instance=rede name=rede type=default
    /routing ospf network
    add area=rede comment="REDE OSPF - ( B ) - BGP ### ETHER 1 ###" disabled=no network=xxx.xxx.182.244/30
    add area=rede comment=LOOPBACK disabled=no network=xxx.xxx.183.4/32
    add area=rede comment="REDE OSPF - ( B ) -  ### ETHER 3 ###" disabled=no network=xxx.xxx.183.216/29

    A configuracao do Roteador ( E ) esta assim:
    Código :
    /routing ospf instance
    set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto metric-connected=20 \
        metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
        redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
        router-id=0.0.0.0
    add comment="REDE OSPF - WIRELESS - ( D )" disabled=no distribute-default=never in-filter=ospf-in metric-bgp=auto \
        metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=wireless out-filter=\
        ospf-out redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no \
        redistribute-static=as-type-1 router-id=xxx.xxx.183.15
    /routing ospf area
    set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
    add area-id=x.9.9.x comment="REDE OSPF - WIRELESS - ( D )" disabled=no instance=wireless name=wireless type=default
    /routing ospf network
    add area=wireless comment="REDE OSPF - WIRELESS - ( D )" disabled=no network=xxx.xxx.183.216/29

    Quando reinicio o Roteador BGP, todas a rede volta a funcionar normalmente, agora quando reinicio o Roteador D, o Roteador E, nao volta, eu tenho que entrar nele por MAC TELNET e desabilitar sua instancia OSPF e habilitar ela de novo ou somente reiniciar a RB que volta a levantar a sessao OSPF, o erro no log do Roteador D que fica aparecendo enquanto esta caida a sessao OSPF é este:
    Código :
    route ospf info    Database Description packet has init bit set in middle of an exchange
    route ospf info    OSPFv2 neighbor xxx.xxx.xxx.xxx: state change from Exchange to 2-Way
    e quando entro no Roteador E e faço o descrito acima, aparece isto no log do Roteador D:
    Código :
    route ospf info    OSPFv2 neighbor xxx.xxx.xxx.xxx: state change from Exchange to Init
    e a sessao OSPF volta a funcionar normalmente.
    Isso tambem acontece com outros Roteadores que estao atras de outros Roteadores, mais nem todos eles, as vezes voltam normal mais as vezes nao.

  2. #2

    Padrão Re: Problemas com OSPFv2

    MikroTik 5.12 e OSPF eu desaprovei, tive problemas ao fazer upgrade da 5.7 e 5.11 rodando OSPF, acabei voltando pra 5.11.

    Na 5.12 também tive problema com as queue types.



  3. #3

    Padrão Re: Problemas com OSPFv2

    5.12 = varias mudanças precisa ser analizadas antes, e algumas mudanças nao esta comentadas.

  4. #4

    Padrão Re: Problemas com OSPFv2

    Citação Postado originalmente por m4d3 Ver Post
    MikroTik 5.12 e OSPF eu desaprovei, tive problemas ao fazer upgrade da 5.7 e 5.11 rodando OSPF, acabei voltando pra 5.11.

    Na 5.12 também tive problema com as queue types.
    Ta tranquilo pra rodar o OSPF na 5.11?



  5. #5

    Padrão Re: Problemas com OSPFv2

    eu ja venho com este problema desde a v. 5.11 foi quando percebi isto

  6. #6
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Problemas com OSPFv2

    Em ambas está rodando bem pelo menos nos meus clientes com exceção de 1 que apresentou muitos problemas mas como a RB está com BadBlock estou suspeitando disso conforme já dito num post respondido pelo Sérgio aqui no underlinux.



  7. #7

    Padrão Re: Problemas com OSPFv2

    Tambem vi este topico e acompanhei ele.
    Ja olhei todas RB´s e verifiquei se existe bad block em alguma que funcione o OSPF e nenhuma delas apresentou bad block

  8. #8

    Padrão Re: Problemas com OSPFv2

    Solucao encontrada ate o momento, cada RB que roda OSPFfica com Watchdog habilitado, pingando a interface loopback do roteador a frente, assim que ela perde a rota, ele reinicia e volta a funcionar



  9. #9

    Padrão Re: Problemas com OSPFv2

    Solucao definitiva, voltei todos os Mikrotik aqui para versao 4.17, acabou os problema

  10. #10

    Padrão Re: Problemas com OSPFv2

    Citação Postado originalmente por speedconnection Ver Post
    Solucao definitiva, voltei todos os Mikrotik aqui para versao 4.17, acabou os problema
    Boa noite Colega,

    Estou passando pelo mesmo problema, porém com a versão 5.24.
    Acabei de dar Downgrade para a 4.17, em ambas RBs, e amanhã posto um feedback também.

    Um abraço



  11. #11

    Padrão Re: Problemas com OSPFv2

    https://under-linux.org/customavatars/avatar58040_3.gif tskstar boa tarde deixa eu te pergunta depois q vc voltou para 4.17 ficou bom o ospf