+ Responder ao Tópico



  1. #1

    Padrão Integrar Load Ballance PCC ao Mikrotik

    Pessoal,


    Entendo muito pouco de Mikrotik, por isso gostaria de pedir a ajuda de vocês. Eu tenho um MK configurado com modem em bridge da velox e link de 8mb. Recentemente comprei um RB 750 e fiz um balance PCC nela vendo os tutoriais aki no fórum. O load tá funcionando tranquilo, porém eu não sei como integrá-lo ao meu servidor mikrotik. Alguém poderia me ajudar?


    Desde já agradeço a todos do fórum,


    Ronaldo

  2. #2

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Amigo,cria um DHCP Server no balançe e um DHCP Client no servidor MikroTik;é a maneira mais façil de fazer isso,uso assim aqui.



  3. #3

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Liga a porta wan do seu servidor na porta lan da sua rb configura o seu servidor na mesma classe de rede coloca o gateway do seu servidor o endereço da lan da rb muda o nat do pppoe-cliente para a sua porta wan e seja feliz

  4. #4

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Amigo,cria um DHCP Server no balançe e um DHCP Client no servidor MikroTik;é a maneira mais façil de fazer isso,uso assim aqui.
    Só não esquece mascarar a porta de entrada no seu servidor vai em IP FIWERALL NAT e faz um CHAIN = srcnat> OUT INTERFACE = porta de entrada>ACTION = masquerade, depois mascara a porta de saída do seu servidor do mesmo jeito



  5. #5

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Galera muito obrigado pelas informações, ajudou bastante e consegui fazer funcionar. Porém agora surgiu uma nova dúvida. Eu configurei o balance a partir de um tutorial aqui mesmo do fórum, não usei o programa PCC que o pessoal está disponibilizando. Então como foi feito tudo "manualmente", como meu minha RB vai balancear os links se ela não sabe o tamanho de cada um? Pq pelo que vi no aplicativo você informa pra ele a velocidade. Existe alguma forma de configurar isso na RB agora que já está tudo pronto?

    Abraço,

    Ronaldo

  6. #6

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Citação Postado originalmente por freitascs Ver Post
    Só não esquece mascarar a porta de entrada no seu servidor vai em IP FIWERALL NAT e faz um CHAIN = srcnat> OUT INTERFACE = porta de entrada>ACTION = masquerade, depois mascara a porta de saída do seu servidor do mesmo jeito
    É isso ai freitas,esqueci de falar do mascaramento!!!



  7. #7

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Citação Postado originalmente por ronaldoipm Ver Post
    Galera muito obrigado pelas informações, ajudou bastante e consegui fazer funcionar. Porém agora surgiu uma nova dúvida. Eu configurei o balance a partir de um tutorial aqui mesmo do fórum, não usei o programa PCC que o pessoal está disponibilizando. Então como foi feito tudo "manualmente", como meu minha RB vai balancear os links se ela não sabe o tamanho de cada um? Pq pelo que vi no aplicativo você informa pra ele a velocidade. Existe alguma forma de configurar isso na RB agora que já está tudo pronto?

    Abraço,

    Ronaldo
    Olha amigo,nao informar o tamanho do link exatamente,mas vc tem que fazer o equilibrio cargas,supondo que vc tem ai 3 links de 2 Megas cada,vc vai fazer assim lá em Ip firewall Mangle

    disabled=no dst-address-type=!local new-connection-mark=IPS1_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=policy_router comment="" disabled=no \
    dst-address-type=!local new-connection-mark=ISP2_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=policy_router comment="" disabled=no \
    dst-address-type=!local new-connection-mark=ISP3_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/2

    Explicando:O Nº 3 indica que vc tem 3 both-addresses no balançe,1 prá cada link,já o 0 na frente do 3 é o seu 1º link(ISP1) assim por diante...Mas se o seu ISP3 fosse de 5 Megas por exemplo,vc teria que trocar o 3 pelo 4 e add uma 4º regra,prq ai vc taria dando mais um both-addresses para seu link de 5 Megas,ficando assim a 4º regra

    add action=mark-connection chain=policy_router comment="" disabled=no \
    dst-address-type=!local new-connection-mark=ISP3_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/3

  8. #8

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Oi, aproveitando o topico, gostaria de uma ajuda.
    Eu tenho 2 links de 2 megas.
    como ficaria o meu /ip firewall mangle ?
    Grato



  9. #9

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    as minhas refras de ip firewall mangle, por favor deem uma olhada e me ajudem.
    Tenho 2 links de 2 megas

    /ip firewall mangle
    add action=mark-connection chain=input comment=EthLinkA_conn \
    connection-state=new disabled=no in-interface=ether1-elo \
    new-connection-mark=EthLinkA_conn passthrough=yes
    add action=mark-connection chain=input comment=EthLinkB_conn \
    connection-state=new disabled=no in-interface=ether4-link2 \
    new-connection-mark=EthLinkB_conn passthrough=yes
    add action=mark-routing chain=output comment=to_EthLinkA connection-mark=\
    EthLinkA_conn connection-state=new disabled=no new-routing-mark=\
    to_EthLinkA passthrough=no
    add action=mark-routing chain=output comment=to_EthLinkB connection-mark=\
    EthLinkB_conn connection-state=new disabled=no new-routing-mark=\
    to_EthLinkB passthrough=no
    add action=accept chain=prerouting comment="out load DST" disabled=no \
    dst-address-list=loopback in-interface=ether3-ap
    add action=mark-connection chain=prerouting comment=EthLinkA_conn disabled=no \
    dst-address-type=!local in-interface=ether1-elo new-connection-mark=\
    EthLinkA_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/0
    add action=mark-connection chain=prerouting comment=EthLinkA_conn disabled=no \
    dst-address-type=!local in-interface=ether1-elo new-connection-mark=\
    EthLinkA_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/1
    add action=mark-connection chain=prerouting comment=EthLinkA_conn disabled=no \
    dst-address-type=!local in-interface=ether1-elo new-connection-mark=\
    EthLinkA_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/2
    add action=mark-connection chain=prerouting comment=EthLinkA_conn disabled=no \
    dst-address-type=!local in-interface=ether1-elo new-connection-mark=\
    EthLinkA_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/3
    add action=mark-connection chain=prerouting comment=EthLinkB_conn disabled=no \
    dst-address-type=!local in-interface=ether4-link2 new-connection-mark=\
    EthLinkB_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/4
    add action=mark-routing chain=prerouting comment=to_EthLinkA connection-mark=\
    EthLinkA_conn disabled=no in-interface=ether1-elo new-routing-mark=\
    to_EthLinkA passthrough=no
    add action=mark-routing chain=prerouting comment=to_EthLinkB connection-mark=\
    EthLinkB_conn disabled=no in-interface=ether4-link2 new-routing-mark=\
    to_EthLinkB passthrough=no

  10. #10

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Pessoal, pegando carona no post, estou com um problema parecido, tenho um balance numa RB493ah e, comprei uma RB1100, configurei o balance nela e ficou igual ao da 493, porém quando conecto ao MK não navega, chego a acessar o MK passando por ela mas não abre página, uma pessoa disse que é problema de BIOS, porém não me deu detalhes, se alguém poder ajudar ficarei muito grato.

    Em tempo, fora do MK navega normal.



  11. #11

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Caro Nisantos problema de BIOS é esculacho eles dizerem isso, o problema ai com certeza deve ser configuração do loadbalance ou mascaramento da entrada e saída da internet no seu Mikrotik depois do loadbalance pois se você tem acesso normal pelo winbox é problema de configuração mesmo,

    Uma dica se por acaso você pegou backup de outra RB e jogou em uma nova achando que vai funcionar não vai não não mesmo que seja igual você terá que acertar as portas ether e outras coisas isso aconteceu aqui comigo tinha um loadbalance de 4 links numa RB450 joguei o Backup em uma RB450G não funcionou de cara tive que acertar configurações das portas ether e outras coisinhas pois ficaram tudo em vermelho depois que só acertei as configurações pronto tudo ficou 100%.

  12. #12

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    freitascs, realmente peguei o backup da 493, porém fiz esses acertos e colocando os ADSLs ficam normais, todos conectam e ficam link ok e navegando pela porta de saída.
    Obrigado pela atenção.



  13. #13

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Mas já conseguiu resolver o seu problema ?
    Seu problema está quando você joga a internet para o seu Servidor MK ?

  14. #14

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Ainda não, estou tentando rsrsrs,
    isso mesmo, terminei de fazer esses acertos, naveguei tranquilamente do note pelo balance, mas quando jogo p o servidor MK nao navega, porém acesso ele.



  15. #15

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Amigo vai esses 4 passos ai que vai funcionar só modifica das minhas configurações os IPs e DNS use os seus ai, se não funcionar instala um TeamViewer ai que eu faço configuração valeu.

    Clique na imagem para uma versão maior

Nome:	         Passo 1.jpg
Visualizações:	178
Tamanho: 	27,0 KB
ID:      	33427Clique na imagem para uma versão maior

Nome:	         Passo 2.jpg
Visualizações:	161
Tamanho: 	41,8 KB
ID:      	33428Clique na imagem para uma versão maior

Nome:	         Passo 3.jpg
Visualizações:	158
Tamanho: 	23,3 KB
ID:      	33429Clique na imagem para uma versão maior

Nome:	         Passo 4.jpg
Visualizações:	156
Tamanho: 	30,3 KB
ID:      	33430

  16. #16

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    ID 179 220 409
    Senha 6260



  17. #17

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    add ai MSN
    [email protected]

  18. #18

    Padrão Re: Integrar Load Ballance PCC ao Mikrotik

    Citação Postado originalmente por ronaldoipm Ver Post
    Pessoal,


    Entendo muito pouco de Mikrotik, por isso gostaria de pedir a ajuda de vocês. Eu tenho um MK configurado com modem em bridge da velox e link de 8mb. Recentemente comprei um RB 750 e fiz um balance PCC nela vendo os tutoriais aki no fórum. O load tá funcionando tranquilo, porém eu não sei como integrá-lo ao meu servidor mikrotik. Alguém poderia me ajudar?


    Desde já agradeço a todos do fórum,


    Ronaldo

    Tive esse problema, meu mikrotik serve não integrava por IP > DHCP Cliente, mais foi apenas de forma manual, como vou mostrar abaixo:

    Load Balance estava assim
    IP > Addresses
    Com o Address 192.168.88.1/30

    Então para integrar fiz o seguindo no meu Mikrotik Serve

    Fiz o seguinte:IP > Addresses > Add
    Adicionando o ip 192.168.88.2/30 em Address.

    Depois em
    IP > Routes > Add
    Adicionando apenas o Gateway 192.168.88.1

    pronto funcionou