Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Boa tarde,

    Cara, ficou muito ruim de entender a rede com esses enlaces em "raio", usa uma linha normal para fazer as ligações =))

    Bom, como sua rede é toda em bridge, fica mais fácil usar vlans, mas sugiro você iniciar um projeto para roteamento.

    No seu servidor, você cria uma vlan na placa que manda o link para frente, digamos que seja VLAN 100. No próximo roteador, você cria uma vlan na interface bridge e coloca o mesmo ID, e assim por diante até chegar no cliente.

    No seu roteador central, você coloca a rede que quiser na VLAN, e ela vai "sair" lá no cliente. Para remover a vlan e entregar a rede pura no cliente, se for na SXT mesmo como você dise, você NÃO coloca a wlan e a ether na mesma bridge. Vai criar a vlan com a interface wlan1 e colocar em uma bridge com a ether1, assim os pacotes "tageados" que entrar na wlan, serão removidos na ether. Se você escanear do cliente, verá apenas o servidor.

    Faça uns testes em bancada e vamos tirando as dúvidas.

    Abraço e boa sorte com os testes.
    Última edição por gamineiro; 26-06-2013 às 08:47.

  2. #22

    Padrão Re: Vlan entre 2 Routerboard

    Boa noite amigo vou retirar os "raios" e vou postar a foto denovo ate que gostaria de colocar a rede roteada mais nao sei por onde começar tenho duvidas ou melhor varias duvidas uma delas seria meus clientes recebem ip por dhcp eles continuaram receber ip por dhcp na rede roteada uso hotspot com radius "mk-auth" vai continuar normalmente desde ja agradeço a atençao
    tenho 2 sxt e rb 450 g aki em casa vou fazer um laboratorio com as vlans mais vou amadureçer a ideia de colocar a rede roteada
    Clique na imagem para uma versão maior

Nome:	         the dude.jpg
Visualizações:	116
Tamanho: 	35,1 KB
ID:      	34954
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         the dude.jpg
Visualizações:	102
Tamanho: 	35,3 KB
ID:      	34953  



  3. #23

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por gamineiro Ver Post
    Boa tarde,

    Cara, ficou muito ruim de entender a rede com esses enlaces em "raio", usa uma linha normal para fazer as ligações =))

    Bom, como sua rede é toda em bridge, fica mais fácil usar vlans, mas sugiro você iniciar um projeto para roteamento.

    No seu servidor, você cria uma vlan na placa que manda o link para frente, digamos que seja VLAN 100. No próximo roteador, você criar uma vlan na interface bridge e coloca o mesmo ID, e assim por diante até chegar no cliente.

    No seu roteador central, você coloca a rede que quiser na VLAN, e ela vai "sair" lá no cliente. Para remover a vlan e entregar a rede pura no cliente, se for na SXT mesmo como você dise, você NÃO coloca a wlan e a ether na mesma bridge. Vai criar a vlan com a interface wlan1 e colocar em uma bridge com a ether1, assim os pacotes "tageados" que entrar na wlan, serão removidos na ether. Se você escanear do cliente, verá apenas o servidor.

    Faça uns testes em bancada e vamos tirando as dúvidas.

    Abraço e boa sorte com os testes.
    Ola amigo fiz oque vc falou mais mesmo assim ainda dou um scan e vejo os mikrotik "sxt" teria comovc meesplicar comocoloco minha rede roteada uso hotspot e dhcp

  4. #24

    Padrão Re: Vlan entre 2 Routerboard

    Boa noite pessoal,

    Usando uma RB 450 e uma 750, fiz as configurações conforme acima descritas e não obtive sucesso isso em bancada. A minha rede é toda sem fio e em bridge e queria mudar pra vlan. Segue anexo print das conf das duas rbs. Desde já agradeço a todos.
    Miniaturas de Anexos Miniaturas de Anexos VLAN NETRE 02 RBS.pdf  



  5. #25
    Correndo atrás... Avatar de Leonardo
    Ingresso
    Aug 2009
    Localização
    Próx. a Brasília
    Posts
    152

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por portalink Ver Post
    Boa noite pessoal,

    Usando uma RB 450 e uma 750, fiz as configurações conforme acima descritas e não obtive sucesso isso em bancada. A minha rede é toda sem fio e em bridge e queria mudar pra vlan. Segue anexo print das conf das duas rbs. Desde já agradeço a todos.
    amigo, aqui consegui assim, cria uma bridge e coloca a interface da vlan como sendo da bridge, e adciona a ether na bridge

  6. #26

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por gamineiro Ver Post
    Boa dia amigo,

    Se a internet entra "pura, sem vlan" na ether1 da RB1, você não pode criar uma VLAN na ether1, já que os pacotes chegam sem VLAN.

    Faça assim,

    Na RB1:
    Crie a VLAN-23, com ID 23 e interface ether2
    Crie a BRIDGE-VLAN23 e coloque a ether1 e a VLAN-23

    Ligue o cabo na ether2 da RB1 até a ether1 da RB2.

    Na RB2:
    Crie a VLAN-23, com ID 23 e interface ether1
    Crie a BRIDGE-VLAN23 e coloque a ether2 e a VLAN-23

    Agora você terá o mesmo sinal que entra na ether1 da RB1 saindo na ether2 da RB2, sendo transportado por uma VLAN.

    Esse exemplo é para um transporte em bridge, caso queira com roteamento é só remover as bridges e setar os IPs na interfaces.

    Abraço
    o trafego não passa pela vlan
    passa direto pela bridge, então a vlan não esta funcionando
    pelo menos nos testes que realizei aqui



  7. #27
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por portalink Ver Post
    Boa noite pessoal,

    Usando uma RB 450 e uma 750, fiz as configurações conforme acima descritas e não obtive sucesso isso em bancada. A minha rede é toda sem fio e em bridge e queria mudar pra vlan. Segue anexo print das conf das duas rbs. Desde já agradeço a todos.
    Bom dia,

    Não sei porque não recebi avisos sobre novos posts nesse tópico. Peço desculpa por não ter visto as respostas.
    Sua configuração está "quase" correta.

    Na primeira RB, como a VLAN está atrelada a ether2, você não pode colocar um IP da mesma rede que as interfaces que compõem a bridge. Então REMOVA o ip da ether2.

    Na segunda RB, Você está usando apenas uma ether. Você criou a VLAN na ether1 e depois colocou a VLAN e a ether1 na mesma bridge, não funciona dessa forma. Tome isso como regra "Uma interface que possui VLAN NÃO pode fazer parte de nenhuma bridge"

    Então, use a ether2 para fazer parte da bridge com a VLAN. Tudo que você colocar na ether1 na PRIMEIRA RB, irá sair na ether2 da SEGUNDA RB. Os pacotes irão entrar SEM TAG, serão transportados entre as RBs COM TAG, e serão entregues na ether2 da segunda RB SEM TAG.

    Vamos falando,

    Abraço

  8. #28
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Você criou a VLAN na ether1 e depois colocou a VLAN e a ether1 na mesma bridge, não funciona dessa forma. Tome isso como regra "Uma interface que possui VLAN NÃO pode fazer parte de nenhuma bridge"
    Pessoal, seguindo a dica do amigo @trober, para que fique mais claro essa afirmação.

    "Você não pode adicionar uma interface física que possui VLAN em uma bridge, MAS pode criar uma VLAN a partir de uma BRIDGE."

    EX.:

    Digamos que a ether1 faça parte da bridge WAN

    Você NÃO pode criar uma VLAN assim:

    Código :
    /interface vlan add name=vlan1 vlan-id=100 interface=ether1

    Mas pode criar a vlan a partir da bridge:

    Código :
    /interface vlan add name=vlan1 vlan-id=100 interface=WAN

    Espero ter ajudado.

    Abraço a todos.



  9. #29

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por gamineiro Ver Post
    Bom dia,

    Pergunte aqui mesmo, talvez mais alguém tenha a mesma dúvida.

    Abraço

    Caro Gamineiro, consegui fazer as vlans funcionarem 100% no meu servidor eu criei as vlans e enviei a torre na rb eu criei uma vlan para cada porta de saida, assim monitoro cada bairro separadamente, só fiquei com um problema, não consigo acessar as minhas nanoloco dos clientes e nem as rockets das torres, pois as vlans não deixam acessar, há alguma coisa que possa fazer para que possa acessar estas antena dos clientes ?? Atenciosamente ... Rodrigo

  10. #30

    Padrão Re: Vlan entre 2 Routerboard

    Show de bola o tópico...

    É basicamente o que perguntei em outro tópico aqui mas acabei sem resposta...

    Vou ver se implemento aqui...só que no meu caso vão ser 3 rbs

    rb1
    recebendo 2 links e repassando para a rb2 mas deixando um "retorno" do servidor para venda de internet no local

    rb2
    recebendo a vlan com os 2 links da rb1 + 1 link dedicado
    recebendo 1 vlan de "retorno" de link do servidor

    rb3
    recebendo a vlan da rb2 e repassando os links separadamente para meu gerenciamento
    jogando o "retorno" de link em uma vlan repassando para rb2 e rb1



  11. #31
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por agatangelos Ver Post
    Caro Gamineiro, consegui fazer as vlans funcionarem 100% no meu servidor eu criei as vlans e enviei a torre na rb eu criei uma vlan para cada porta de saida, assim monitoro cada bairro separadamente, só fiquei com um problema, não consigo acessar as minhas nanoloco dos clientes e nem as rockets das torres, pois as vlans não deixam acessar, há alguma coisa que possa fazer para que possa acessar estas antena dos clientes ?? Atenciosamente ... Rodrigo
    Bom dia,

    Mande-nos a topologia que você está usando, bem como a forma como as VLANs estão configuradas (na interface ou na bridge?).

    Assim fica mais fácil ajudar.

    Abraço

  12. #32

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por gamineiro Ver Post
    Bom dia,

    Mande-nos a topologia que você está usando, bem como a forma como as VLANs estão configuradas (na interface ou na bridge?).

    Assim fica mais fácil ajudar.

    Abraço

    Caro gamineiro, eu uso em meu servidor um PC com mikrotik, autenticando via radius em pppoe com MK-AUTH, uso somente um concentrador os enlaces são todos com equipamentos ubiquit em bridge WDS, do meu servidor alimenta a minha torre principal e dela distribuo para mais 3 torres e na rua via cabo aqui no centro, estou chegando a um volume de clientes que o broadcast já esta ficando alto e quero por em cada torre uma rb e em cada porta as antenas de distribuição para que possa monitorar o trafego de cada antena de cada bairro, já criei as vlans na INTERFACE ether4 que é onde sai os clientes, pois não tenho bridge no meu servidor a rede é roteada por interface, criei um servidor pppoe para cada vlan, e criei as vlans "com tag" direcionando cada uma para uma determinada porta da RB que esta na torre, na RB da torre criei uma bridge para cada porta e adicionai nela a vlan correspondente a ela, tudo já esta a um mês funcionando 100% porém não consigo acessar as antenas ubiquiti (nano loco, nano bridge, rocket etc.) que estão depois das vlans, os equipamentos UBNT estão na classe 192.168.100.0/24 e a interface de saída esta como 10.3.0.0/24, porém a vlan que sai para aonde preciso acessar as antenas esta com o ip 192.168.100.100/24 também mas não funciona, já passei as antenas para a classe 10.3.0.0/24 mas também não acessei elas, eu gostaria de por toda a minha rede desta forma, pois gostei do desempenho com as vlans, e de saber o controle de cada bairro e antena separado, e vou por na rua também nos principais entroncamentos, para saber se até ali o trafego esta chegando já ara servir como monitor e tirar os gargalos da rede ... um grande abraço ... Rodrigo

    /ip address
    add address=172.31.255.1/30 comment=MK-AUTH disabled=no interface=ether3 network=172.31.255.0
    add address=10.3.0.1/24 comment=pgcorte disabled=no interface=ether4 network=10.3.0.0
    add address=10.255.10.253/30 comment=LINK disabled=no interface=ether2 network=10.255.10.252
    add address=192.168.2.1/24 comment=CACHE disabled=no interface=ether1 network=192.168.2.0
    add address=10.10.3.254/24 disabled=yes interface=ether2 network=10.10.3.0
    add address=10.10.11.1/30 comment=Vlan disabled=no interface=vlan_JMeudon network=10.10.11.0
    add address=192.168.100.100/24 disabled=no interface=vlan_Barra network=192.168.100.0
    add address=10.10.13.1/30 disabled=no interface=vlan_Varzea5.8 network=10.10.13.0
    add address=10.10.14.1/30 disabled=no interface=vlan_Artistas network=10.10.14.0



  13. #33
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Amigo, boa tarde.

    Continua muito difícil entender, tem como você fazer um desenho? Se possível mande as telas de configuração das interfaces e IPs.

    Abraço

  14. #34

    Padrão Re: Vlan entre 2 Routerboard

    Citação Postado originalmente por gamineiro Ver Post
    Amigo, boa tarde.

    Continua muito difícil entender, tem como você fazer um desenho? Se possível mande as telas de configuração das interfaces e IPs.

    Abraço
    segue as telas do pc que envia Clique na imagem para uma versão maior

Nome:	         vlan.jpg
Visualizações:	131
Tamanho: 	49,2 KB
ID:      	46665Clique na imagem para uma versão maior

Nome:	         vlan2.jpg
Visualizações:	121
Tamanho: 	80,1 KB
ID:      	46666Clique na imagem para uma versão maior

Nome:	         vlan3.jpg
Visualizações:	103
Tamanho: 	56,1 KB
ID:      	46667


    rb que recebe Clique na imagem para uma versão maior

Nome:	         vlan_rb_recebe.jpg
Visualizações:	111
Tamanho: 	62,8 KB
ID:      	46668Clique na imagem para uma versão maior

Nome:	         vlan_rb_recebe2.jpg
Visualizações:	103
Tamanho: 	99,1 KB
ID:      	46669Clique na imagem para uma versão maior

Nome:	         vlan_rb_recebe3.jpg
Visualizações:	88
Tamanho: 	33,8 KB
ID:      	46670Clique na imagem para uma versão maior

Nome:	         vlan_rb_recebe4.jpg
Visualizações:	79
Tamanho: 	43,9 KB
ID:      	46671



  15. #35
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Vlan entre 2 Routerboard

    Boa tarde,

    Está tudo correto. Eu tentaria atualizar as RBs para a mesma versão, visto que uma está com a 5.4 e a outra na 5.18.

    Vamos falando para resolver logo o seu problema.

    Abraço

  16. #36

    Padrão Re: Vlan entre 2 Routerboard

    E ai pessoal, boa noite.

    Depois de uns tempos parado em relação a vlan, comecei na semana passada e como o meu tempo é curto, toda noite faço um pouco, até ontem eu não tinha conseguido fazer funcionar uma conexão saindo do provedor passando por três repetições e chegando na minha residencia sendo que toda a minha rede está em bridge. Bom como tinha dito acima eu tava usando 02 rbs 750, mas quando recomecei achei de colocar uma 450, não sei se ela ta com defeito ou o que foi. Hoje coloquei as duas rbs 750, como eu já havia testado varias configurações e tomado atentado para as regras que o Gabriel Mineiro possou.

    Na rb que ta no provedor a internet entra na ether1 vindo do switch sem vlan. Na ether2 criei a vlan e adicionei esta vlan à bridge juntamente com a ether1 (veja as regras que o Gabriel passou).

    Na outra rb que está na minha residencia criei a vlan na ether1 é a que recebe a internet e coloquei esta vlan na bridge juntamente com a ether2, onde liguei o meu notbok.

    Um detalhe importante pra mim aqui foi mesmo com a configuração acima ainda não funcionava a internet ai marquei na interface vlan USE SERVICE TAG, rapaz foi na hora funcionou, não sei se isto é regra mas aqui ta assim.

    To fazendo mais testes qualquer outras novidades eu posto aqui.

    Att

    Aparecido



  17. #37

    Padrão Re: Vlan entre 2 Routerboard

    Otimo tópico, vem a duvida, é possível fazer roteamento OSPF em cima das vlans ?

    Só para informa consegui fazer o Roteamento Ospf em cima das vlans.
    Última edição por rafaeldsv; 23-07-2013 às 09:21.

  18. #38

    Padrão Re: Vlan entre 2 Routerboard

    Olá pessoal.

    Agora to tentando colocar uma terceira rb na rede, neste caso, na rb que ta no provedor vou criar uma segunda vlan na porta 02 que ja tem a vlan1 ou na ether 3 da rb? Posso criar mais de uma vlan nas mesma porta ether?

    Desde já agradeço a todos



  19. #39

    Padrão Re: Vlan entre 2 Routerboard

    boa tarde pessoal estou com o seguinte problema

    segue o link com o cenario, eu consiguo resolver isso com vlan ?

    https://under-linux.org/showthread.php?t=16695

  20. #40

    Padrão Re: Vlan entre 2 Routerboard

    O link esta quebrado.