+ Responder ao Tópico



  1. #1

    Lightbulb Dois links de entrada com dois gatways diferentes

    Pessoal, ja li muitas coisas neste forum, porém n consegui resolver meu problema. Eu fiz uma coisa super simples, deixei meus 2 modems roteados, e fiz na rb duas bridges, trabalhei com as duas bridges pra separar os links de internet. Quando eu conecto na bridge 1 a internet vai até bem, mas quando conecto na bridge 2 fica um lixo. Ja inverti os modems, mas continua sempre lento a bridge 2. Isso é somente um teste com modems roteados, o que eu quero é modem em bridge, e rb discando. Alguém tem alguma solução para 2 links de entrada, com duas saídas distintas na mesma rb sem lentidão?. ""NÃO QUERO PCC"". Desde ja obrigado a quem me ajudar.

  2. #2

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Não entendi. Uma hora você disse modem roteado, outra, modem em bridge. O que você precisa exatamente?



  3. #3

    Padrão Re: Dois links de entrada com dois gatways diferentes

    veja aqui no fórum tópico balanço por rota ,,é ótimo e não tem os erros do pcc e vc pode tem quantos link conseguir por em sr servidor e fazer as saídas individual por clientes e rotas diferente eu uso e é simples e eficiente,,

  4. #4
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Amigo da uma olhada neste site um companheiro do forum postou em um topico similar Políticas de roteamento e Configurando rotas no roteador MikroTik



  5. #5

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Então Demattos eu li a página, mas eu não consegui resolver meu problema. Vou explicar o que eu quero, se puderem me ajudar agradeço. farei duas conexões PPPoE, um link de de 5 megas entrará na ether1 e outro de 5 megas na ether2. Quero que o link1 saia pela wlan1, e quero que o link2 saia pra wlan2. isso é possível?, se é qual regra tenho q fazer?. Não quero PCC, quero links compeltamente separados.
    Última edição por SalvadorDanczuk; 16-04-2012 às 02:49.

  6. #6
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Bom dia,

    Você quer "extrair" a internet desa RB para outra porta que não seja a wlan1 e a wlan2? Digo isso porque se queres apenas direcionar a internet para as wireless, poderia deixar o modem roteando e criar as bridges independentes.

    BRIDGE1 = Ether1 + wlan1
    BRIDGE2 = Ether2 + wlan2

    Vamos falando, abraço



  7. #7

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Sim, quero que o modem 1 alimente a wlan1 e o modem 2 alimente a wlan2. Em bridge até da certo, o problema é que na hora de controlar a banda ip x mac não funciona.

  8. #8
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Então, vamos fazer um teste.

    Modem1 = 10.0.1.254/24
    eth1 = 10.0.1.1/24
    wlan1 = 192.168.1.254/24

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 out-interface=ether1 action=masquerade


    Modem2 = 10.0.2.254/24
    eth2 = 10.0.2.1/24
    wlan2 = 192.168.2.254/24

    /ip firewall nat add chain=srcnat src-address=192.168.2.0/24 out-interface=ether2 action=masquerade

    Agora o truque.

    /ip route add gateway=10.0.1.254 comment="Modem1" routing-mark=Modem1

    /ip route add gateway=10.0.2.254 comment="Modem2" routing-mark=Modem2

    /ip route rule add src-address=192.168.1.0/24 action=lookup table=Modem1
    /ip route rule add src-address=192.168.2.0/24 action=lookup table=Modem2



    Não conferi os comandos para saber se são exatamente assim, mas não deve mudar muito.

    O que fazemos aqui é criar um NAT simples para cada rede. Depois criamos gateways com tables de roteamento direfentes (routing-mark).
    Depois em Rules, dizemos que cada rede deve usar a sua tabela.

    Nunca teste isso usando NAT, mas se não funcionar, precisamos apenas criar 2 regras de magle para cada rede.

    Testa ai e vamos falando,

    Abraço



  9. #9

    Padrão Re: Dois links de entrada com dois gatways diferentes

    vou conferir e posterei o resultado, obrigado gamineiro pelo interesse em ajudar.

  10. #10

    Padrão Re: Dois links de entrada com dois gatways diferentes

    Citação Postado originalmente por SalvadorDanczuk Ver Post
    vou conferir e posterei o resultado, obrigado gamineiro pelo interesse em ajudar.
    tenho uma duvida e se o modem1 parar tem como direcionar tudo para o modem2 de forma automatica?
    E quando o modem1 voltar a rota voltará para o modem1 ?