Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão Re: Ospf Dando Erro

    Trober, obrigado novamente li o seu outro tópico e intendi, atualizei todos os meus routers para 5.20 ospf funcionando 100% com 5 routers, agora vem outro passo vou fazer os enlaces com AirgridsM5 em bancada para testar, vou atualizar para v5.5.2, vem uma duvida, nesses equips que vai ser feito o enlace, tenho que colocar em network router ou ip static na AirgridsM5 e fazer uma classe de ip /30 para interliga esses enlaces com a rbs? preciso depois colocar o network dessa classe em ospf network, esses enlaces faço como station ou station wds, vou fazer todos os testes possíveis queria só um esclarecimento pois vc ja tem amplo conhecimento. Obrigado novamente. Mais uma duvida no ospf exemplo, minha infraestrutura torres etc, tem mais de 25 pops posso fazer todos esses pops dentro da Area backbone, atualmente trabalho com route static.

  2. #42

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por rafaeldsv Ver Post
    Trober, obrigado novamente li o seu outro tópico e intendi, atualizei todos os meus routers para 5.20 ospf funcionando 100% com 5 routers
    Que bom. Fico feliz com a notícia

    Citação Postado originalmente por rafaeldsv Ver Post
    vem uma duvida, nesses equips que vai ser feito o enlace, tenho que colocar em network router ou ip static na AirgridsM5 e fazer uma classe de ip /30 para interliga esses enlaces com a rbs?
    Se você usar /30, não terá acesso aos Ubiquiti AirGrid. Use um /29

    Citação Postado originalmente por rafaeldsv Ver Post
    Mais uma duvida no ospf exemplo, minha infraestrutura torres etc, tem mais de 25 pops posso fazer todos esses pops dentro da Area backbone, atualmente trabalho com route static.
    Depende, há casos que até 50 roteadores é possível trabalhar com uma só área (backbone). Mas há casos em que com menos de 12 roteadores, foi necessário trabalhar com três áreas. Não tem uma fórmula pronta.

    Citação Postado originalmente por rafaeldsv Ver Post
    Obrigado novamente.
    Espero ter ajudado.

    Saudações,

    Trober



  3. #43

    Padrão Re: Ospf Dando Erro

    Trober, mais uma vez obrigado, criei outra areá area1 e coloquei mais 3 routers/rb nessa area e o mesmo funcionou perfeitamente, em cada rb/routers configurei o pppoe com autenticação radius para meu servidor e o mesmo funcionou sem nem um problema todos funcionando com autenticação e controle de banda, agora vou para seguinte passo fazer esses enlaces com equipamentos ubnt obrigado deis de já. lembrando estou com 8 routers/rb v5.20 com duas areas funcionando o pppoe + radius sem problema algum em laboratório, vou fica monitorando.

  4. #44

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por rafaeldsv Ver Post
    criei outra areá area1 e coloquei mais 3 routers/rb nessa area e o mesmo funcionou perfeitamente, em cada rb/routers configurei o pppoe com autenticação radius para meu servidor e o mesmo funcionou sem nem um problema todos funcionando com autenticação e controle de banda, agora vou para seguinte passo fazer esses enlaces com equipamentos ubnt obrigado deis de já. lembrando estou com 8 routers/rb v5.20 com duas areas funcionando o pppoe + radius sem problema algum em laboratório, vou fica monitorando.
    Fique atento para não distribuir "/32" dos clientes PPPoE. Dos anúncios "/32", somente os loopbacks devem transitar. Faça sumarização das rotas.

    Também fique atento ao uso[1] de RADIUS e OSPF, quanto ao source address

    Talvez alguém diga que não tem problema, numa rede pequena (até 2000 clientes). Imagina que monstruoso seria ter, na sua rede de médio porte, algumas ~9000 rotas /32 "anunciadas de lá para cá". Se você tem a chance de fazer desde agora o certo, não hesite.

    Se bem que quando chegar ao porte de uma rede média (entre 2000-20000 hosts), o OSPF será meramente para anúncio de loopbacks para o MPLS

    [1] https://under-linux.org/f343/problem...61/#post613731

    Saudações,

    Trober
    Última edição por trober; 02-10-2012 às 12:48. Razão: Correção gramatical e adendos



  5. #45
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por trober Ver Post
    Depende, há casos que até 50 roteadores é possível trabalhar com uma só área (backbone). Mas há casos em que com menos de 12 roteadores, foi necessário trabalhar com três áreas. Não tem uma fórmula pronta.
    Saudações amigo,

    Estive conversando com um administrador de uma operadora nacional esses dias, falando justamente sobre a necessidade de uso de outras áreas. A resposta dele era que antigamente a CPU dos roteadores era limitada, então quanto mais LSA's na área, mais a CPU era consumida, tendo que ser divida ainda entre outros serviços, como o BGP.

    Hoje em dia temos acesso a roteadores com maior capacidade de processamento, permitindo um número maior de roteadores (LSA's) por área.

    Para ter uma idéa do quão maior pode ser esse número, a rede dessa operadora toma dimensões nacionais utilizando a mesma área.

    Esse exemplo vai contra o propósito da topologia sugerida para o uso de OSPF, cada rede tem sua particularidade e dimensão, cabe a cada uma avaliar o melhor para sua administração e "saúde" da rede.

    Acho esse assunto interessante para debatermos, visto que cada vez mais os administradores estão aderindo ao roteamento interno dinâmico (IGP).

    Um abraço a todos, obrigado especial ao Trober, "Comandante do tópico" o/

  6. #46

    Padrão Re: Ospf Dando Erro

    Amigo, trober e amigo gamineiro gostaria que vocês explica-sem com maiores detalhes a sumarização de rotas, pois gostaria de entender melhor o assunto...



  7. #47

    Padrão Re: Ospf Dando Erro

    Crio uma rota estatica com a network apontando para a interface loopback e paro de anunciar as rotas conectadas no PPPoE é só isso ou tem mais?

    Citação Postado originalmente por allac Ver Post
    Amigo, trober e amigo gamineiro gostaria que vocês explica-sem com maiores detalhes a sumarização de rotas, pois gostaria de entender melhor o assunto...

  8. #48

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por allac Ver Post
    Amigo, trober e amigo gamineiro gostaria que vocês explica-sem com maiores detalhes a sumarização de rotas, pois gostaria de entender melhor o assunto...
    Oi Allan.

    A sumarização é um processo de agregação de segmentos de redes. Por exemplo, dentro de uma rede /24, cabem 8 redes /27. Se todas as rotas estão atrás do mesmo destino/roteador, essas 8 rotas /27 podem ser 'condensadas' num único /24.

    No MikroTik RouterOS, você faz a sumarização em 'Area Ranges', uma vez que não[1] está contemplada a auto-sumarização no RFC2328.

    A auto-sumarização em OSPF é uma característica de implementações proprietários do protocolo, como no caso da Cisco.

    [1] https://under-linux.org/f343/sumariz...29/#post631942
    [2] http://www.ietf.org/rfc/rfc2328.txt

    Saudações,

    Trober



  9. #49

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por allac Ver Post
    Crio uma rota estatica com a network apontando para a interface loopback e paro de anunciar as rotas conectadas no PPPoE é só isso ou tem mais?
    Rota estática? Apontar para interface loopback? Não precisa disso. O que você precisa está previsto no Wiki[1] da MikroTik, inclusive com sumarização.

    Aproveitando, acertou sua rede aí?

    [1] http://wiki.mikrotik.com/wiki/OSPF_and_PPPoE_Setup

    Saudações,

    Trober

  10. #50

    Padrão Re: Ospf Dando Erro

    Trober, pesquisei sobre sumarização, intendi um pouco mas vem a duvida eu tenho que faze a sumarização
    de quais ips, loopback? os ips que faz a conexão entre as rbs? Exemplo de sua topologia
    temos a rtr-a que tem o ip 172.17.1.1/30 que faz comunicação com a rtr-b que tem o ip 172.17.1.2/30
    estão conectadas pela ether1, vem a questão faço a sumarização desses ips mas vou abranger todos
    os ips dessa classe 172.17.x.x, de todas as outras RBS no seguimento dessa topologia?. Deu para entender rsrs?
    Mais uma coisa essa sumarização faço em Area Ranges como vc disse, então em Network no ospf onde eu coloquei já esse ip que faz a comunicação da rb rtr-a com a rtr-b 172.17.1.0/30 ainda continua?.

    Só para concluir abaixo todos os ips dessa topologia.

    172.17.1.0/30 rtr-a / rtr-b
    172.17.2.0/30 rtr-b / rtr-c
    172.17.3.0/30 rtr-c / rtr-d
    172.17.4.0/30 rtr-d / rtr-a


    Acima os ips que faz a comunicação entre as RBS, faço a sumarização deles?
    A loopback preciso fazer algo?
    E os ips privado que irão para os cliente no caso esses 10.5.255.0/24 nesse ñ precisa fazer sumarização, tudo isso um exemplo

    Eu agradeço pela ajuda que vc esta nos dando.

    Obrigado.



  11. #51
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Ospf Dando Erro

    Citação Postado originalmente por allac Ver Post
    Amigo, trober e amigo gamineiro gostaria que vocês explica-sem com maiores detalhes a sumarização de rotas, pois gostaria de entender melhor o assunto...
    Bom dia,

    Apenas acrescentando a explicação do Trober, a sumarização de rotas deve ser feita em ABR's (Roteadores de Borda de Área), preferencialmente na borda com a área 0 (backbone).

    Abraço

  12. #52

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por rafaeldsv Ver Post
    Trober, pesquisei sobre sumarização, intendi um pouco mas vem a duvida eu tenho que faze a sumarização
    de quais ips, loopback? os ips que faz a conexão entre as rbs? Exemplo de sua topologia
    temos a rtr-a que tem o ip 172.17.1.1/30 que faz comunicação com a rtr-b que tem o ip 172.17.1.2/30
    estão conectadas pela ether1, vem a questão faço a sumarização desses ips mas vou abranger todos
    os ips dessa classe 172.17.x.x, de todas as outras RBS no seguimento dessa topologia?. Deu para entender rsrs?
    Mais uma coisa essa sumarização faço em Area Ranges como vc disse, então em Network no ospf onde eu coloquei já esse ip que faz a comunicação da rb rtr-a com a rtr-b 172.17.1.0/30 ainda continua?.

    Só para concluir abaixo todos os ips dessa topologia.

    172.17.1.0/30 rtr-a / rtr-b
    172.17.2.0/30 rtr-b / rtr-c
    172.17.3.0/30 rtr-c / rtr-d
    172.17.4.0/30 rtr-d / rtr-a


    Acima os ips que faz a comunicação entre as RBS, faço a sumarização deles?
    A loopback preciso fazer algo?
    E os ips privado que irão para os cliente no caso esses 10.5.255.0/24 nesse ñ precisa fazer sumarização, tudo isso um exemplo

    Eu agradeço pela ajuda que vc esta nos dando.

    Obrigado.
    O Gabriel já contribuiu com a informação do local (roteador) onde você fará a sumarização

    Código :
    [rtr-noc]-----[rtr-base]-----[rtr-base-to-pop1]-\/\/\/\/\/\--[rtr-pop1-to-base]
                                                                        [rtr-pop1-n] 10.1.0.0/24 (north)
                                                                        [rtr-pop1-e] 10.1.1.0/24 (east)
                                                                        [rtr-pop1-s] 10.1.2.0/24 (south)
                                                                        [rtr-pop1-w] 10.1.3.0/24 (west)

    No diagrama acima, você tem 4 redes /24, disponíveis para os clientes ao norte, leste, sul e oeste do seu pop. No roteador rtr-pop1-to-base, você sumariza as rotas num único 10.1.0.0/22

    Não é possível sumarizar dentro da mesma área, por isso o Gabriel comentou o ABR

    Saudações,

    Trober



  13. #53

    Padrão Re: Ospf Dando Erro

    Trober rsrs, fica bravo ñ só que não consigo ver onde faço a sumarização nessa topologia abaixo.


    Vou explicar essa topologia abaixo, rtr-noc é uma rb1100 ah que faz o roteamento ospf para rede na area backbone, sai um cabo da ether1 desse rtc-noc que vai para um switch 3com, nesse Switch liga todos os ptps ( existem +ou- 20 ptps ligado nesse Switch ), aqui na empresa tem 1 torre de 30 metros que todos os ptps sai dela. Chega o ptp/enlace ate o rtr-a q fica "exemplo" em uma caixa d aguá, que tem uma rb450g com roteamento ospf area backbone, que contem um range de ips privado para os clientes, descrito abaixo, com isso não tenho mais segmentos de rede. Agora para outra torre sai um ptp do switch novamente que vai para outra torre assim por diante. Com isso onde faço a sumarização, ou ñ é necessário nessa topologia.


    Topologia

    rtr-noc (rb1100ah - ospf area backbone) ----- switch ------ ( enlace ptp - nanobridgem5 )-\/\/\/\/\/\/\/-( enlace receptor - nanobridgem5 ) --- ether 01 rtr-a ( rb450g ospf area backbone ) -> 172.20.0.1/24 ( clientes )

    Obrigado pela paciência.

  14. #54

    Padrão Re: Ospf Dando Erro

    Citação Postado originalmente por rafaeldsv Ver Post
    Trober rsrs, fica bravo ñ...
    De forma alguma. Não tenho motivos para isso

    Citação Postado originalmente por rafaeldsv Ver Post
    Com isso onde faço a sumarização, ou ñ é necessário nessa topologia.
    Se entendi certo seu diagrama, não há necessidade de sumarizar, por enquanto.

    Saudações,

    Trober



  15. #55

    Post Re: Ospf Dando Erro

    boa tarde trober .muito obrigado pelas contribuiçao para todos nos , q DEUS te da em dobro .
    deixa eu te pergunta de uns tempo para ca tenho um elance q ta dando

    --- OSPFv2 neighbor xxxxx: state change from Full to Down
    (isso na RB 1)

    --- OSPFv2 neighbor xxxxx: state change from Full to init

    --- OSPFv2 neighbor xxxxx: state change from Full to 2-Way
    (isso na RB 2)

    esta como o seu exemplo a unica coisa e q eu coloquei uma area
    e em vez de ser brodcast coloquei ptp

    /routing ospf interface add interface=loopback network-type=broadcast passive=yes /routing ospf interface add interface=ether1 network-type=ptp /routing ospf interface add interface=ether4 network-type=ptp /routing ospf interface add interface=ether5 network-type=broadcast passive=yes

    /routing ospf network add area=backbone network=xxxxx q vem do backbone /routing ospf network add area=area network=172.17.1.0/29 /routing ospf network add area=area network=xxxxxx indo para o enlace

    o q vc acha pg so este enlace q ta com este problema para frente ta normal .muito obrigado

  16. #56

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por mariodc Ver Post
    boa tarde trober .muito obrigado pelas contribuiçao para todos nos
    Boa tarde. Fico feliz por minhas contribuições serem úteis

    Citação Postado originalmente por mariodc Ver Post
    deixa eu te pergunta de uns tempo para ca tenho um elance q ta dando

    --- OSPFv2 neighbor xxxxx: state change from Full to Down
    (isso na RB 1)

    --- OSPFv2 neighbor xxxxx: state change from Full to init

    --- OSPFv2 neighbor xxxxx: state change from Full to 2-Way
    (isso na RB 2)

    esta como o seu exemplo a unica coisa e q eu coloquei uma area
    e em vez de ser brodcast coloquei ptp

    /routing ospf interface add interface=loopback network-type=broadcast passive=yes /routing ospf interface add interface=ether1 network-type=ptp /routing ospf interface add interface=ether4 network-type=ptp /routing ospf interface add interface=ether5 network-type=broadcast passive=yes

    /routing ospf network add area=backbone network=xxxxx q vem do backbone /routing ospf network add area=area network=172.17.1.0/29 /routing ospf network add area=area network=xxxxxx indo para o enlace
    Como é composto seu enlace? É feito de uma routerboard diretamente para outra, no caso, RB1 para RB2 (via cartão)? Tem Ubiquiti compondo o enlace? Se tem, qual versão do Ubiquiti AirOS? Essas informações são necessárias.

    Para facilitar, você pode nos informar a saída dos comandos abaixo, nas duas routerboards.

    Código :
    :put ( "Routerboard: ". [/system routerboard get model]." (".[/system routerboard get current-firmware]."/".[/system routerboard g
    et upgrade-firmware].")")
    /ip neighbor print detail without-paging terse
    /interface export compact
    /ip export compact
    /routing export compact
    Se não quiser divulgar seus endereços públicos, substitua o primeiro octeto (se IPv4) por uma palavra, como no exemplo:

    BLOCO1.100.50.1/27
    BLOCO1.100.50.33/29

    BLOCO2.75.12.4/27
    BLOCO2.75.12.41/28

    Citação Postado originalmente por mariodc Ver Post
    o q vc acha pg so este enlace q ta com este problema para frente ta normal .muito obrigado
    Use pontuação nas frases. O "pg" é uma abreviação de qual palavra? Desculpe-me, mas não entendi.

    Saudações,

    Trober



  17. #57

    Padrão Re: Ospf Dando Erro

    Citação Postado originalmente por salvato Ver Post
    Muito obrigado, vou testar hoje mesmo, e posto resultados.
    Ola.. li todo os posts, gostaria de agradecer a todos principalmente ao Trober, pela grande contribuição ao Fórum!
    Tenho apenas uma duvida, irei fazer a topologia anel, rodando OSPF, minha duvida seria o seguinte.. é possivel receber as requisições pppoe dos clientes vindo pelas mesmas interfaces que interligam os Roteadores do OSPF? pois a mesma rede que interliga os Routers, é a rede onde tem os clientes.. e as requisições viram na mesma interface que setei ip para comunicação entre os Roteadores do OSPF... ??
    Agradeço a atenão de Todos..

  18. #58

    Padrão Re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Opa! Concluí aqui

    Vamos a nomenclatura dos ativos:

    rtr-internet: É o roteador (FreeBSD) que está conectado à internet. O único da rede toda que tem NAT. As redes previstas no RFC1918 estão sendo encaminhadas estaticamente para rtr-a. Eu poderia fazer OSPF no FreeBSD, mas não é o foco da demonstração.

    rtr-a: Uma RB750G, ao norte do círculo, com três interfaces, sendo ether5 voltada para o servidor FreeBSD (nosso gateway com NAT). As ethernets de cada RB representam um segmento (perna) de rede. Veja que ether1 de rtr-a conversa com ether1 de rtr-b. Já a ether2 de rtr-b conversa com ether2 de rtr-c. E assim sucessivamente, para demonstrar, de forma mais didática, cada "perna" de rede (ou braço, vai do apelido que cada um prefere dar. Eu sou mais fã de "segmento").

    rtr-b: Uma RB750G, ao leste do diagrama. Conversa com rtr-a e rtr-c.

    rtr-c: Uma RB751G-2HnD, ao sul do diagrama. Conversa com rtr-b, rtr-d e também uma estação de teste, chamada wks-test, de endereço 192.168.140.5/24, simulando o extremo da rede, a ser provida com redundância.

    rtr-d: Uma RB751G-2HnD, que desempenha o mesmo papel de rtr-b, só que do lado oeste do circuito, conversando com rtr-c e rtr-a.

    wks-test: Uma estação de teste. Um notebook rodando PC-BSD. Tem endereço IP 192.168.140.5/24, e gateway 192.168.140.3.

    Abaixo, o diagrama

    Código :
     
    .                              (200.200.200.2/30)
    .                              [rtr-internet] 
    .                              (192.168.250.1) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                     | 
    .                               192.168.250.100 
    .                                   ether5 (lo1 172.30.0.1) 
    .               (172.17.4.1) ether4 [rtr-a] ether1 (172.17.1.1) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .          (172.17.4.4) ether4                   ether1 (172.17.1.2) 
    .(lo1 172.30.0.4) [rtr-d]                             [rtr-b] (lo1 172.30.0.2) 
    .          (172.17.3.4) ether3                   ether2 (172.17.2.2) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .               (172.17.3.3) ether3 [rtr-c] ether2 (172.17.2.3) 
    .                                   ether5 (lo1 172.30.0.3) 
    .                              (192.168.140.3) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                [wks-test] 
    .                              (192.168.140.5) 
    . 
    . 
    . 
    . 
    .
    .
    .
    .
    .
    .
    .

    A circularidade funciona 100%. Desconecta de um lado, o lado oposto assume. Perde uma ou duas sequências ICMP, sendo quase imperceptível ao usuário final.

    Aqui vai o código de rtr-a:
    Código :
    # rtr-a
    # 
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] distribute-default=always-as-type-1 router-id=172.30.0.1
     
    /ip address add address=172.30.0.1/32 interface=loopback network=172.30.0.1
    /ip address add address=172.17.1.1/29 interface=ether1
    /ip address add address=172.17.4.1/29 interface=ether4
    /ip address add address=192.168.250.210/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
    /ip route add distance=1 gateway=192.168.250.1
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.1/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-a
     
     
     
     
     
    #
    Aqui vai o código de rtr-b:
    Código :
    # rtr-b
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.2
     
    /ip address add address=172.30.0.2/32 interface=loopback network=172.30.0.2
    /ip address add address=172.17.1.2/29 interface=ether1
    /ip address add address=172.17.2.2/29 interface=ether2
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether2 network-type=broadcast
     
     
    /routing ospf network add area=backbone network=172.30.0.2/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.2.0/29
     
     
     
     
    /system identity set name=rtr-b
     
     
     
     
     
    #
    Aqui vai o código de rtr-c:
    Código :
    # rtr-c
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.3
     
    /ip address add address=172.30.0.3/32 interface=loopback network=172.30.0.3
    /ip address add address=172.17.2.3/29 interface=ether2
    /ip address add address=172.17.3.3/29 interface=ether3
    /ip address add address=192.168.140.3/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether2 network-type=broadcast
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.3/32
    /routing ospf network add area=backbone network=172.17.2.0/29
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=192.168.140.0/24
     
     
     
    /system identity set name=rtr-c
     
     
     
     
     
    #
    Aqui vai o código de rtr-d:
    Código :
    # rtr-d
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.4
     
    /ip address add address=172.30.0.4/32 interface=loopback network=172.30.0.4
    /ip address add address=172.17.3.4/29 interface=ether3
    /ip address add address=172.17.4.4/29 interface=ether4
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.4/32
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-d
     
     
     
     
     
    #

    Observações importantes:

    Lá em rtr-c, você ao ter o círculo fechado, você terá uma rota padrão ECMP (Equal Cost Multi Path), ou seja, com dois gateways de mesmo custo.

    Outra coisa muito importante. O OSPF tem um tempo de convergência. Então não pense em ficar "fapando cabo" (hehehe) na porta, a cada 5 segundos, achando que terá convergência em tempo real. Detectar queda é instantâneo. Detectar retorno leva não menos que 10 segundos, tempo do Hello Interval. Aqui é entra a questão de atualização entre roteadores e tal, e a conversa vai longe, não sendo o propósito inicial desse tópico.

    Para finalizar, funcionou aqui 100% e funciona em todos o provedores, prefeituras e mais um pool de cliente que tenho em produção

    Espero ter sido útil o material a você e demais colegas do Under-Linux.

    Saudações,

    Trober

    Ola.. li todo os posts, gostaria de agradecer a todos principalmente ao Trober, pela grande contribuição ao Fórum!
    Tenho apenas uma duvida, irei fazer a topologia anel, rodando OSPF, minha duvida seria o seguinte.. é possivel receber as requisições pppoe dos clientes vindo pelas mesmas interfaces que interligam os Roteadores do OSPF? pois a mesma rede que interliga os Routers, é a rede onde tem os clientes.. e as requisições viram na mesma interface que setei ip para comunicação entre os Roteadores do OSPF... ??
    Agradeço a atenão de Todos..



  19. #59

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por goplex Ver Post
    Ola.. li todo os posts, gostaria de agradecer a todos principalmente ao Trober, pela grande contribuição ao Fórum!
    Fico feliz em ter ajudado

    Peço desculpas pela demora na resposta, pois estou em viagem.

    Citação Postado originalmente por goplex Ver Post
    Tenho apenas uma duvida, irei fazer a topologia anel, rodando OSPF, minha duvida seria o seguinte.. é possivel receber as requisições pppoe dos clientes vindo pelas mesmas interfaces que interligam os Roteadores do OSPF? pois a mesma rede que interliga os Routers, é a rede onde tem os clientes.. e as requisições viram na mesma interface que setei ip para comunicação entre os Roteadores do OSPF... ??
    Cara, eu não faria isso. Eu prefiro ter interfaces de enlace específicas para enlace, e interfaces de clientes, específicas para clientes. No seu caso, como é PPPoE, pode sumarizar numa área. A interface em que seus clientes conectam fica definida como passiva.

    Saudações,

    Trober


  20. #60

    Padrão Re: OSPF dando erro

    Citação Postado originalmente por trober Ver Post
    Fico feliz em ter ajudado

    Peço desculpas pela demora na resposta, pois estou em viagem.



    Cara, eu não faria isso. Eu prefiro ter interfaces de enlace específicas para enlace, e interfaces de clientes, específicas para clientes. No seu caso, como é PPPoE, pode sumarizar numa área. A interface em que seus clientes conectam fica definida como passiva.

    Saudações,

    Trober

    Cara.. obrigado pela resposta!
    Entendi o conselho.. mas realmente de momento não consigo colocar um Router em cada POP pra fazer requisição pppoe em uma interface e enlace do OSPF em outra.. por isso em alguns pontos as requisições pppoe irão pelo mesmo enlace do OSPF.. mas pelo que entendi.. daria pra trabalhar assim? porem teria que "Sumarizar numa areá" e deixar a interface cliente passiva?
    tem como detalhar para nós... essa explicação?
    Grato

    Até Breve