+ Responder ao Tópico



  1. #1

    Padrão PPPoE Relay NanoStation Loco M5

    Bem, vamos lá.
    Procurei por essa dúvida em diversos lugares, mas não encontrei uma resposta definitiva para isso.
    Hoje tenho minha rede configurada em PPPoE com radios NanoLoco M5 e NanoStaion M5 em modo cliente discando para o servidor, e roteando a conexão para o cliente.
    O que ocorre, é que em prédios eu tenho que utilizar um único equipamento para vários clientes, pela logística de instalação, e aí eu tenho que trabalhar com o equipamento em bridge, com os clientes utilizando discadores.
    A dúvida surge no seguinte: Existe alguma forma de fazer os equipamentos ubiquiti traalharem em modo router, e passando o PPPoE como se fosse um PPPoE Relay pela conexão roteada? Assim eu poderia isolar de forma mais eficaz e simples os clientes atrás desse Nano. Hoje eu utilizo alguns bloqueios que só deixam passar o PPPoE pela bridge, mas me facilitaria até a manutenção se pudesse trabalhar em modo router com o PPPoE passando pelo roteamento.
    Se alguém tiver alguma informação concreta sobre isso, seria de bom grado.
    Obrigado.

  2. #2

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Amigo em nossa rede tambem trabalhamos assim mas em caso de predios nos colocamos um concentrador de usuario no predio e liberamos uma quantidade de link para o mesmo assim , porem aqui nos usamos radius concentramos os usuarios no predio mas autenticam no radius na empresa , espero ter ajudado
    se nao desconsidere



  3. #3

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por philmaster Ver Post
    Amigo em nossa rede tambem trabalhamos assim mas em caso de predios nos colocamos um concentrador de usuario no predio e liberamos uma quantidade de link para o mesmo assim , porem aqui nos usamos radius concentramos os usuarios no predio mas autenticam no radius na empresa , espero ter ajudado
    se nao desconsidere
    Entendi.
    O problema é que eu tenho um servidor Radius central, e centralizo também meu concentrador, facilitando alterações.
    De qualquer forma, obrigado pela contribuição.
    Abs

  4. #4

    Padrão Re: PPPoE Relay NanoStation Loco M5

    O que você pode fazer é colocar uma RB no prédio, entre os clientes e a Bridge, deixando passar só o PPPoE, mais nada. Seria uma forma de melhorar sua manutenção.

    Se ajudei, estrelinha pra mim!



  5. #5
    joycemuniz
    Visitante

    Padrão Re: PPPoE Relay NanoStation Loco M5

    oi

  6. #6

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Boa tarde,
    Estou com a mesma ideia aqui! Já achei uma forma de criar um script automático na inicialização do nano, porém falta o binário pppoe-relay... caso alguém tenha o pacote rp-pppoe compilado com a sdk + toolchain da ubnt para fornecer pra gente (toh sem tempo para criar esse esquema aih do zero!)



  7. #7

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Bom... como ninguém se prontificou, compilei o pppoe-relay para o nanostation 2/5 (falta ainda compilar para a familia m5).
    Testei em vários equipamentos aqui, e está funcionando perfeitamente.
    Segue o link para baixar o binario compilado.
    http://www.saorc.com.br/ubnt/nano5/pppoe-relay

    Para isso tudo funcionar, precisa fazer o seguinte:

    - Fazer o upload do pppoe-relay para dentro do /etc/persistent no nano2/nano5:
    Código :
    $ cat pppoe-relay | ssh [email protected]_do_nanostation 'cat > /etc/persistent/pppoe-relay'

    - Acessar o nanostation via ssh e criar um script de inicialização (rc.poststart) dentro do /etc/persistent, contendo o seguinte:
    Código :
    #!/bin/sh
    /etc/persistent/pppoe-relay -S ath0 -C eth0

    - Ainda dentro do nanostation, setar ambos como executável e salvar as alterações:
    Código :
    $ chmod +x /etc/persistent/rc.poststart
    $ chmod +x /etc/persistent/pppoe-relay
    $ save

    Depois é só alterar a configuração via web de bridge para router, e pronto!
    Assim que conseguir compilar o pppoe-relay pra família m5, eu posto o link para download aqui.

  8. #8

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Fantástico! Vou fazer os testes para ver se roda legalzinho aqui. Por hora, a grande maioria dos meus equipamentos são série M5, mas tenho alguns Nano5 tb. Obrigado pela contribuição!



  9. #9

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Como prometido, segue abaixo link para o executável do pppoe-relay portado para a família M5:

    http://www.saorc.com.br/ubnt/nanom5/pppoe-relay

    Para funcionar, é só seguir os mesmos passos do nanostation 5 (logo acima), com a vantagem do nano m5 ter o wget para baixar o binário diretamente no /etc/persistent, ao invés de copiar via ssh/cat.

  10. #10

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por loxxxa Ver Post
    Bom... como ninguém se prontificou, compilei o pppoe-relay para o nanostation 2/5 (falta ainda compilar para a familia m5).
    Testei em vários equipamentos aqui, e está funcionando perfeitamente.
    Segue o link para baixar o binario compilado.
    http://www.saorc.com.br/ubnt/nano5/pppoe-relay

    Para isso tudo funcionar, precisa fazer o seguinte:

    - Fazer o upload do pppoe-relay para dentro do /etc/persistent no nano2/nano5:
    Código :
    $ cat pppoe-relay | ssh [email protected]_do_nanostation 'cat > /etc/persistent/pppoe-relay'

    - Acessar o nanostation via ssh e criar um script de inicialização (rc.poststart) dentro do /etc/persistent, contendo o seguinte:
    Código :
    #!/bin/sh
    /etc/persistent/pppoe-relay -S ath0 -C eth0

    - Ainda dentro do nanostation, setar ambos como executável e salvar as alterações:
    Código :
    $ chmod +x /etc/persistent/rc.poststart
    $ chmod +x /etc/persistent/pppoe-relay
    $ save

    Depois é só alterar a configuração via web de bridge para router, e pronto!
    Assim que conseguir compilar o pppoe-relay pra família m5, eu posto o link para download aqui.
    Amigo, você chegou a testar isso com os equipamentos Bullet2? Tentei implementar no Bullet2, e recebo essa mensagem de erro no arquivo de log na hora que o pppoe-relay é executado, tanto manualmente quanto carregado automaticamente pelo rc.poststart:


    "daemon.err pppoe-relay[303]: send (sendPacket): No such device or address"

    Tem alguma idéia do que possa ser?
    Obrigado!



  11. #11

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Hum... não tenho nenhum bullet pra testar aqui.
    Mas você chegou a olhar se as interfaces do bullet são as mesmas que postei? (ath0 e eth0)?
    Mas creio que não seja isso. O mais provável é que como o bullet2 trabalha em 2.4, o SKD seja diferente, assim como o Nanostation 5 é diferente do Nanostation M5.

    Resumindo: se as interfaces estão corretas, o problema está no binário mesmo, que precisará ser compilado para o bullet2.

  12. #12

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por loxxxa Ver Post
    Hum... não tenho nenhum bullet pra testar aqui.
    Mas você chegou a olhar se as interfaces do bullet são as mesmas que postei? (ath0 e eth0)?
    Mas creio que não seja isso. O mais provável é que como o bullet2 trabalha em 2.4, o SKD seja diferente, assim como o Nanostation 5 é diferente do Nanostation M5.

    Resumindo: se as interfaces estão corretas, o problema está no binário mesmo, que precisará ser compilado para o bullet2.
    Pode ser isso, pois as interfaces são as mesmas.
    Haveria a possibilidade ou custos para você compilar isso e disponibilizar para bullet2?
    Fiz os testes com um equipamento série M5 e rodou tudo 100%.
    Obrigado pela colaboração.



  13. #13

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Vou baixar o SDK do bullet2 e assim que tiver algum progresso, eu posto aqui!

  14. #14

    Padrão Re: PPPoE Relay NanoStation Loco M5

    O SDK do bullet2 e do nanostation5 é o mesmo. Estranho dar esse erro do pppoe-relay dentro do bullet...
    Você está usando o pppoe-relay do m5 ou nanostation comum no bullet?



  15. #15

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por loxxxa Ver Post
    O SDK do bullet2 e do nanostation5 é o mesmo. Estranho dar esse erro do pppoe-relay dentro do bullet...
    Você está usando o pppoe-relay do m5 ou nanostation comum no bullet?
    Testei no Bullet, e hoje vou fazer um teste na bancada em outro Bullet2 e um PicoStation 2 também, para ver se é um problema isolado, e depois posto o feedback.
    Desde já obrigado pela atenção, você tem me ajudado muito com essa versão do PPPoE Relay!

  16. #16

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por loxxxa Ver Post
    O SDK do bullet2 e do nanostation5 é o mesmo. Estranho dar esse erro do pppoe-relay dentro do bullet...
    Você está usando o pppoe-relay do m5 ou nanostation comum no bullet?
    Conforme eu prometi, o feedback é o seguinte: Reparei que os bullet2 que eu tava usando estavam com firmware mais antiga. Troquei a firmware e está rodando tudo certinho agora.
    Fico imensamente agradecido por sua prontidão, loxxxa. Atitudes como essa sua é o que ainda mantém o fórum!
    Vou ver se implemento a solução na rede esse final de semana. Por hora na bancada, tudo rodando certinho!
    Aqui nós temos boa parte da rede ainda trabalhando com equipamentos da Ubiquiti, e estou fazendo migração para PPPoE, o que vai me dar um certo trabalho, pois no Mikrotik eu trabalhei com Túneis EoIP e sanei meu problema do PPPoE, mas nos equipamentos ubiquiti eu estava completamente perdido, até você postar esse fruto do seu trabalho.
    Já cogitou apresentar isso para a equipe UBNT no fórum oficial? Acho que seria muito bom, e existe a possibilidade de ser implementado futuramente.
    Abraços e mais uma vez muito obrigado!



  17. #17

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Amigos, sou novo no Fórum e estou passando por problemas na minha rede Hotspot e em Bridge, com muitas quedas, começei a fazer toda a migração para PPPoE e para modo Router, porém estou com o mesmo problema nos prédios. Gostaria de saber se tem como fazer um passo-a-passo de como inserir o binário no Nano/Loco M5.

    Grato pelo Ajuda.

    Sds,

    Paulo






    Citação Postado originalmente por horusosbourne Ver Post
    Conforme eu prometi, o feedback é o seguinte: Reparei que os bullet2 que eu tava usando estavam com firmware mais antiga. Troquei a firmware e está rodando tudo certinho agora.
    Fico imensamente agradecido por sua prontidão, loxxxa. Atitudes como essa sua é o que ainda mantém o fórum!
    Vou ver se implemento a solução na rede esse final de semana. Por hora na bancada, tudo rodando certinho!
    Aqui nós temos boa parte da rede ainda trabalhando com equipamentos da Ubiquiti, e estou fazendo migração para PPPoE, o que vai me dar um certo trabalho, pois no Mikrotik eu trabalhei com Túneis EoIP e sanei meu problema do PPPoE, mas nos equipamentos ubiquiti eu estava completamente perdido, até você postar esse fruto do seu trabalho.
    Já cogitou apresentar isso para a equipe UBNT no fórum oficial? Acho que seria muito bom, e existe a possibilidade de ser implementado futuramente.
    Abraços e mais uma vez muito obrigado!

  18. #18

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por PAHENCOS Ver Post
    Amigos, sou novo no Fórum e estou passando por problemas na minha rede Hotspot e em Bridge, com muitas quedas, começei a fazer toda a migração para PPPoE e para modo Router, porém estou com o mesmo problema nos prédios. Gostaria de saber se tem como fazer um passo-a-passo de como inserir o binário no Nano/Loco M5.
    Paulo, bom dia!
    Acho que mais detalhado que o amigo loxxxa postou não tem como.
    Na segunda página desse tópico o senhor encontra como upar os binários pra dentro do equipamento, e inclusive tem binários e tutoriais diferentes para ambos equipamentos.
    Sds.



  19. #19

    Padrão Re: PPPoE Relay NanoStation Loco M5

    opa...
    versao 5.5.6
    nao funciona
    /etc/persistent/pppoe-relay: can't resolve symbol '__uClibc_start_main'

    na verdade e assim pelo menos aqui comigo...
    se fazer update para uma versao mais nova, tem que remover o pppoe-relay
    baixar denovo e dar o chmod +x novamente
    e rodar ai funciona sem o erro acima..
    unica situacao e que nao fica o mac do cliente
    fica o mac da Wlan da antena

  20. #20

    Padrão Re: PPPoE Relay NanoStation Loco M5

    Citação Postado originalmente por xbili Ver Post
    opa...
    versao 5.5.6
    nao funciona
    /etc/persistent/pppoe-relay: can't resolve symbol '__uClibc_start_main'

    na verdade e assim pelo menos aqui comigo...
    se fazer update para uma versao mais nova, tem que remover o pppoe-relay
    baixar denovo e dar o chmod +x novamente
    e rodar ai funciona sem o erro acima..
    unica situacao e que nao fica o mac do cliente
    fica o mac da Wlan da antena
    unico bolo que percebi na 556 é que nao ta vindo aom a interface bridge br0 que tinha antes com a lan1 e lan0 dai tem que colocar pelo modo avançado do radio

    /etc/persistent/pppoe-relay -S ath0 -C br0

    se nao colocar em bridge o instalador confunde a porta e ja era