+ Responder ao Tópico



  1. #1

    Padrão Probelma com BGP

    Estou tendo problema com o BGP no Mikrotik versao 5.13 level 4, vamos a descrição tenho 3 interface neste servidor.
    WAN, LAN e saida para virtualização, meu link é de 500Mb Full duplex da GVT
    Quando desabilito a placa de rede que faz a LAN, meu consumo dde rede que era para zerar, faz ao contrario na parte da WAN, vai para 500Mb de Down e UP e o numero de pacote passa de 250.000 em TX e 250.000 RX, meu BGP esta assim:

    Código :
    /routing bgp instance
    set default as=111111 client-to-client-reflection=no disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=no redistribute-ospf=no \
        redistribute-other-bgp=no redistribute-rip=no redistribute-static=no router-id=xxx.xxx.xxx.1 routing-table=""
    /routing bgp network
    add disabled=no network=xxx.xxx.xxx.0/21 synchronize=no
    /routing bgp peer
    add address-families=ip allow-as-in=1 as-override=no default-originate=never disabled=no hold-time=3m in-filter=GVT-bgp-in instance=default multihop=no name=GVT \
        nexthop-choice=default out-filter=GVT2-bgp-in passive=no remote-address=xxx.zzz.zzz.125 remote-as=18881 remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default \
        use-bfd=no
     
     
    /routing filter
    add action=discard chain=GVT-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""
    add action=accept bgp-as-path=111111 chain=GVT-bgp-in comment="GVT 1 prefixo /21" disabled=no invert-match=no prefix=xxx.xxx.0.0/16 prefix-length=21-24 set-bgp-prepend=5 \
        set-bgp-prepend-path=""
    add action=accept bgp-as-path=111111 chain=GVT2-bgp-in comment="GVT 2 prefixo /21" disabled=no invert-match=yes prefix=xxx.xxx.0.0/16 prefix-length=21-24 set-bgp-prepend=10 \
        set-bgp-prepend-path=""
    add action=discard chain=GVT2-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""
    add action=accept bgp-as-path=111111 chain=GVT1-bgp-in comment="GVT 1" disabled=no invert-match=no prefix=xxx.xxx.0.0/16 prefix-length=21-24 set-bgp-prepend=15 \
        set-bgp-prepend-path=""
    add action=discard chain=GVT1-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""
    add action=discard chain=GVT1-bgp-in disabled=no invert-match=no set-bgp-prepend-path=""

    Alguem ja pegou este problema?

    No forum do Mikrotik, eles tiveram este problema e parece que nao teve solução la
    MikroTik RouterOS • View topic - BGP Loop when interface goes down

  2. #2



  3. #3
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Probelma com BGP

    Bom dia,

    Primeiramente seus filtros estão configurados de uma forma muito estranha.

    A primeira regra é de discard, não tendo ativado o invert-match.

    Acho que tem uma troca de filtros de entrada por filtros de saida.

    Poste também a saída do comando
    /routing bgp network print

    Abraço

  4. #4

    Padrão Re: Probelma com BGP

    Citação Postado originalmente por gamineiro Ver Post
    Bom dia,

    Primeiramente seus filtros estão configurados de uma forma muito estranha.

    A primeira regra é de discard, não tendo ativado o invert-match.

    Acho que tem uma troca de filtros de entrada por filtros de saida.

    Poste também a saída do comando
    /routing bgp network print

    Abraço
    /routing bgp network print
    Flags: X - disabled
    # NETWORK SYNCHRONIZE
    0 177.23.176.0/21 no



  5. #5

    Padrão Re: Probelma com BGP

    Citação Postado originalmente por thiagotg Ver Post
    Tem rota default?
    tem sim

    ip route> print
    Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 A S ;;; GVT
    0.0.0.0/0 177.43.178.125 1

  6. #6
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Probelma com BGP

    Bom dia, você tem apenas um peer BGP certo?

    Coloque isso:

    /routing filter
    add chain=OUT-FILTERS prefix=177.23.176.0/21 prefix-length=21-24 invert-match=no action=accept
    add chain=OUT-FILTERS prefix=0.0.0.0/0 prefix-length=0-32 invert-match=no action=discard

    Depois adicione em OUT-FILTER no peer esse filtro OUT-FILTERS.

    Vamos falando.



  7. #7

    Padrão Re: Probelma com BGP

    Bom dia, você tem apenas um peer BGP certo?
    Sim

    Coloquei os filtros e desabilitei os outros e deixei so que me passou habilitado, fui em peer e adicionei o filtro que me passou e removi os meus, ficou assim
    Clique na imagem para uma versão maior

Nome:	         normal.jpg
Visualizações:	76
Tamanho: 	46,7 KB
ID:      	35427

    fui fazer o teste, desabilitei a LAN e olha como ficou a WAN
    Clique na imagem para uma versão maior

Nome:	         erro.jpg
Visualizações:	69
Tamanho: 	42,6 KB
ID:      	35428

    Mesmo habilitando os outros filtros continuou o erro
    se eu desabilitar o BGP e desabilitar a LAN, nao acontece isso

  8. #8
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Probelma com BGP

    Use a opção torch em cima dessa placa e veja de onde vem esse consumo.



  9. #9

    Padrão Re: Probelma com BGP

    Parece que e nosso AS que esta consumindo, coloquei para mostrar por consumo e olah que deu
    Clique na imagem para uma versão maior

Nome:	         tourch.jpg
Visualizações:	76
Tamanho: 	70,9 KB
ID:      	35429