Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por marciogreick Ver Post
    ve ai se estas servem para voce :Balanceamento de Cargas - 4 Links com cargas iguais Modens Roteados

    A pedido do Wyldner (netmax2010), adaptei o balance do vídeo do Jerônimo para 4 links de ADSL roteados, com cargas iguais, mas presta atenção Wyldner, os ips dos modens têm que ser diferentes, para não gerar confusão para o Mikrotik.

    Peço encarecidamente que leia com atenção, adapte os endereços de IP para os da sua rede, e o nome das interfaces. Tá muito fácil, é só copiar e colar.

    Abraço.

    ================================================== ================================================== ================
    Defina os endereços de IP das interfaces

    Código:

    /ip addressadd address=10.0.10.2/30 broadcast=10.0.10.3 comment="" disabled=no \ interface=ISP1 network=10.0.10.0add address=10.0.20.2/30 broadcast=10.0.20.3 comment="" disabled=no \ interface=ISP2 network=10.0.20.0add address=10.0.30.2/30 broadcast=10.0.30.3 comment="" disabled=no \ interface=ISP3 network=10.0.30.0add address=10.0.40.2/30 broadcast=10.0.40.3 comment="" disabled=no \ interface=ISP4 network=10.0.40.0add address=192.168.88.1/30 broadcast=192.168.88.3 comment="" disabled=no \ interface=Local network=192.168.88.0
    A seguir, deve-se configurar o Firewall. Tais configurações envolvem, dentre outras, a própria configuração do Balance, marcação de pacotes e rotas.
    Código:

    /ip firewall mangleadd action=accept chain=prerouting comment=\ "====================================================================" \ disabled=no dst-address=192.168.88.0/30 src-address=192.168.88.0/30add action=accept chain=prerouting comment="" disabled=no dst-address=\ 10.0.10.0/30 src-address=192.168.88.0/30add action=accept chain=prerouting comment="" disabled=no dst-address=\ 10.0.20.0/30 src-address=192.168.88.0/30add action=accept chain=prerouting comment="" disabled=no dst-address=\ 10.0.30.0/30 src-address=192.168.88.0/30add action=accept chain=prerouting comment="" disabled=no dst-address=\ 10.0.40.0/30 src-address=192.168.88.0/30add action=mark-connection chain=prerouting comment=\ "====================================================================" \ connection-mark=no-mark disabled=no in-interface=ISP1 \ new-connection-mark=ISP1_conn passthrough=yesadd action=mark-connection chain=prerouting comment="" connection-mark=\ no-mark disabled=no in-interface=ISP2 new-connection-mark=ISP2_conn \ passthrough=yesadd action=mark-connection chain=prerouting comment="" connection-mark=\ no-mark disabled=no in-interface=ISP3 new-connection-mark=ISP3_conn \ passthrough=yesadd action=mark-connection chain=prerouting comment="" connection-mark=\ no-mark disabled=no in-interface=ISP4 new-connection-mark=ISP4_conn \ passthrough=yesadd action=jump chain=prerouting comment=\ "====================================================================" \ connection-mark=no-mark disabled=no in-interface=Local jump-target=\ policy_routeradd action=mark-routing chain=prerouting comment=\ "====================================================================" \ connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \ passthrough=yes src-address=192.168.88.0/30add action=mark-routing chain=prerouting comment="" connection-mark=ISP2_conn \ disabled=no new-routing-mark=ISP2_trafic passthrough=yes src-address=\ 192.168.88.0/30add action=mark-routing chain=prerouting comment="" connection-mark=ISP3_conn \ disabled=no new-routing-mark=ISP3_trafic passthrough=yes src-address=\ 192.168.88.0/30add action=mark-routing chain=prerouting comment="" connection-mark=ISP4_conn \ disabled=no new-routing-mark=ISP4_trafic passthrough=yes src-address=\ 192.168.88.0/30add action=mark-routing chain=output comment=\ "====================================================================" \ connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \ passthrough=yesadd action=mark-routing chain=output comment="" connection-mark=ISP2_conn \ disabled=no new-routing-mark=ISP2_trafic passthrough=yesadd action=mark-routing chain=output comment="" connection-mark=ISP3_conn \ disabled=no new-routing-mark=ISP3_trafic passthrough=yesadd action=mark-routing chain=output comment="" connection-mark=ISP4_conn \ disabled=no new-routing-mark=ISP4_trafic passthrough=yesadd action=mark-connection chain=policy_router comment=\ "====================================================================" \ disabled=no dst-address-type=!local new-connection-mark=ISP1_conn \ passthrough=yes per-connection-classifier=both-addresses:4/0add action=mark-connection chain=policy_router comment="" disabled=no \ dst-address-type=!local new-connection-mark=ISP2_conn passthrough=yes \ per-connection-classifier=both-addresses:4/1add action=mark-connection chain=policy_router comment="" disabled=no \ dst-address-type=!local new-connection-mark=ISP3_conn passthrough=yes \ per-connection-classifier=both-addresses:4/2add action=mark-connection chain=policy_router comment="" disabled=no \ dst-address-type=!local new-connection-mark=ISP4_conn passthrough=yes \ per-connection-classifier=both-addresses:4/3
    Criando o Masquerading para as conexões ADSL ROTEADAS

    Código:

    /ip firewall natadd action=masquerade chain=srcnat comment="" disabled=no out-interface=ISP1add action=masquerade chain=srcnat comment="" disabled=no out-interface=ISP2add action=masquerade chain=srcnat comment="" disabled=no out-interface=ISP3add action=masquerade chain=srcnat comment="" disabled=no out-interface=ISP4
    As rotas com FAILOVER, caso algum LINK ADSL caia:

    Código:

    /ip routeadd comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.10.1 \ routing-mark=ISP1_trafic scope=30 target-scope=10add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.20.1 \ routing-mark=ISP2_trafic scope=30 target-scope=10add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.30.1 \ routing-mark=ISP3_trafic scope=30 target-scope=10add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.40.1 \ routing-mark=ISP4_trafic scope=30 target-scope=10add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.0.10.1 \ scope=30 target-scope=10add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.0.20.1 \ scope=30 target-scope=10add comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=10.0.30.1 \ scope=30 target-scope=10add comment="" disabled=no distance=5 dst-address=0.0.0.0/0 gateway=10.0.40.1 \ scope=30 target-scope=10
    Configurar os DNS. Abaixo os do Google. Coloque os da sua preferência.
    Código:

    /ip dnsset allow-remote-requests=no cache-max-ttl=1w cache-size=20480KiB \ max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
    Obrigado pela ajuda, porém ainda não é o meu caso...
    o Link1 (ether1) é IP Dinâmico, o MK já recebe o IP da internet NELE, não é um modem que dá para rotear (Embratel - NetVirtua)...
    Outra coisa é que os meus pesos são diferentes, 20Mb e 15MB, acredito que seria pesos 4 e 3...

    Alguma idéia??

  2. Zerei meu MK e aqui está a configuração dele "COMPLETA" como estou deixando ele...
    Os dois links conectam, e se um cai, o outro assume, mas não está fazendo o balanceamento de carga...

    Código :
    /interface {
        set ether1 name=ether1-Virtua20Mb;
        set ether2 name=ether2-Velox15Mb;
        set ether3 name=ether3-Local;
    }
    /ip address
        add address=192.168.123.1/24 broadcast=192.168.123.255 comment="LAN" disabled=no interface=ether3-Local network=192.168.123.0;
        add address=192.168.2.254/24 broadcast=192.168.2.255 comment="WAN2" disabled=no interface=ether2-Velox15Mb network=192.168.2.0;
    /ip dhcp-client
        add interface=ether1-Virtua20Mb disabled=no comment="WAN1";
    /ip pool
        add name="local" ranges=192.168.123.2-192.168.123.254;
    /ip dhcp-server
        add name="dhcp1" address-pool="local" interface=ether3-Local disabled=no;
    /ip dhcp-server network
        add address=192.168.123.0/24 gateway=192.168.123.1 dns-server=192.168.123.1 comment="";
    / ip route
        add dst-address=0.0.0.0/0 gateway=177.65.180.1,192.168.2.1 check-gateway=ping;
    / ip firewall nat
        add chain=srcnat out-interface=ether1-Virtua20Mb action=masquerade;
        add chain=srcnat out-interface=ether2-Velox15Mb action=masquerade;
    / ip firewall mangle
        add chain=input in-interface=ether1-Virtua20Mb action=mark-connection new-connection-mark=wan1_conn;
        add chain=input in-interface=ether2-Velox15Mb action=mark-connection new-connection-mark=wan2_conn;
        add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1;
        add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2;
    / ip route
        add dst-address=0.0.0.0/0 gateway=177.65.180.1 routing-mark=to_wan1;
        add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_wan2;
    /ip dns
        set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes;



  3. PessoALL,
    consegui fazer o balanceamento...
    Só to com uma dúvida quanto ao PESO dos links, no meu caso os pesos são 4 e 3 (20Mb e 15Mb), é assim que fica mesmo???
    Abaixo a minha configuração COMPLETA, com o balanceamento funcionando...

    Código :
    /interface {
       set ether1 name=ether1-Virtua20Mb;
       set ether2 name=ether2-Velox15Mb;
       set ether3 name=ether3-Local;
       set ether4 name=ether4-slave-local;
       set ether5 name=ether5-slave-local;
    }
     
    /ip address
       add address=192.168.123.1/24 broadcast=192.168.123.255 disabled=no interface=ether3-Local network=192.168.123.0;
       add address=192.168.2.254/24 broadcast=192.168.2.255 disabled=no interface=ether2-Velox15Mb network=192.168.2.0;
     
    /ip dhcp-client add interface=ether1-Virtua20Mb disabled=no;
     
    /ip dns   set allow-remote-requests=yes;
     
    /ip pool add name="local" ranges=192.168.123.2-192.168.123.254;
    /ip dhcp-server add name="dhcp1" address-pool="local" interface=ether3-Local disabled=no;
    /ip dhcp-server network add address=192.168.123.0/24 gateway=192.168.123.1 dns-server=192.168.123.1 comment="";
     
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!ether1-Virtua20Mb src-address=192.168.123.1/24;
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!ether2-Velox15Mb src-address=192.168.123.1/24;
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ether1-Virtua20Mb;
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ether2-Velox15Mb;
     
    /ip  firewall mangle add action=mark-connection chain=prerouting comment=""  connection-state=new disabled=no dst-address-list=LINK0  in-interface=ether3-Local new-connection-mark=Sites0 passthrough=yes;
    /ip  firewall mangle add action=mark-routing chain=prerouting comment=""  connection-mark=Sites0 disabled=no in-interface=ether3-Local  new-routing-mark=Rota0 passthrough=no;
    /ip route add gateway=177.65.180.1 routing-mark=Rota0;
    /ip  firewall mangle add action=mark-connection chain=prerouting comment=""  connection-state=new disabled=no dst-address-list=LINK1  in-interface=ether3-Local new-connection-mark=Sites1 passthrough=yes;
    /ip  firewall mangle add action=mark-routing chain=prerouting comment=""  connection-mark=Sites1 disabled=no in-interface=ether3-Local  new-routing-mark=Rota1 passthrough=no;
    /ip route add gateway=192.168.2.1 routing-mark=Rota1;
     
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0;
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0;
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0;
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1;
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1;
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1;
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1;
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1;
     
    /ip  firewall mangle add action=mark-connection connection-state=new  chain=prerouting disabled=no in-interface=ether1-Virtua20Mb  new-connection-mark=ISP1_conn passthrough=yes;
    /ip firewall mangle  add action=mark-connection connection-state=new chain=prerouting  disabled=no in-interface=ether2-Velox15Mb new-connection-mark=ISP2_conn  passthrough=yes;
    /ip firewall mangle add action=mark-routing  chain=output connection-mark=ISP1_conn disabled=no  new-routing-mark=to_ISP1 passthrough=yes;
    /ip firewall mangle add  action=mark-routing chain=output connection-mark=ISP2_conn disabled=no  new-routing-mark=to_ISP2 passthrough=yes;
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.0.3.0/24 in-interface=ether3-Local;
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=10.0.4.0/24 in-interface=ether3-Local;
    /ip  firewall mangle add action=mark-connection connection-state=new  chain=prerouting disabled=no dst-address-type=!local  in-interface=ether3-Local new-connection-mark=ISP1_conn passthrough=yes  per-connection-classifier=both-ports:4/0;
    /ip firewall mangle add  action=mark-connection connection-state=new chain=prerouting disabled=no  dst-address-type=!local in-interface=ether3-Local  new-connection-mark=ISP2_conn passthrough=yes  per-connection-classifier=both-ports:3/0;
    /ip firewall mangle add  action=mark-routing chain=prerouting connection-mark=ISP1_conn  disabled=no in-interface=ether3-Local new-routing-mark=to_ISP1  passthrough=yes;
    /ip firewall mangle add action=mark-routing  chain=prerouting connection-mark=ISP2_conn disabled=no  in-interface=ether3-Local new-routing-mark=to_ISP2 passthrough=yes;
     
    /ip  route add check-gateway=ping disabled=no distance=1  dst-address=0.0.0.0/0 gateway=177.65.180.1 routing-mark=to_ISP1  comment="Link0";
    /ip route add check-gateway=ping disabled=no  distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1  routing-mark=to_ISP2 comment="Link1";
    /ip route add  check-gateway=ping comment="Link0" disabled=no distance=1  dst-address=0.0.0.0/0 gateway=177.65.180.1 scope=30 target-scope=10;
    /ip  route add check-gateway=ping comment="Link1" disabled=no distance=2  dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=30 target-scope=10;
     
    /interface ethernet {
       set ether4-slave-local master-port=ether3-Local;
       set ether5-slave-local master-port=ether3-Local;
    }
     
    /ip dns set servers=8.8.8.8,8.8.4.4;

    Mais uma coisa...
    Alguém sabe como eu pegar o IP externo da conexão que está roteada pelo MK?? Tipo, algum comando...
    Pois estou usando um script para atualizar o no-ip e ele está pegando o ip INTERNO (192.168.2.254)...
    Queria editar o script pra pegar o IP Externo...
    Em relação ao link1 (IP Dinâmico) o no-ip, está atualizando sem problemas...

  4. Pessoal,

    Peço ajuda nesse caso, é muito importante.

    Os meus dois MODENS fazem a autenticação e liberam acesso através do NAT. O grande problema é que a queda do ADSL não gera queda do meu GATEWAY, que é a porta LAN do MODEM, então, se eu desplugar o cabo de telefone o meu gateway continuará ativo e ele não vai fazer a troca. Só vai cair a internet.

    Preciso que a partir da porta eth1 ele faça um PING externo, quando o ping parar de responder ele faz a troca de rede, depois que voltar a funcionar ele volte novamente o tráfego para o principal.

    Alguém sabe como fazer isso?

    Obrigado!!



  5. Pessoal,

    Peço ajuda nesse caso, é muito importante.

    Os meus dois MODENS fazem a autenticação e liberam acesso através do NAT. O grande problema é que a queda do ADSL não gera queda do meu GATEWAY, que é a porta LAN do MODEM, então, se eu desplugar o cabo de telefone o meu gateway continuará ativo e ele não vai fazer a troca. Só vai cair a internet.

    Preciso que a partir da porta eth1 ele faça um PING externo, quando o ping parar de responder ele faz a troca de rede, depois que voltar a funcionar ele volte novamente o tráfego para o principal.

    Alguém sabe como fazer isso?

    Obrigado!!
    Então amigo para que a internet não pare pros cliente estão no link que caiu, os seus modens teriam que está em bridge e o loadbalance discando os links só assim quando um link cair o outro irá assumir todo os clientes que estão online no link que caiu e assim que voltar o link que caiu o loadbalance ele irá dividir os clientes novamente pois usando os modens roteado isso já não acontece pois pro MK o seu link ainda está ativo pois ele continua tendo resposta do ip do modem não reconhece que a internet caiu a não ser que você tire o cabo do modem ou desligue o modem ai sim.

    Tipo meu cenário tenho 3 ADSL em bridge e um dedicado IP FIXO o que fiz foi colocar uma RB750 recebendo internet do dedicado e criei um servidor PPPoE na RB750 dai sai o cabo da RB750 e entra no meu loadbalance RB450G e quando um certo link cai os outro links assumem inclusive se o dedicado cair os ADSL assumem coisa que já aconteceu umas 3 vezes do dedicado ter parado por rompimento de fibra e tals, fica a dica pois você pode fazer o mesmo.






Tópicos Similares

  1. loadbalance com oi velox e link IP dinamico
    Por valternatel no fórum Redes
    Respostas: 2
    Último Post: 11-05-2014, 11:16
  2. Respostas: 7
    Último Post: 12-07-2011, 11:24
  3. Balanceamento com 2 links com ip dinamico
    Por kleitonisaac no fórum Redes
    Respostas: 5
    Último Post: 18-02-2008, 12:36
  4. Descobrir meu IP dinamico
    Por Rods no fórum Servidores de Rede
    Respostas: 6
    Último Post: 10-11-2003, 13:38
  5. ip dinamico
    Por no fórum Servidores de Rede
    Respostas: 9
    Último Post: 28-07-2003, 17:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L