+ Responder ao Tópico



  1. Citação Postado originalmente por allac Ver Post
    Eu transformei uma interface dinâmica em fixa, depois disso ele não pegou as rotas dinâmicas do DR ... aguardei uns 5 minutos e nada pegou rotas dos vizinhos adjacentes e nada....

    Ai, habilitei e desabilitei na mão a network e ele pegou na hora as rotas dinamicas ....

    Que bug é esse??

    Tem bug sim!!!
    Boa noite a todos.

    Allan, peço que não tome por ironia os comentários que farei, pois não são.

    Você está com problemas[1], e respeito esse momento de adversidades em sua rede.

    Entretanto, peço que atente para os seguintes fatos:

    1.1) O Under-Linux é um forum público, com atuais 26640 usuários, e que serve há anos de referência em vários países lusófonos[2].

    1.2) Logo, eu não mentiria sobre o funcionamento da rede de meus clientes.

    1.3) Aqui no Under-Linux, uso meu nome[3] verdadeiro, nome que me acompanha desde que nasci, o que reforça o item anterior.

    1.4) Muitos desses clientes estão aqui na lista, lendo esse tópico, e inclusive me autorizaram a divulgar imagens da suas redes, para ajuda você e o icxsoft, ambos com problemas em roteamento dinâmico.

    Com isso, todas as orientações que nesse tópico já provi, de fato funcionam, e foram inclusive endossadas por outros usuários.

    De qualquer forma, vamos fazer um apanhado geral do que você precisa:

    2.1) Atualizar todos os seus ativos que executam o sistema operacional MikroTik RouterOS, a elevar a versão para 5.20, que é a versão mais recente, hoje, dia 19/09/2012.

    2.2) Atualizar o firmware de todos os ativos MikroTik Routerboard de seu rede.

    2.3) Verificar se há badblock na unidade de armazenamento do ativo que está executando o sistema operacional MikroTik RouterOS. O Sérgio Souza já abordou[4] esse tema.

    2.4) Atualizar[5] todos os seus ativos Ubiquiti, elevando para a versão máxima aceitável (não beta) do Ubiquiti AirOS.

    2.5) Usar criptografia MD5 no OSPF. O Warner Maia já abordou publicamente esse tema, durante o MUM Brazil 2011[6].

    2.6) Fazer uso da interface loopback[7].

    2.7) Interface que não "conversa" OSPF, deve ser declarada explicitamente como passiva[8].

    2.8) Não redistribuir rotas conectadas[9]. Isso não é uma característica da MikroTik, pois a documentação da Cisco também não recomenda[10], conforme destacado abaixo:

    Redistributing directly connected networks into routing protocols is not a common practice and is not shown in any of the examples above for this reason.
    2.9) Não precisa usar NBMA para ter OSPF através de enlaces Ubuquiti. NBMA é um trabalho braçal desnecessário, que pode ser calculado assim: n*2, sendo para n o número de enlaces Ubiquiti que você tem.

    2.10) Anuncie suas redes manualmente[9] no OSPF (/routing ospf network).

    2.11) Não faça NAT[5] em interface que "conversa" OSPF. É possível fazer? Sim, é possível, mas por enquanto, até que esteja enraizado no seu entendimento o funcionamento do OSPF, faça de conta que não é possível ter um convívio harmonioso[5] de NAT e OSPF.

    A maioria das dicas acima estão descritas aqui no Under-Linux, em outros tópicos, com as devidas referências (no final dessa mensagem). Com poucas exceções, as referências são para outros sites, que não o próprio Under-Linux.

    E por último, e reforçando a frase que comecei essa mensagem, não estou ironizando, mas recomendo fortemente que você faça o treinamento MTCRE. Não desmerecendo os demais centros de treinamento, mas por experiência própria, recomendo a MDBrasil[11].

    Espero que com isso você resolva o seu problema.

    Desejo uma boa noite a todos. Eu sei que terei minha boa noite de sono, e meus clientes também.

    [1] https://under-linux.org/f343/ospf-quando-cai-nao-volta-rotas-159445/#post638926
    [2] http://www.vivaolinux.com.br/artigo/Alexa-e-o-ranking-dos-principais-sites-Linux-da-comunidade-brasileira?pagina=3
    [3] https://under-linux.org/members/trober/
    [4] https://under-linux.org/f343/dica-bad-blocks-e-ospf-154009/
    [5] https://under-linux.org/f343/sequencia-pra-migrar-rede-bridge-pra-ospf-157849/#post624208
    [6] http://www.tiktube.com/index.php?video=nEfn3aJHaKGqEmmKnLnzEzCunlDolDoH=
    [7] https://under-linux.org/f212/acessando-rbs-na-mesma-rede-156552/#post615422
    [8] https://under-linux.org/f343/ospf-dando-erro-156851/#post617482
    [9] https://under-linux.org/f97/redistribuir-rotas-nulas-com-roteamento-dinamico-ospf-153931/
    [10] http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009487e.shtml
    [11] http://www.mdbrasil.com.br

    Saudações,

    Trober
    Última edição por trober; 19-09-2012 às 12:08. Razão: Correções ortográficas, gramaticais e formato.

  2. Meu roteador que possui o BPG caiu....um problema no nobreak ....

    Depois que voltou ele distribuía a rota default .... nos outros roteadores mas não saia para a internet de jeito nenhum...

    Ai eu fui lá no OSPF do mikrotik, desabilitei e habilitei a distribuição de rotas default no Router BGP e voltou a funcionar a internet nos outros roteadores.

    Na minha opnião outro bug!!



  3. Citação Postado originalmente por trober Ver Post
    Boa noite a todos.

    Allan, peço que não tome por ironia os comentários que farei, pois não são.

    Você está com problemas[1], e respeito esse momento de adversidades em sua rede.

    Entretanto, peço que atente para os seguintes fatos:
    Jamais tomaria qualquer comentário aqui como critica ou deboche ... o ambiente aqui é de colaboração ...

  4. Citação Postado originalmente por trober Ver Post
    2.1) Atualizar todos os seus ativos que executam o sistema operacional MikroTik RouterOS, a elevar a versão para 5.20, que é a versão mais recente, hoje, dia 19/09/2012.

    2.2) Atualizar o firmware de todos os ativos MikroTik Routerboard de seu rede.
    Estão todos nessa versão

    Citação Postado originalmente por trober Ver Post
    2.3) Verificar se há badblock na unidade de armazenamento do ativo que está executando o sistema operacional MikroTik RouterOS. O Sérgio Souza já abordou[4] esse tema.
    Os meus roteadores que funcionam o OSPF são: RB493, RB1100, RB1200, RB800 não verifiquei se tem badblock, não acho que os bugs relacionados estão associados a isso mais ainda assim vou verificar isso.

    Citação Postado originalmente por trober Ver Post
    2.4) Atualizar[5] todos os seus ativos Ubiquiti, elevando para a versão máxima aceitável (não beta) do Ubiquiti AirOS.
    Já estão nessa versão sim, pois minha rede pegou um vírus brabo de ubiquiti e tive de atualizar tudo, sou observador tomei esse cuidado.

    Citação Postado originalmente por trober Ver Post
    2.5) Usar criptografia MD5 no OSPF. O Warner Maia já abordou publicamente esse tema, durante o MUM Brazil 2011[6].
    Não estou usando, isso fará diferença com relação as minhas observações?

    Citação Postado originalmente por trober Ver Post
    2.6) Fazer uso da interface loopback[7].
    To usando em todas e coloquei como passiva como você orientou.

    Citação Postado originalmente por trober Ver Post
    2.7) Interface que não "conversa" OSPF, deve ser declarada explicitamente como passiva[8].
    Não tenho nenhum caso

    Citação Postado originalmente por trober Ver Post
    2.8) Não redistribuir rotas conectadas[9]. Isso não é uma característica da MikroTik, pois a documentação da Cisco também não recomenda[10], conforme destacado abaixo:
    Embora dê mais segurança acho muito trabalhoso e ainda não ví um motivo pratico para não usar...

    Citação Postado originalmente por trober Ver Post
    2.9) Não precisa usar NBMA para ter OSPF através de enlaces Ubuquiti. NBMA é um trabalho braçal desnecessário, que pode ser calculado assim: n*2, sendo para n o número de enlaces Ubiquiti que você tem.
    Estou realmente de saco cheio do nbma, tenho um amigo que me orientou a usa-lo no sentido de poder escolher o DR porém pelo que estudei ele só faria diferença em uma rede com um /24 e muitos roteadores trocando msg OSPF ... Como comecei assim ... Vou descontinuar com calma.

    2.10) Anuncie suas redes manualmente[9] no OSPF (/routing ospf network).

    Citação Postado originalmente por trober Ver Post
    2.11) Não faça NAT[5] em interface que "conversa" OSPF. É possível fazer? Sim, é possível, mas por enquanto, até que esteja enraizado no seu entendimento o funcionamento do OSPF, faça de conta que não é possível ter um convívio harmonioso[5] de NAT e OSPF.
    Não faço NAT em nenhum dos meus 13 roteadores com OSPF porém um roteador que será descontinuado tem NAT ... Será que ele atrapalha a rede toda?


    Citação Postado originalmente por trober Ver Post
    A maioria das dicas acima estão descritas aqui no Under-Linux, em outros tópicos, com as devidas referências (no final dessa mensagem). Com poucas exceções, as referências são para outros sites, que não o próprio Under-Linux.


    E por último, e reforçando a frase que comecei essa mensagem, não estou ironizando, mas recomendo fortemente que você faça o treinamento MTCRE. Não desmerecendo os demais centros de treinamento, mas por experiência própria, recomendo a MDBrasil[11].
    Seria ótimo se eu pude-se fazer sim, vou me organizar para no futuro fazer esse curso. Semana que vem estou em Recife fazendo um curso da ANID com o Rinaldo, sobre BGP.

    Como eu percebi que você é um bom colaborador aqui do fórum e tem me ajudado muito vou postar mais fotos e detalhes, para você me ajudar ainda mais....



  5. Pessoal sem mais discução é só atualizar e ser feliz. Tudo perfeito. MK em 5.20 e UBNT em 5.5.2, o OSPF levanta rapido.






Tópicos Similares

  1. Respostas: 3
    Último Post: 02-03-2017, 17:10
  2. Respostas: 0
    Último Post: 03-02-2016, 09:15
  3. Respostas: 9
    Último Post: 06-12-2013, 09:00
  4. Qnd a REDE CAI o DEBIAN NÃO VOLTA
    Por thicouto no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-08-2006, 22:10
  5. (MX4000 128MB) Quando sai do X o shell não volta em ASCII
    Por cytron no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-10-2005, 00:31

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L