+ Responder ao Tópico



  1. #1

    Padrão Problema OSPF distribuição de rotas.

    Olá, estou enfrentando alguns problemas com utilização de OSPF em alguns cenários especificos.

    Em uma rede com 1 RB1100, 1 RB1200, 4 rb450, eu criei um ambiente para colocar em fase de testes o mpls + ospf.

    nos roteadores rb450 eu tenho duas instâncias( uma default e outra criada por mim), criei duas áreas, associei
    cada área com uma instância e criei as networks associada a sua área em questão.

    criei uma instancia vpls(coloquei essa interface vpls como interface da área x) com outro roteador rb 450 e a intenção era inserir apenas as redes dessa area no vpls.

    coloquei tudo "no" as opções nas instâncias para redistribuir rota estática, diretamente conectada.

    Feito isso, funcionou tudo como deveria funcionar, apenas as redes da area foram inseridas no tunel vpls e apenas as redes da outra área foram propagadas para os outros roteadores.

    Ou seja, eu consegui criar uma espécie de segregação de tráfico ospf.

    Porém, essa semana parou tudo.

    primeiro que as rotas apenas são distribuidas se eu marcar nas instâncias para redistribuir as rotas diretamente conectadas,estáticas, etc..

    segundo que as networks de outra área (y por exemplo) estão sendo distribuidas juntos na área do vpls( x por exemplo).
    Eu testei esse cenário com o 5.19, 5.20.

    Att,

  2. #2

    Padrão Re: Problema OSPF distribuição de rotas.

    Recomendo a leitura do topico talves ajude

    https://under-linux.org/f343/ospf-qu...-rotas-159445/


    Me diga uma coisa,os tuneis MPLS VPLS estão inseridas em qual rb ,nas 450? da uma lida no link abaixo:

    http://wiki.mikrotik.com/wiki/Manual...n_RouterBoards



  3. #3

    Padrão Re: Problema OSPF distribuição de rotas.

    jailtonnetlink,

    Obrigado pela resposta.

    Eu li esse tópico, o que me incentivou a abrir esse tópico devido aos erros estranhos do ospf.

    E, sim o MPLS VPLS está rodando entre 2 mikrotiks 450

  4. #4

    Padrão Re: Problema OSPF distribuição de rotas.

    Citação Postado originalmente por victornunes Ver Post
    jailtonnetlink,
    sim o MPLS VPLS está rodando entre 2 mikrotiks 450

    E preciso que RBS suportem L2MTU >= 1524. Do contrário, o MPLS não funciona
    ,tem rb que suporta somente L2MTU de 1520, e MPLS não funciona. Outro caso típico é o uso de enlaces com Ubiquiti, em que o MTU não ultrapassa 1518,leia o link que te passei,veja que essa rb não suporta MPLS.

    http://wiki.mikrotik.com/wiki/Manual...n_RouterBoards



  5. #5

    Padrão Re: Problema OSPF distribuição de rotas.

    jailtonnetlink, as interfaces de todos os rb estão setados em ou acima de 1526.
    Como eu disse anteriormente, estava funcionando, porém o ospf começou a bagunçar as rotas.

    Seu eu coloco no na configuração do ospf que a rede 192.168.12.0/24 faz parte da area 10, e coloco essa area pertecendo a uma outra instancia, por que raios a area 2( a outra área) tá distribuindo a rede 192.168.12.0/24 ?

    Att

  6. #6

    Padrão Re: Problema OSPF distribuição de rotas.

    a questao nao e setar,e sim de nao suportar.Da uma olhada no outro topico que lhe indiquei,parece que tem um BUG com ospf com enlaces ubiquitis,nao to nem mechendo em nada aqui e torcendo para que nao de problema e que eu tenha que reiniciar rsrsrfs

    https://under-linux.org/f343/ospf-qu...-rotas-159445/



  7. #7

    Padrão Re: Problema OSPF distribuição de rotas.

    Eu to testando isso em bancada apenas com rbs, sem utilização de rádios.

    Att,

  8. #8

    Padrão Re: Problema OSPF distribuição de rotas.

    resumindo, como o ospf deve ser configurado para que eu posso selecionar apenas algumas redes para serem distribuidas por uma
    instância e selecionar outras redes para serem distribuidas por outra instância?

    Ou seja, quero distribuir algumas redes por uma interface e distribuir outras redes por outra interface

    Att



  9. #9

    Padrão Re: Problema OSPF distribuição de rotas.

    Amigo quantas areas vc tem?
    Como está dividido está topologia?
    Teria como colocar um desenho da rede?

  10. #10

    Padrão Re: Problema OSPF distribuição de rotas.

    Claro.

    Como eu não tenho o vision, vou tentar fazer o melhor com as ferramentas que possuo.

    Clique na imagem para uma versão maior

Nome:	         Sem título 1.jpg
Visualizações:	83
Tamanho: 	12,3 KB
ID:      	38755

    Essa é minha topologia.

    Eu crio um vpls entre o roteador da area 2 e area 4.
    Crio uma instância no ospf.
    Crio uma outra área ( área 10) nos roteadores da área 2 e 4.
    Coloco uma rede pertencendo a esa área(área 10)
    Adiciona a interface vpls de cada roteador na aba "interfaces" e coloco eles como point-to-point.

    Ou seja, criei uma segregação de rotas sendo distribuido nas áreas nativas deles e na aŕea 10( utilizada pelo vpls).

    E acontece os seguintes problemas relatado acima.

    Att,



  11. #11

    Padrão Re: Problema OSPF distribuição de rotas.

    Victor a topologia é bem simples mais a maneira como está configurando o OSPF não está correta.

    Vc está usando lobridge para orientar as publicações do OSPF???

    A segregação está STUB ou NSSA???

    Dêem uma olhada nestes videos que vai mudar sua maneira de ver rede roteada.

    - Parte 1/3
    - Parte 2/3
    - Parte 3/3

  12. #12

    Padrão Re: Problema OSPF distribuição de rotas.

    Sim lacierdias, eu estou utilizando lobridge para orientar as publicações da rota ospf e a mesma lobridge para o ldp do mpls, conforme exemplos no wiki do mikrotik.

    E estou utilizando a rede em todas as areas como "default", não como stub ou nssa.

    Eu já tive a oportunidade de ver a sua apresentação no youtube sobre alta disponibilidade, e ali basicamente
    aconselha-se a usar ibgp no backbone e ospf nas erbs.

    Foi cogitado isso aqui, porém não se viu grande ganho em comparação a utilizar ospf como protocolo homogêneo na rede.
    Tinha a questão do vrf para segmentar o trafégo do cliente, porém até então a utilização das vpls como tunéis de ospf tinha dado certo.

    Enfim, caso você tenha alguma leitura, estudo de caso, serei muito grato.

    Att,



  13. #13

    Padrão Re: Problema OSPF distribuição de rotas.

    Victor coloca no seu desenho os ips e os clientes e como fica o tunel.

    Assim poderei te ajudar. :-)

  14. #14

    Padrão Re: Problema OSPF distribuição de rotas.

    Ok.

    Segue minha topologia detalhada.

    Clique na imagem para uma versão maior

Nome:	         imagem.jpg
Visualizações:	82
Tamanho: 	41,5 KB
ID:      	38798
    Eu rodo o mpls, e funciona diretinho.
    A tabela FIB é montada corretamente

    Ai eu fecho um tunel entre rou2 e rou4, crio uma área, associo essa área a interface vpls.
    no rou4, associo a rede 192.168.12.0/24 a área 10 e a a rede 172.30.1.0/24 a área 2.
    no rou2, associo a rede 192.168.11.0/24 a área 10.

    a vizinhança na interface vpls é estabelecida corretamente, chegando ao estágio "full".
    Porém acontece os problemas relatados nos outros posts.

    O ospf distribue as rotas apenas se tiver marcado para distribuir na isntancia, as redes que estão na sua área padrão, tanmbém são distribuidas nas áreas vpls e etc..

    Att,



  15. #15

    Padrão Re: Problema OSPF distribuição de rotas.

    Bom dia.

    Com intuito de colaborar com o "limpeza" do forúm e ajudar outros que tiverem a mesma dúvida, venho dizer que aparentemente consegui resolver o problema.

    Eu não estava declarando a interface loopback como passiva.
    E eu percebi que quando coloca-se manualmente as redes em "/routing ospf network", o ospf apenas vai redistribuir essa rota
    se a interface tiver "up", enquanto, caso se marque na instância para distribuir as rotas diretamente conectadas, etc.., o ospf não utiliza desse mesmo paramêtro; ele distribue as redes mesmo as interfaces estando down.

    Obrigado a todos pela ajuda.

    Att,