+ Responder ao Tópico



  1. #1

    Padrão Script ChangeIp não atualiza.

    Ola pessoal.
    Estou com um problema aqui com o script ChangeIp no Mikrotik, ele não atualiza o ip.
    Já tentei vários script, inclusive um para No-ip que também não atualizava.
    Vi outros tópicos sobre esse assunto mais as soluções apresentadas não resolveram meu problema, ou talvez estou deixando passar algo.
    Peço ajuda pois não sei mais oque fazer.

    Clique na imagem para uma versão maior

Nome:	         change.jpg
Visualizações:	98
Tamanho: 	83,3 KB
ID:      	39357

    O script :

    :log info "DDNS: Begin"
    :global ddns-user "xxxxxxxxxxxx"
    :global ddns-pass "xxxxxxxxx"
    :global ddns-host "xxxxxxxxxxxx.xxx.xx"
    :global ddns-interface "PPPoE1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    ( só lembrando no ligar da carinha na verdade é : e a letra p )

  2. #2

    Padrão Re: Script ChangeIp não atualiza.

    Qual e sua veção desse seu mikrotik amigo ... Me add ae eu posso te ajuda [email protected]



  3. #3

    Padrão Re: Script ChangeIp não atualiza.

    Bom dia. Estou usando a versão 5.20 em uma rb750.

  4. #4

    Padrão Re: Script ChangeIp não atualiza.

    Citação Postado originalmente por Jacksonjm Ver Post
    Bom dia. Estou usando a versão 5.20 em uma rb750.

    entao a regra nao e essa amigo me add no msn q te ajundo caralho



  5. #5

    Padrão Re: Script ChangeIp não atualiza.

    Ja mandei o convite.

  6. #6

    Padrão Re: Script ChangeIp não atualiza.

    Muito obrigado amigo alyssonbmx, resolveu meu problema, agora esta funcionando!