Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa Noite a todos. Gostaria de parabenizar as vídeos aulas do Allan e os tutoriais do Trober, através deles consegui implementar o OSPF em bancada 3 roteadores sem problemas, tudo perfeito. Em um tutorial do Troper ele diz que no Router que terá saída para internet deverá marcar a opção Redistribute Default Route "always as type". Até ai tudo bem. Utilizo aqui uma rb 1100 como concentrador (Nat) e Radiu o Software Topsapp que autentica (pppoe ou hotspot) os clientes. Como faço para interligar minha rede OSPF ou meu concentrador? Ou seja colocar realmente em produção.

  2. Galera percebi que nos meus videos faltaram falar sobre a rota default e sobre os concentradores PPPoE.

    Vou fazer uns videos complementando esse assunto.

    Quanto ao Concetrador PPPoE digo o seguinte o amigo gamineiro tem uma certa razão ... cada coisa de cada vez.

    Na rede toda bridge é mais fácil ter um só concentrador PPPoE. Pois ele é acessível por toda a rede.

    Quando vc tem uma rede roteada realmente isso é mais complicado pois cada interface que os clientes se conectam deve ter um PPPoE Server habilitado nele. O que se torna uma tarefa complicada sob o ponto de vista de quem tinha um concentrador PPPoE passar a ter uns 10 ou mais isso é penoso.

    Fazer com que a autenticação seja somente em um local não é tarefa complicada nem trabalhosa... é tranquilão...

    Agora não sei se o caminho correto é usar o mpls para fazer uma bridge até o concentrador PPPoE único na rede. Técnicamente é possivel e funciona mas vai dar tanto trabalho que não sei se vale a pena. Também não sei o quanto de recursos consome habilitar o mpls em todos os roteadores na rede.

    Eu gostaria de fazer essa pergunta pros feras ? Qual o melhor caminho para que tem uma rede roteada e tem a necessidade de ter vários concentradores PPPoE espalhados pela rede?

    Qual a melhor Pratica? Vários concentradores na Ponta ? Ou criar tuneis até um concentrador só?

    Eu faço essa pergunta para quem tem a necessidade de usar PPPoE não vale me responder para usar outro tipo de pratica tipo IP Fixo, DHCP e etc.



  3. Bom dia a todos

    Citação Postado originalmente por halves Ver Post
    1 - Nas implementações de ospf tem um único roteador que vai distribuir a rota default?
    Sim, conforme o Gabriel informou. A exceção é quando você tem mais circuitos de acesso, em pontos distintos. Mas nem vamos entrar nesse contexto, pois não é o foco do tópico.

    Citação Postado originalmente por halves Ver Post
    2 - Aqui em minha rede uso o Myauth 3, no mikrotik quando eu colocar a rede pertencendo ao ospf lá em network o myauth não entra no ospf, só entra quando coloco 0.0.0.0/0
    Anunciar 0.0.0.0/0 é, tecnicamente, a mesma coisa que anunciar rotas conectadas, o que não é salutar. O que está faltando é você explicitar a rede conectada ao seu autenticador. Se você tem, por exemplo, um /24 para seu autenticador, é só anunciar a rede (e declarar a interface como passiva).

    Existe quem diga que OSPF se faz só com /30, e isso não é verdade. Você pode ter um conjunto de servidores, em seu NOC, dispostos em qualquer rede menos específica que /31 (se IPv4). Adicione a interface voltada para esses servidores, como passiva, e adicione a rede em networks.

    Pronto! Mas tenha cuidado para não ter NAT no fluxo[1] entre roteadores e o autenticador, para não ter problemas com Called-ID, entre outros problemas (típicos de NAT).

    Citação Postado originalmente por pytagoras Ver Post
    Mesmo com o NAT funciona, coloca umas regras de accept para o protocolo ospf antes da regra de NAT.
    Código :
    /ip firewall nat
    add action=accept chain=srcnat disabled=no protocol=ospf
    add action=accept chain=dstnat disabled=no protocol=ospf
    Assim vc garante o funcionamento.
    Quase lá. Os chains não são scrnat, nem dstnat. O fluxo previsto para OSPF acontece em input e output. (244.0.0.5->244.0.0.6) Veja os fluxos no Wiki[1] da MikroTik.

    Desde o MikroTik RouterOS 5.19 não é mais necessária essa "adaptação", muito utilizada no passado. E como parto do princípio de que todos estão usando a versão mais recente, isso não será problema.

    Citação Postado originalmente por carlosallan Ver Post
    Boa Noite a todos. Gostaria de parabenizar as vídeos aulas do Allan e os tutoriais do Trober, através deles consegui implementar o OSPF em bancada 3 roteadores sem problemas, tudo perfeito. Em um tutorial do Troper ele diz que no Router que terá saída para internet deverá marcar a opção Redistribute Default Route "always as type". Até ai tudo bem. Utilizo aqui uma rb 1100 como concentrador (Nat) e Radiu o Software Topsapp que autentica (pppoe ou hotspot) os clientes. Como faço para interligar minha rede OSPF ou meu concentrador? Ou seja colocar realmente em produção.
    Fico feliz que os tutoriais sejam úteis

    Quanto ao NAT, faço-o considerando a especificidade de interfaces e redes de origem

    Pesquise aqui no Under-Linux pelas palavras "convívio", "harmonioso", "NAT" e "OSPF". Não recomendo, mas é possível

    Citação Postado originalmente por allac Ver Post
    Qual a melhor Pratica? Vários concentradores na Ponta ? Ou criar tuneis até um concentrador só?
    Criar túneis até o concentrador é neutralizar o esforço e sentido de ter implementado roteamento na sua rede.

    Citação Postado originalmente por allac Ver Post
    Eu faço essa pergunta para quem tem a necessidade de usar PPPoE não vale me responder para usar outro tipo de pratica tipo IP Fixo, DHCP e etc.
    Não entendi a dificuldade. Se você tem uma rede com vários segmentos de redes, alcançáveis com roteamento entre si, com o uso do OSPF, qual é a dificuldade de decidir se a autenticação será concentrada ou não?

    Vai do quanto você é (ou não) refém do software de gestão.

    O software de gestão é licenciado por usuário? É licenciado por servidor? É licenciado por interface?

    Essas sãos as dúvidas que dificultam a implantação de PPPoE, e não as técnicas de roteamento. O agente PPPoE, tendo o endereço de loopback definido em source-address, e chegando até o concentrador, não tendo endereço traduzido (mascarado), vai funcionar "lindamente". Da mesma forma, se o seu software de gestão fizer chamadas remotas nos roteadores (seja API, telnet ou ssh), adicionando contas e editando perfis, criando entradas em access-list e demais funcionalidades. (Free)Radius idem.

    Com isso, não entendo a dificuldade do cenário.

    [1] http://wiki.mikrotik.com/wiki/Manual:Packet_Flow

    Espero ter ajudado.

    Saudações,

    Trober

  4. Minha autenticação é centralizada. E o software eu mesmo desenvolvi, ele cria os usuários por script. Mas poderia fazer por ssh.

    Eu acho um pequeno transtorno ter de habilitar Servidor PPPoE nas pontas da rede, considerando que antes eu tinha somente um concentrador PPPoE.

    Passei a ter 5 concentradores, ficou mais trabalhoso ver onde o cliente está conectado.

    Além de ficar alguns Ip's no bloco meio que sem uso. Considerando que em alguns casos uso /28 ou /26

    O que vc's acham?



  5. Citação Postado originalmente por allac Ver Post
    Eu acho um pequeno transtorno ter de habilitar Servidor PPPoE nas pontas da rede, considerando que antes eu tinha somente um concentrador PPPoE.
    Penso que o "pequeno transtorno" evita o "grande transtorno" de ter broadcasts passeando por quilômetros de enlaces, principalmente em redes grandes.

    Citação Postado originalmente por allac Ver Post
    Além de ficar alguns Ip's no bloco meio que sem uso. Considerando que em alguns casos uso /28 ou /26
    PPPoE possibilita entrega de endereços em /32, sem as perdas mencionadas. Esses endereços /32 podem ser alocados de forma orquestrada, de forma que possibilite a sumarização em faixas menos específicas/mas abrangentes. Não teria assim uma tabela de roteamento "inflada" sendo atualizada a cada conexão/desconexão de usuário.

    Citação Postado originalmente por allac Ver Post
    O que vc's acham?
    Enfim, minhas considerações.

    Saudações,

    Trober






Tópicos Similares

  1. Ajuda com rede 1.8Km sem visada (arvores)
    Por jerryskt no fórum Redes
    Respostas: 1
    Último Post: 11-03-2008, 02:08
  2. Ajuda em redes
    Por Omega_Red no fórum Assuntos não relacionados
    Respostas: 8
    Último Post: 01-06-2006, 07:43
  3. Ajuda com rede Wireless Indor
    Por allan_nogueira no fórum Redes
    Respostas: 3
    Último Post: 15-03-2006, 16:24
  4. AJUDA URGENTE REDE
    Por lucasbh no fórum Servidores de Rede
    Respostas: 3
    Último Post: 13-01-2006, 10:04
  5. Ajuda em Rede...
    Por clash no fórum Servidores de Rede
    Respostas: 20
    Último Post: 29-04-2005, 19:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L