Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Posta ai a configuração do cron.

  2. Segue abaixo o conteúdo do arquivo /etc/crontab

    SHELL=/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

    # m h dom mon dow user command
    17 * * * * root cd / && run-parts --report /etc/cron.hourly
    25 6 * * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
    47 6 * * 7 root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
    52 6 1 * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )

    #Teste agendamento (agendei desta forma para realizar alguns testes)
    07 * * * * root /bin/bash /root/backup_equipamentos_ubiquiti/ubiquiti-backup

    O agendamento em si está normal. Com alguns testes verifiquei que o script quando agendado não chega a executar o for na lista de ip, tanto que se eu tirar o for e colocar as linhas para backup com os ips, o agendamento funciona normalmente. Pior é que o for funciona perfeitamente quando o script é executado manualmente.



  3. Tente mudar o cabeçario do "for". Ex:
    for i in `cat /home/user/lista_para_backup.txt`; do
    <comandos>...
    done

  4. radar02123

    Realizei estas alterações no script mas o problema continuou. Vou subir o script em outro server, com uma versão mais atualizada do cron para ver se resolve, pq vish este negocio ta muito tenso!



  5. Galera,

    Consegui resolver o problema com uma solução muito simples.

    na linha;

    sshpass -p vantemonitor ssh $i -l admin -o StrictHostKeyChecking=no "cat /tmp/system.cfg" > /backups/ip-$i-backup-`date +%d-%m-%Y_%H:%M`.cfg 2> /dev/null && export FIM=`date +%d-%m-%Y_%H:%M:%S`; echo -e "O backup de $i foi efetuado com sucesso em $FIM" >> /var/log/log_backups_airmax.log


    Mudei e coloquei o caminho completo da pasta onde o script ia gerar o backup. Após isso, funcionou perfeitamente o agendamento pelo cron.


    Obrigado pela a ajuda.
    Abraços






Tópicos Similares

  1. Problemas com a porta LAN de equipamentos UBNT
    Por LinkDedicado-BRASIL no fórum Redes
    Respostas: 3
    Último Post: 29-10-2015, 10:57
  2. Problema com script para controle de banda!
    Por striteiro no fórum Servidores de Rede
    Respostas: 1
    Último Post: 14-07-2009, 07:17
  3. Preciso de um script para backup
    Por Slack_RJ no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-10-2006, 15:58
  4. Problemas com script de logon
    Por grmuniz no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-08-2005, 08:03
  5. Problema com script (IP x MAC + Controle de banda)
    Por sarna no fórum Servidores de Rede
    Respostas: 10
    Último Post: 06-05-2005, 18:34

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L