+ Responder ao Tópico



  1. #1

    Padrão Problema com cache de DNS em RB 750G

    Há alguns meses eu tava com cache de DNS ativo numa RB750G e tudo ok, mas hoje de madrugada simplesmente parou tudo, nao conseguia abrir site algum. Eu verifiquei um monte de coisa e nada de resolver, a ultima coisa que fiz foi colocar um DNS manualmente na placa de rede do PC o acesso voltou. Dei um flush na lista do cache de DNS e nada de resolver, coloquei outros DNS, nada. Então desabilitei o cache e coloquei os DNS no DHCP pra atribui-los automaticamente aos dispositivos requisitantes por um endereço DNS e tudo voltou ao normal. Antes disso eu tinha desligado e religado a RB e sem solução. Entao desliguei mais uma vez, reconfigurei o cache de DNS, sem sucesso, a pagina faz que vai carregar, carrega pela metade ou nem responde. Desativei novamente e volta ao normal. Será pau na memoria NAND da RB ou algo assim ou o cache fica na memoria RAM da RB?

  2. #2

    Padrão Re: Problema com cache de DNS em RB 750G

    Citação Postado originalmente por raumaster Ver Post
    Há alguns meses eu tava com cache de DNS ativo numa RB750G e tudo ok, mas hoje de madrugada simplesmente parou tudo, nao conseguia abrir site algum. Eu verifiquei um monte de coisa e nada de resolver, a ultima coisa que fiz foi colocar um DNS manualmente na placa de rede do PC o acesso voltou. Dei um flush na lista do cache de DNS e nada de resolver, coloquei outros DNS, nada. Então desabilitei o cache e coloquei os DNS no DHCP pra atribui-los automaticamente aos dispositivos requisitantes por um endereço DNS e tudo voltou ao normal. Antes disso eu tinha desligado e religado a RB e sem solução. Entao desliguei mais uma vez, reconfigurei o cache de DNS, sem sucesso, a pagina faz que vai carregar, carrega pela metade ou nem responde. Desativei novamente e volta ao normal. Será pau na memoria NAND da RB ou algo assim ou o cache fica na memoria RAM da RB?

    É problema no software da mikrotik, também aconteceu comigo em algumas rbs 750, na 751 tb acontece mesmo com a v5.22.



  3. #3

    Padrão Re: Problema com cache de DNS em RB 750G

    Nessa RB ainda to com a versão 5.12, nao pude parar pra atualizar e como ta funcionando bem, nao to afim de mexer tb. Pois é, agora vou deixar sem cache de DNS nela...

  4. #4

    Padrão Re: Problema com cache de DNS em RB 750G

    Tive o mesmo problema depois de um upgrade para 5.22, apos retornar para
    versão estavel 4.17 não deu mais problema.



  5. #5

    Padrão Re: Problema com cache de DNS em RB 750G

    Pessoal estou com problemas com o cache de DNS em uma CCR 6.1 referente ao DYNDNS para clientes que acessam DVR pelo serviço.
    Uso PPPoe com ip´s Publicos dinâmicos, quando estava uma RB1100ahx2 estava tudo normal, troquei para CCR 6.1 e começou.
    O problema é que por algum motivo o cache trava no ip que o DVR jogou da primeira vez no momento da configuração pro DYNDNS.
    Daí quando um outro cliente pega aquele ip do inicio da config do DVR o dominio abre a AirGrid de quem está usando o ip no momento.
    Se pingar do DOS no dominio da resposta é deste primeiro ip, mesmo o cliente do DVR estando em outro, no site DYNDNS aparece o correto atualizado em "My Services". Teria que funcionar está tudo certo.
    Mas aí vou lá dou um "Flush Cache" aguardo um pouco e funciona. Abre o DVR e o ping responde pelo ip correto.
    Creio que para solucionar terei que colocar um script para dar um Flush Cache ou deixar de usar o DNS no MK e colocar direto nos Profiles do PPPoe.
    Alguem poderia passar um scritp para limpar de hora em hora, ou melhor tirar o IP>DNS de funcionamento.
    Desde já agradeço a atenção.

  6. #6
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: Problema com cache de DNS em RB 750G

    Deve ser algo com a versão 6.x pois uso aqui a 5.26 com cache DNS e o The Dude testando vários DVRs e não tenho problemas não...
    Para limpar o cache DNS (mas ai vc perde a vantagem de usar cache) agenda no scheduler o comando "/ip dns cache flush"