+ Responder ao Tópico

  1. Citação Postado originalmente por mascaraapj Ver Post
    Os Clientes de diversas Operadoras, mesmo tendo 2, 3, 5 ou 10 Megas... algumas vezes não conseguem fazer download na velocidade máxima dele.
    Sendo necessário abrir 2, 3 ou mais downloads e somar a taxa de transferência para se ter a velocidade máxima.

    Hoje vou ensinar como implementar um controle de Download igual a esses que as Operadoras fazem.

    ### CENÁRIO:
    Esse controle de banda avançado é um QoS, sendo assim, não podemos aplica-lo no mesmo servidor que faz controle de banda dos clientes.
    Logo, essa regra somente irá funcionar na rede daqueles que tem um servidor central, mas fazem a autenticação (e controle de banda) dos clientes na RB mais próxima.
    Anexo 42314

    ### REGRAS (Firewall, Queue):
    Essa Regra deve ser adicionada no ROUTER 1

    /ip firewall mangle
    add action=mark-packet chain=forward comment=ControleDownloadAPJ connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=tcp
    add action=mark-packet chain=forward connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=udp

    /queue type
    add kind=pcq name=ControleDownloadAPJ pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address,dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=5000

    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both disabled=yes interface=all limit-at=0/0 max-limit=0/0 name=ControleDownloadAPJ packet-marks=3mb-0-conn parent=none priority=8 queue=default-small/ControleDownloadAPJ target-addresses=1xx.xx.xxx.0/24 time=17h-23h59m59s,sun,mon,tue,wed,thu,fri,sat total-queue=default-small

    ### COMO FUNCIONA:
    Com as regras acima, um cliente que possua 3 Mega de velocidade, se fizer um teste de velocidade, irá ter a velocidade máxima dele (3 Mega).

    Mas, quando esse cliente fizer um ou mais download, após ter baixado 3mb (connection-bytes). Cada download dele irá entrar no controle de banda avançado do ROUTER1 e sua velocidade de download vai baixar para 512k (pcq-rate).
    Sendo o limite máximo da banda dele o que estiver no Router2, que no caso desse cliente seria de 3 Mega.

    Em outras palavras.
    Um cliente que possua 3 megas de Velocidade, sem essas regras, precisaria fazer 1 ÚNICO download para usar 100% de sua banda.
    Já com essas Regras, o cliente precisaria fazer 6 downloads para usar 100% de sua banda.

    Exemplo:
    Download SEM a Regra - 1 Único download é suficiente para o cliente utilizar 100% de sua banda.
    Anexo 42315

    Download COM a Regra - Mesmo realizando 2 download, não foi o suficiente para o cliente utilizar 100% de sua banda.
    Anexo 42316

    ### ADAPTAÇÃO
    - Podemos fazer com que apenas alguns Clientes passem por essa regra.
    - Podemos fazer com que somente o download de alguns sites específicos passe por essa regra.
    - Podemos fazer com que esse controle funcione em determinado dia da semana ou hora.
    - Podemos fazer com que Diferentes tipos de Planos seja necessário fazer quantidades diferentes de download para atingir 100% da velocidade.

    connection-bytes - Tamanho do download que o Cliente poderá fazer antes de entrar no Controle (default da regra 3mb).
    pcq-rate - velocidade máxima (default da regra 512k) atingida após o cliente ter feito download acima.
    target-addresses - Faixa de IP que será controlada.
    time - Horário de funcionamento da regra

    Enfim, podemos adaptar essas regras para os mais variados tipos.


    Olá bom dia.
    Como posso adaptar essas regras para o seguinte cenário .
    Reduzir a velocidade de todos os clientes da rede ( 0.0.0.0/0 ) para não passar de 600k em um determinado tempo.
    Antes que me perguntem por que isso ! Tenho 2 links de operadoras diferentes. Essa regra somente iria utilizar quando algum link cair.


  2.    Publicidade


  3. Citação Postado originalmente por megabyte Ver Post
    Olá bom dia.
    Como posso adaptar essas regras para o seguinte cenário .
    Reduzir a velocidade de todos os clientes da rede ( 0.0.0.0/0 ) para não passar de 600k em um determinado tempo.
    Antes que me perguntem por que isso ! Tenho 2 links de operadoras diferentes. Essa regra somente iria utilizar quando algum link cair.
    as regras já foram postadas:

    Aqui você controla qual o tamanho do download que o cliente poderá fazer antes de entrar no controle.
    Nessa regra, eu configurei para 3mb (300000).
    Você tambem pode usar essa regra para retirar alguns sites especificos ou para somente agir em determinados sites.
    Código :
    /ip firewall mangle
    add action=mark-packet chain=forward comment=ControleDownloadAPJ connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=tcp
    add action=mark-packet chain=forward connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=udp

    Aqui você controla a velocidade que cada cliente terá após entrar no controle.
    Nessa regra eu configurei em 512k.
    Código :
    /queue type
    add kind=pcq name=ControleDownloadAPJ pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address,dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=5000

    Aqui é o final usado para controlar a banda, veja que ele faz uso do queue type que criamos anteriormente.
    Podemos controlar os clientes que vão fazer parte desse controle aqui, basta adicionar os IPs dele em target-addresses.
    O horário de funcionamento dessa regra também é configurado aqui...
    Código :
    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both disabled=yes interface=all limit-at=0/0 max-limit=0/0 name=ControleDownloadAPJ packet-marks=3mb-0-conn parent=none priority=8 queue=default-small/ControleDownloadAPJ target-addresses=1xx.xx.xxx.0/24 time=17h-23h59m59s,sun,mon,tue,wed,thu,fri,sattotal-queue=default-small

  4. Fiz aqui deu certo. Esse pcq é muito interessante para o provedor que vende bandas de 1MB, 2MB, 3MB acima.
    Dá para ter um controle de trafego muito bom. Aprovado.

  5. Citação Postado originalmente por megabyte Ver Post
    Fiz aqui deu certo. Esse pcq é muito interessante para o provedor que vende bandas de 1MB , 2MB, 3MB acima.
    Dá para ter um controle de trafego muito bom. Aprovado.
    Chamo a atenção para o seguinte:
    1 - Você pode fazer isso antes ou depois, mas faça esse controle em uma RB diferente da que faz o controle de banda dos clientes.
    se fizer na mesma RB, esse controle irá sobrepor o controle normal de cada cliente.

    2 - Se você tiver um cache, pode adicionar a regra de Cache full junto (acima dessas regras).
    Dessa forma, tudo que vem do cache tem a velocidade normal (ou maior, vc q configura), mas tudo que vem da Internet tem a velocidade limitada.

  6. Minha rede aqui é roteada, tenho um concentrador na borda e em cada torre um route. Então coloquei esse controle na borda . Nas torres não mudei nada. Valeu.




Visite: BR-Linux ·  VivaOLinux ·  Dicas-L