Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Se você executar o script na manualmente funciona?

  2. Citação Postado originalmente por bjaraujo Ver Post
    Se você executar o script na manualmente funciona?
    Sim. Os 2 scripts funcionam somente o segundo não checa se esta saindo pelo link principal, mas vou tentar a seguinte solução no ping realizado no script2 vou setar algum IP que faça parte do roteamento do link principal, tipo o Gateway do meu provedor de Internet 1.1.1.1, baseado no exemplo abaixo.
    Ex.: tracert
    10.111.0.1
    10.111.0.254
    1.1.1.1

    Alterado o script ficaria da seguinte maneira:

    :local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 1.1.1.1 interval=3 count=1]=1))}; :if ($i=5 && [/ip route get [find comment="Default Route"] distance]=3) do={:log info "Main Gateway up"; /ip route set [find comment="Default Route"] distance=1}

    Vou realizar o teste e posto o resultado.



  3. Citação Postado originalmente por fabiolaureano Ver Post
    Pessoal, estou testando o script de Failover que esta no wiki.mikrotik.com/wiki/Improved_Netwatch_II. No meu caso o script1 funciona normalmente, mas o script2 não esta atendendo a minha demanda , pois ele realiza o teste de ping para retornar para a rota default, mas não checa se esta saindo pelo link primário, sendo assim sempre que executo o script2 mesmo saindo pelo link secundario e com o link principal fora, ele realiza o ping, resolve o host e volta a rota default para o link primario que ainda esta inoperante.
    Por acaso alguem já utilizou este script e poderia me ajudar a entender e enxergar na onde esta o erro? Ou me ajudar a criar uma validação que force o script2 a passar pelo link primário, para testar o retorno do link.

    script 1:

    :local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=0))}; :if ($i=5 && [/ip route get [find comment="Default Route"] distance]=1) do={:log info "Main Gateway down"; /ip route set [find comment="Default Route"] distance=3}

    script 2:


    :local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=1))}; :if ($i=5 && [/ip route get [find comment="Default Route"] distance]=3) do={:log info "Main Gateway up"; /ip route set [find comment="Default Route"] distance=1}

    oq esta faltando aki e só uma rota estatica. para esse ip 64.233.169.99

    /ip route +

    destination: 64.233.169.99
    gatway: SEU GATWAY PADRAO
    distance:1


    ai vc esta setando que esse ip sempre vai passar pelo seu gatway padrao, e quando ele nao pingar e pq seu gatway padrao parou de funcionar, e vai rodar os script certinho

  4. Citação Postado originalmente por isacloko Ver Post
    oq esta faltando aki e só uma rota estatica. para esse ip 64.233.169.99

    /ip route +

    destination: 64.233.169.99
    gatway: SEU GATWAY PADRAO
    distance:1


    ai vc esta setando que esse ip sempre vai passar pelo seu gatway padrao, e quando ele nao pingar e pq seu gatway padrao parou de funcionar, e vai rodar os script certinho
    Caro isacloko a tua dica funcionou perfeitamente solucionando o problema. Realizei o teste de alterar o ping para o gateway do meu provedor de serviços tambem funcionou, mas corro o risco de perda de funcionalidade caso o provedor altere o gateway padrao. Muito obrigado a todos pela atenção.






Tópicos Similares

  1. Resolvido problemas com módulos no kernel 2.6
    Por estanisgeyer no fórum Servidores de Rede
    Respostas: 7
    Último Post: 20-04-2006, 00:51
  2. Acesso Remoto Via VNC Desconectando(Resolvido)
    Por Edivan no fórum Servidores de Rede
    Respostas: 4
    Último Post: 15-12-2004, 23:39
  3. "C-Media um problema nunca resolvido"
    Por mcyberx no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-08-2004, 22:25
  4. "Resolvido" o problema !
    Por kaka1983 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-05-2004, 14:53
  5. Failover entre dois adaptadores
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-08-2003, 14:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L