+ Responder ao Tópico



  1. #1
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Clique na imagem para uma versão maior

Nome:	         LogoAcessoRemoto.jpg
Visualizações:	208
Tamanho: 	33,0 KB
ID:      	47674

    Olá pessoal venho através deste tutorial ensinar como fazer um acesso remoto para seu Mikrotik pelo WinBox de qualquer lugar

    Existe muita gente que não sabe fazer o acesso remoto, ou acessa da forma mais difícil, deixando algum computador ligado em casa para entrar por programa tipo, VNC, TeanWiever, Logmein em fim... vamos ao tutorial

    1º) Vamos criar uma conta no site nonip www.noip.com/newUser.php


    Clique na imagem para uma versão maior

Nome:	         Criar Conta.jpg
Visualizações:	141
Tamanho: 	35,4 KB
ID:      	47663

    • Bote seu nome de usuário e senha e e-mail válido, próximo passo não vamos criar um host agora, clique em "Creat My Hostname Later"


    Clique na imagem para uma versão maior

Nome:	         CreatMyHostnameLater.jpg
Visualizações:	144
Tamanho: 	54,7 KB
ID:      	47664

    • Clique em Sign Up para ativar uma conta gratuita


    Clique na imagem para uma versão maior

Nome:	         Sign UP.jpg
Visualizações:	122
Tamanho: 	49,7 KB
ID:      	47665

    • Vá até a sua caixa de entrada e confirme seu e-mail


    Clique na imagem para uma versão maior

Nome:	         Confirmação de E-mail.jpg
Visualizações:	135
Tamanho: 	48,5 KB
ID:      	47666


    • Após clicar no link que o site noip mandou para você confirme digitando seu nome e senha para concluir o cadastro.


    Clique na imagem para uma versão maior

Nome:	         Conta nome e senha.jpg
Visualizações:	139
Tamanho: 	43,8 KB
ID:      	47669

    • Após entrar clique em "Hosts/Redirects" e depois "Add a Host"

    Clique na imagem para uma versão maior

Nome:	         Hosts.jpg
Visualizações:	142
Tamanho: 	48,5 KB
ID:      	47667

    • Crie um hostname para o tutorial eu botei meuservidorr.sytes.net que o sytes.net é gratuito, após escolhido clique em "Add Host"

    Clique na imagem para uma versão maior

Nome:	         Sytes.net.jpg
Visualizações:	162
Tamanho: 	108,4 KB
ID:      	47668

    • Pronto seu hostname foi criado agora vamos baixar um programa DUC "Dynamic Update Client" https://www.noip.com/downloads.php Link direto: DUCSetup_v4_0_1.7z

    Clique na imagem para uma versão maior

Nome:	         DUC.jpg
Visualizações:	151
Tamanho: 	85,7 KB
ID:      	47670

    • Baixe o programa DUC e instale, após instalar ele pedirá um nome e senha, bote o mesmo nome e senha que você fez para a conta no site noip

    Clique na imagem para uma versão maior

Nome:	         Nome e Senha DUC.jpg
Visualizações:	143
Tamanho: 	49,9 KB
ID:      	47652


    • Agora clique em Edit Hosts e selecione o hostname que você criou para ele começar a verificar.

    Clique na imagem para uma versão maior

Nome:	         DUC Edit Hosts.jpg
Visualizações:	122
Tamanho: 	54,9 KB
ID:      	47653Clique na imagem para uma versão maior

Nome:	         DUC Selecionar Servidor.jpg
Visualizações:	120
Tamanho: 	48,7 KB
ID:      	47654
    Clique na imagem para uma versão maior

Nome:	         DUC OK.jpg
Visualizações:	143
Tamanho: 	53,1 KB
ID:      	47655

    • Se tudo deu certo o programa DUC irá ficar com 3 marcações em verde dizendo que está tudo OK, agora vamos botar o programa DUC para inicializar junto com o windows, segue na imagem:


    Clique na imagem para uma versão maior

Nome:	         DUC File Preference Start.jpg
Visualizações:	152
Tamanho: 	79,5 KB
ID:      	47656

    - Este programa DUC irá mandar seu IP atual para o site noip poder fazer o redirecionamento correto para seu hostname funcionar corretamente, este programa DUC é uma alternativa para o seu PC, mas irei mandar as regras para adicionar no seu microtik, para ele fazer este serviço que o DUC faz, eu mesmo deixo os dois. Segue:

    http://wiki.mikrotik.com/wiki/Dynami..._for_No-IP_DNS

    Como você pode ver as regras são de alterações simples

    • Vá em systen>scripts e crie um novo script com o nome no-ip_ddns_update deixe marcado write, test, read e cole a regra, mas tem que altera-la antes para poder funcionar veja o exemplo:

    Em "your no-ip user" bote seu nome de usuário
    e em your no-ip pass bote sua senha, a mesma que você botou no site noip

    # No-IP User account info
    :local noipuser "[email protected]"
    :local noippass "minhasenhadeteste"

    # Adicione o site que você criou no noip caso queira adicionar mais sites adicione uma "Virgula" "," para poder adicionar e sem espaços.
    :local noiphost "meuservidor.sytes.net"

    # Adicione o nome da porta de entrada de sua internet caso queira saber aonde fica o nome da entrada da internet vá em "Interfaces" no winbox lá tem o nome
    :local inetinterface "Entrada de Internet"
    Clique na imagem para uma versão maior

Nome:	         Script.jpg
Visualizações:	168
Tamanho: 	59,6 KB
ID:      	47658

    Clique aqui para baixar o texto para aplicar no scripts faça as suas alterações primeiro. Systen Scripts No-IP.txt

    • Agora vamos criar um scheduler para ativar de 5 em 5 minutos o script que nós criamos

    • Vá em systen>scheduler e crie uma regra:

    /system scheduler add comment="Update No-IP" disabled=no interval=5m \ name=no-ip_ddns_update on-event=no-ip_ddns_update policy=read,write,test

    Clique na imagem para uma versão maior

Nome:	         Update.jpg
Visualizações:	155
Tamanho: 	48,8 KB
ID:      	47659

    Pronto! Agora o seu Mikrotik irá fazer as atualizações de IP para o site noip.

    Agora vamos ao winbox e vamos ver qual a porta que se destina abrir o winbox:

    • vá em IP>Services e veja qual é a porta em que seu winbox funciona:

    Clique na imagem para uma versão maior

Nome:	         PortaWinbox.jpg
Visualizações:	180
Tamanho: 	36,3 KB
ID:      	47660

    No caso a minha é 8291, pode ser diferente no seu mikrotik mas não precisa alterar, iremos usa-la para fazer o Nat no seu modem.

    • Veja tambem qual é o IP da interface de entrada da internet de seu mikrotik:

    • Vá em IP>Addresses e veja o IP, o IP pode variar dependendo de como foi configurado o seu Mikrotik

    Clique na imagem para uma versão maior

Nome:	         Entrada de Internet.jpg
Visualizações:	201
Tamanho: 	36,9 KB
ID:      	47661

    Pronto! Agora sabemos que o ip é 192.168.1.4 e a porta é 8291, vamos agora liberar o IP do seu mikrotik no modem de sua internet, pode ser qualquer modem que tenha pelomenos uma opção de liberação de portas como NAT que fica em firewall, este passo depende muito de modem para modem, cada um tem configurações diferentes, mas irei mostar como fiz no meu para poder funcionar.

    • Digite o IP de seu modem, caso não saiba normalmente ele é o primeiro IP de seu range de IP, no caso o meu é 192.168.1.1, digite o IP de seu modem no navegador e entre com o nome e senha, no meu caso é Nome=admin Senha=gvt12345

    Clique na imagem para uma versão maior

Nome:	         Modem Interface.jpg
Visualizações:	150
Tamanho: 	29,3 KB
ID:      	47671

    • Procure as configurações de Firewall e Nat, no meu é assim ADVANCED>NAT>Virtual Server>ADD


    Clique na imagem para uma versão maior

Nome:	         Advanced.jpg
Visualizações:	167
Tamanho: 	85,3 KB
ID:      	47672

    • Clicando em ADD você irá botar o IP e porta de seu mikrotik veja na imagem:

    Clique na imagem para uma versão maior

Nome:	         Configurações.jpg
Visualizações:	186
Tamanho: 	54,9 KB
ID:      	47673

    Pronto digite corretamente as configurações de seu IP e porta e aplique, logo depois é só reiniciar seu modem.

    Você já pode fazer o loguin em qualquer lugar que você esteja, pode testar qualquer dúvida é só avisar embaixo.


    Clique na imagem para uma versão maior

Nome:	         LogoAcessoRemoto.jpg
Visualizações:	208
Tamanho: 	33,0 KB
ID:      	47674
    Última edição por mjmmarcus2; 24-08-2013 às 13:57. Razão: faltou uma pequena atualização

  2. #2

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Parabéns, amigo Mjmmarcus2, pela sua iniciativa em dar essa força para o pessoal... eu conheço uma outra forma de acesso remoto, mas foi muito legal conhecer essa nova forma... interessante mesmo.

    Muito bom o seu tutorial.

    Abraço.



  3. #3

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Parabens Amigo!

    Gera um aquivo desse para que possamos fazer download.

  4. #4

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Parabéns pela iniciativa.


    Grato.



  5. #5
    Avatar de ShiFT
    Ingresso
    Sep 2010
    Localização
    Francisco Beltrão - PR
    Posts
    113

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Dessa forma eu consigo fazer com o modem em modo router? Não estou usando bridge na rede.

    Meu modem é um Tomsom TG508

  6. #6

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Amigo Mjmmarcus2, vc sabe informar se essa regra funciona para mikrotik versão 3.20? Alguns scripts q encontrei funcionam bem para mk a partir da versão 4.x.

    Estou usando um script que apesar de estar tudo funcionando perfeitamente, aparece essa mensagem: ddns error > Server Error. Não deveria aparecer a mensagem: "DDNS: No update required."?

    Confira: https://under-linux.org/showthread.p...650#post688650

    Abraço.



  7. #7
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Citação Postado originalmente por ShiFT Ver Post
    Dessa forma eu consigo fazer com o modem em modo router? Não estou usando bridge na rede.

    Meu modem é um Tomsom TG508
    Acredito que irá funcionar sim, liberando certinho as configurações de IP e porta no seu moden.

    Citação Postado originalmente por Poemander Ver Post
    Amigo Mjmmarcus2, vc sabe informar se essa regra funciona para mikrotik versão 3.20? Alguns scripts q encontrei funcionam bem para mk a partir da versão 4.x.
    Acabei de dar uma olhada no tópico, mas sobre que vai funcionar em outros MK eu tenho certeza que sim, siga o tutorial passo a passo e depois mande uma resposta para ver se funcionou.

  8. #8
    Avatar de ShiFT
    Ingresso
    Sep 2010
    Localização
    Francisco Beltrão - PR
    Posts
    113

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Citação Postado originalmente por mjmmarcus2 Ver Post
    Acredito que irá funcionar sim, liberando certinho as configurações de IP e porta no seu moden.
    Cara, testei e não deu cara.. O ip que me aparece é o 192.168.6.1 que é referente ao ip da rede do modem, e não da entrada de net.

    E se tiver alguma porta pra liberar pra esse serviço, qual porta seria?

    agradecido desde já.



  9. #9

    Padrão Re: Acesso Remoto ao Winbox - Tutorial Passo a Passo

    Amigo Mjmmarcus2, fiz exatamente o que estava no seu tutorial, troquei o script q eu havia colocado pelo seu, tudo devidamente alterado e até funcionou mas, quando eu reiniciei o mk passou a não funcionar mais.

    Vc sabe o que pode estar acontecendo?

    Abraço.

    PS: não sei se foi impressão minha... mas depois que executei o aplicativo DUC, eu consegui acesso remoto. Não tem como fazer o scrpit funcionar sem precisar rodar toda vez esse programa como se fazia Change IP? O script não deveria fazer isso sozinho?

    Abraço.
    Última edição por Poemander; 26-11-2013 às 14:19.