+ Responder ao Tópico



  1. #1

    Padrão Problema BGP com três saídas de link, mas upload sai somente por um

    Bom dia amigos,
    Estou com um problema que esta me tirando o sono, tenho um BGP ativo a mais de 2 anos com a GVT, essa semana tive que aumentar o link e por falta de viabilidade eles me entregaram duas portas de 100mb ao invés de 1 só.
    Até ai tudo bem, o problema foi que, configurei o BGP nas 3 porta, link antigo de as 2 portas novas, tudo funcionou legal o balanceamento de download esta ok, porém o upload sobe todo pelo primeiro link, e o pior se derrubo esse link o bgp não funciona nas 2 portas novas.
    Em router as rotas recebidas pelos links novos ficam unreacheble não era pra ficar recursive ?
    Alguém já passou por isso ?

  2. #2

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Se entendi bem eles entregaram para você mais dois links, você já tinha um e instalaram mais dois em 2 interfaces separadas, correto? Pelo menos isso que entendi da sua explicação.
    Caso seja isso para cada interface estão entregando IPs para você de que forma, /29 /30 ou em loopback?
    Pelo que entendi na forma que você passou teria que fechar 3 sessões com eles correto?

    Passa mais detalhes para podermos debater com o forum.



  3. #3

    Cool Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Citação Postado originalmente por tecnic Ver Post
    Bom dia amigos,
    Estou com um problema que esta me tirando o sono, tenho um BGP ativo a mais de 2 anos com a GVT, essa semana tive que aumentar o link e por falta de viabilidade eles me entregaram duas portas de 100mb ao invés de 1 só.
    Até ai tudo bem, o problema foi que, configurei o BGP nas 3 porta, link antigo de as 2 portas novas, tudo funcionou legal o balanceamento de download esta ok, porém o upload sobe todo pelo primeiro link, e o pior se derrubo esse link o bgp não funciona nas 2 portas novas.
    Em router as rotas recebidas pelos links novos ficam unreacheble não era pra ficar recursive ?
    Alguém já passou por isso ?
    10
    tecnic

    1) Seu upload realmente vai sair somente por um link, pois quem controla o trafego de saída de sua rede é o seu servidor de borda e não a operadora, então faça um balanceamento de upload para os seus 3 links.

    2) Você possui 3 Sessões BGP, 1 para cada Link correto? Para as 3 sessões você está anunciando como a sua rede? As sessões são levantadas com /30 que a operadora te entrega de cada link?

    3) Já pensou em utilizar algum outro tipo de equipamento para borda sem ser mikrotik? Pois pode ser o bug da rota presa do mikrotik...



    se precisar de ajuda me add no skype: alissonx2

  4. #4

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Citação Postado originalmente por alissonx Ver Post
    10
    tecnic

    1) Seu upload realmente vai sair somente por um link, pois quem controla o trafego de saída de sua rede é o seu servidor de borda e não a operadora, então faça um balanceamento de upload para os seus 3 links.

    2) Você possui 3 Sessões BGP, 1 para cada Link correto? Para as 3 sessões você está anunciando como a sua rede? As sessões são levantadas com /30 que a operadora te entrega de cada link?

    3) Já pensou em utilizar algum outro tipo de equipamento para borda sem ser mikrotik? Pois pode ser o bug da rota presa do mikrotik...



    se precisar de ajuda me add no skype: alissonx2
    Sim possuo 3 sessões de BGP, as sessões são levantadas com /30 que a operadora me forneceu, o anuncio nas 3 sessões estou anunciando meu /21 por questão de Failback.



  5. #5

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Citação Postado originalmente por tecnic Ver Post
    Sim possuo 3 sessões de BGP, as sessões são levantadas com /30 que a operadora me forneceu, o anuncio nas 3 sessões estou anunciando meu /21 por questão de Failback.
    Certo,

    pode ser algum problema em suas configurações ou a falta de alguma configuração.

    ja revisou suas regras?

    Caso precise de alguma ajuda pode me adicionar no skype: alissonx2

  6. #6

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Teria de ter Full Routing em todas sessões e fazer o balanceamento por filtros acertando qual range sai por onde vc quer...



  7. #7

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Como dito anteriormente, quem controla o UPLOAD é voce.

    Possivelmente ha alguma configuração errada de rotas de saída ou filtros.

  8. #8

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Boa tarde amigos,

    Concordo com o amigo #alissonx, seria interessante reduzir esses peers, fechando uma sessão com loopback... Uso dessa forma com a própria GVT, controle de upload perfeito e um balanceamento bem simetrico!

    Atenciosamente.
    Emanuel Linoan F Junior
    Zone Network - Soluções Eficientes em TI
    (079) 9903.1467/VIVO
    http://www.zonenetwork.com.br/
    [email protected]
    Skype: zone.network

    Citação Postado originalmente por alissonx Ver Post
    Como dito anteriormente, quem controla o UPLOAD é voce.

    Possivelmente ha alguma configuração errada de rotas de saída ou filtros.
    Última edição por kabelinho; 27-02-2014 às 15:00.



  9. #9

    Padrão Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Boa tarde amigos,

    Tenho um cenário parecido, tenho 2 link com operadoras distintas, tenho um /21, minhas sessões estão full routing, no bgp (Quagga) quebrei o /21 em vários /24 para enviar os prefixos em cada operadora, estou tendo problema com upload baixo, como faço para balancear a carga ou alguém poderia mandar um print de exemplo para manipular download e upload, segue como está configurado.


    router bgp xxxx
    bgp router-id x.x.x.x
    network x.x.128.0/24

    ip prefix-list CIR_128 seq 5 permit x.x.128.0/24

    route-map OPERADORA-OUT permit 10
    match ip address prefix-list CIR_128

  10. #10

    Thumbs up Re: Problema BGP com três saídas de link, mas upload sai somente por um

    Citação Postado originalmente por diegovilela01 Ver Post
    Boa tarde amigos,

    Tenho um cenário parecido, tenho 2 link com operadoras distintas, tenho um /21, minhas sessões estão full routing, no bgp (Quagga) quebrei o /21 em vários /24 para enviar os prefixos em cada operadora, estou tendo problema com upload baixo, como faço para balancear a carga ou alguém poderia mandar um print de exemplo para manipular download e upload, segue como está configurado.


    router bgp xxxx
    bgp router-id x.x.x.x
    network x.x.128.0/24

    ip prefix-list CIR_128 seq 5 permit x.x.128.0/24

    route-map OPERADORA-OUT permit 10
    match ip address prefix-list CIR_128
    Para todos deste topico.

    Nao importa se vc esta usando Mikrotik, Quagga, Cisco, OpenBGP.

    1) O Download é definido através dos filtros BGP escolhendo cada faixa quebrada para qual operadora vai ser enviada, se vc tem um /22, anuncie 1 /21 para cada, porem em BGP não existe magica para balancear trafego de download de forma igualitária, o que vc tem que fazer é uma métrica, exemplo: 1000 clientes no primeiro /21 e 1000 clientes no segundo /21.
    PS: Download quem controla é a operadora.

    2) O Upload é definido através de regras do seu equipamento, pois a saída da sua rede quem controla exclusivamente é VOCE. Para alguns equipamentos é indicado fazer regras via firewall, para outros via regras ECMP e por ai vai.
    PS: Upload quem controla é voce.

    Creio que seja isso, se falei alguma besteira, por favor me corrijam.



  11. #11

    Padrão

    Alguém poderia me dar dica de como posso fazer para marcar pacotes vindas de cada Peer, pois não tenho rota padrão. Para assim poder encaminhar o upload pelo peer que entrou o pacote.

  12. #12

    Padrão

    Pessoal o que aconteceu com esse forum, era tão bom, hoje o pessoal juntou todos os posts e ninguém responde a mais nada, ninguém para ajudar ?



  13. #13
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão

    Boa tarde a todos,

    Tenho algumas considerações que podem ser úteis.

    Citação Postado originalmente por alissonx Ver Post
    PS: Download quem controla é a operadora.
    Amigo @alissonx, você pode SIM controlar o seu download, da mesma maneira que controla o upload, com filtros.

    Vou focar no upload, que é o que o autor do tópico está precisando, se alguém quiser saber sobre download, falamos depois.

    Existe um parâmetro no BGP que chama-se local-preference, que é um dos atributos responsáveis pela decisão de quais rotas serão instaladas na FIB. Por padrão, o valor de local-preference é 100, mas fica oculto quando visualizamos as rotas.

    Sendo assim, podemos criar filtros com base no DESTINO, e dizer qual dos links será o responsável por esse tráfego. Segue alguns exemplos de filtros.

    Código :
    /routing filter
    add chain=IN-FILTERS-OPERADORA-A prefix=0.0.0.0/0 prefix-length=0-32 set-bgp-local-pref=100

    Este filtro é apenas didático, pois irá mostrar 100 no campo local-preference.

    Código :
    /routing filter
    add chain=IN-FILTERS-OPERADORA-A  prefix=200.0.0.0/8 prefix-length=8-32 set-bgp-local-pref=120
    add chain=IN-FILTERS-OPERADORA-A  prefix=201.10.0/16 prefix-length=16-32 set-bgp-local-pref=120

    Este dois filtros fazem com que qualquer rota dentro dos blocos informados acima tenho um preferencia MAIOR (set-bgp-local-pref=120) comparada as rotas com valor padrão (set-bgp-local-pref=100), sendo assim, o trafego de UPLOAD destinado à esses blocos será direcionado para a operadora A.

    Faça alguns testes e poste os resultados para analisarmos juntos.

    Abraço