+ Responder ao Tópico



  1. #1

    Padrão VPLS não volta quando há alteração na rede.

    Bom, montei um laboratório com 7 roteadores em bancada em formato anel, levantei o OSPF e MPLS certinho e interface VPLS com tunel linkando normalmente, porem... quando acontece alguma alteração na rede ( por exemplo, um roteador do caminho mais curto cai e o OSPF refaz as rotas ) o tunel VPLS para de funcionar, sendo necessário eu acessar a RB principal de onde partem os tuneis e desativar/ativar a interface VPLS ai volta ao normal.
    Alguém já passou por esse problema ? tem ideia do que pode estar acontecendo ?

  2. #2

    Padrão Re: VPLS não volta quando há alteração na rede.

    Voce criou uma interface de loopback e colocou um ip nela pra usar como transporte na mpls ou esta usando o ip da propria interface de rede?



  3. #3

    Padrão Re: VPLS não volta quando há alteração na rede.

    Tenho bridges aplicadas nos roteadores com ip para acesso ( logicamente é a mesma coisa que uma loopback, só não tem o nome "loopback" mesmo kkk )

    A ideia é ter um anel reduntante em OSPF ( uso rstp+vlan hoje porem não esta me agradando em alguns pontos ) com autenticação centralizada em uma 1100ahx2 dentro do cpd.

    Na bancada, os tuneis funcionam ok após configurados, porem, quando acontece alguma coisa no OSPF que implique em alteração nos LSA's mesmo que não seja relacionado a rota do roteador aonde o VPLS esta, o mesmo cai, só volta se eu for no roteador de onde partem os tuneis VPLS e desativo/ativo a interface VPLS.

  4. #4

    Padrão Re: VPLS não volta quando há alteração na rede.

    Estranho... eu tenho ospf+mpls+vpls+pppoe rodando e quando cai um ponto ele muda e sobe as vpls.
    Nas bridges que uso pra loopback uso ip 10.1.1.X/32 em todas as rbs e no meu caso nao eh o ip de acesso pois uso ips validos em todas as RBs. Utilizo esse 10.x.x.x somente pra mpls e vpls pois assim se mudar qualquer coisa na minha rede o mpls continua ok.



  5. #5

    Padrão Re: VPLS não volta quando há alteração na rede.

    Qual a versão do ROs que você esta usando nos seus roteadores ? Usa alguma manobra de custo no OSPF ? Você fez alguma alteração de MTU nas suas interfaces pra rodar redondinho igual está hoje ?

    É muito estranho, e o mais interessante é que, caso um caminho pare o OSPF publica tudo certinho e levanta o outro caminho, tanto é que eu continuo com acesso aos roteadores, porem a interface vpls não levanta.

  6. #6

    Padrão Re: VPLS não volta quando há alteração na rede.

    versoes 5.8, 5.20.5.24 e mais algumas perdidas. kkkk
    Os custos mantive os mesmos, nao alterei nada. MTU testei com varios e hj mantive o 1508.

    O ip que esta rodadando na mpls eh um ip /32 que colocasse na bridge ou eh o mesmo que ta na interface e que vc usa pra acessar?
    e na vpls? vc colocou o ip destino com o mesmo que esta na interface ou usou um /32 tambem??

    Axo que a chave esta nesses ips!



  7. #7

    Padrão Re: VPLS não volta quando há alteração na rede.

    Bom, no caso eu uso ips /32 aplicados em bridge ( loopback mesmo, só o nome dela que esta access porem não tem nenhuma interface aplicada nessa bridge, é só o ip ) , porem, uso o 1.1.1.1/32 no central e nos outros nós uso 162.162.163.3/32 .4/32 até o .9/32, tudo relacionado ao OSPF e MPLS esta setado com ips de loopback devido o fato de se usar ip de interface fisica e a porta fica down o ip fica inutilizável. Vou tentar refazer tudo novamente e trocar o mtu das interfaces p/ 1508 e fazer primeiro com 2 roteadores, depois com 3, e assim sucessivamente, vamos ver o que vai dar, dependendo do que der já posto novamente.

  8. #8

    Padrão Re: VPLS não volta quando há alteração na rede.

    Blza... tenta ai.. qualquer coisa da um grito.



  9. #9

    Padrão Re: VPLS não volta quando há alteração na rede.

    Após 2 dias de labuta pra ativar um enlace licenciado no nosso provedor, consegui tirar um tempinho e mexer no laboratório ospf/mpls/vpls, e descobri aonde eu estava errando.

    Nas loopbacks, no meu designated router eu colocava o ip 1.1.1.1/32 e nos outros nós eu colocava 162.162.163.x/32, acho que por serem de classes diferentes não funcionava quando o ospf tinha que virar para o outro lado, então fiz o teste separando uma faixa ( 192.168.100.x/32 ) e apontei no mpls e funcionou perfeitamente

    Obrigado pela ajuda amigo, agora é só forçar + alguns testes e partir pro estudo da implementação, chega de rstp kkk

  10. #10

    Padrão Re: VPLS não volta quando há alteração na rede.

    Axo que te falei isso num post acima. quando disse eu uso 10.1.1.x/32 em todas...