+ Responder ao Tópico



  1. #1

    Padrão Bgp com 3 link da mesma operadora

    Boa tarde,

    Pessoal a GVT não quer mais Fazer upgrade aqui na região mais está vendendo links de 100mb ai me patrão comprou 300mb 3x100mb. Como posso fazer para subir meu bgp pelos 3?

  2. #2

    Padrão Re: Bgp com 3 link da mesma operadora

    Configuração

    No Router A:

    # loopback interface
    /interface bridge add name=lobridge

    # addresses
    /ip address add address=1.1.1.1/24 interface=ether1
    /ip address add address=2.2.2.1/24 interface=ether2
    /ip address add address=3.3.3.1/24 interface=ether3
    /ip address add address=9.9.9.1/32 interface=lobridge

    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2,3.3.3.2

    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.2 remote-as=65000 update-source=lobridge

    No Router B:

    # loopback interface
    /interface bridge add name=lobridge

    # addresses
    /ip address add address=1.1.1.2/24 interface=ether1
    /ip address add address=2.2.2.2/24 interface=ether2
    /ip address add address=3.3.3.2/24 interface=ether3
    /ip address add address=9.9.9.2/32 interface=lobridge

    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.1/32 gateway=1.1.1.1,2.2.2.1,3.3.3.1

    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge

    # a route to advertise
    /routing bgp network add network=4.4.4.0/24

    Resultados

    Checke esta BGP connection se esta estabelicida:

    [[email protected]] > /routing bgp peer print status
    Flags: X - disabled
    0 name="peer1" instance=default remote-address=9.9.9.1 remote-as=65000
    tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no hold-time=3m
    ttl=255 in-filter="" out-filter="" address-families=ip
    update-source=lobridge default-originate=no remote-id=1.1.1.1
    local-address=9.9.9.2 uptime=28s prefix-count=0 updates-sent=1
    updates-received=0 withdrawn-sent=0 withdrawn-received=0 remote-hold-time=3m
    used-hold-time=3m used-keepalive-time=1m refresh-capability=yes
    as4-capability=yes state=established

    Route table no Router A:

    [[email protected]] > /ip route print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC G GATEWAY DISTANCE INTER...
    0 ADC 1.1.1.0/24 1.1.1.1 0 ether1
    1 ADC 2.2.2.0/24 2.2.2.1 0 ether2
    2 ADC 3.3.3.0/24 3.3.3.1 0 ether3
    3 ADb 4.4.4.0/24 r 9.9.9.2 200 ether1
    ether2
    4 ADC 9.9.9.1/32 9.9.9.1 0 lobridge
    5 A S 9.9.9.2/32 r 1.1.1.2 1 ether1
    r 2.2.2.2 ether2
    r 3.3.3.2 ether3

    [[email protected]] > /ip route print detail
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    0 ADC dst-address=1.1.1.0/24 pref-src=1.1.1.1 interface=ether1 distance=0 scope=10

    1 ADC dst-address=2.2.2.0/24 pref-src=2.2.2.1 interface=ether2 distance=0 scope=10

    2 ADC dst-address=3.3.3.0/24 pref-src=3.3.3.1 interface=ether3 distance=0 scope=10

    3 ADb dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2,ether3
    gateway-state=recursive distance=200 scope=40 target-scope=30
    bgp-local-pref=100 bgp-origin=igp received-from=9.9.9.2

    4 ADC dst-address=9.9.9.1/32 pref-src=9.9.9.1 interface=lobridge distance=0 scope=10

    5 A S dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2,3.3.3.2 interface=ether1,ether2,ether3
    gateway-state=reachable,reachable distance=1 scope=30 target-scope=10

    a routa 4.4.4.0./24 esta instalada em Linux kernel agora com tres nexthops: 1.1.1.2 (on ether1) ,

    2.2.2.2 (on ether2) and 3.3.3.2 (on ether3).

    Exemplo com eBGP
    Configuracao

    O exemplo dado acima é desenvolvido para o caso eBGP. Por padrão, os pares eBGP são obrigatórios

    para ser acessado diretamente. Se estamos usando interfaces loopback, que tecnicamente não são, por

    isso, multihop=yes configuração deve ser especificada.

    No Router A:

    /routing bgp instance set default as=65000
    /routing bgp set peer1 remote-address=9.9.9.2 remote-as=65001 update-source=lobridge multihop=yes

    No Router B:

    /routing bgp instance set default as=65001
    /routing bgp set peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge multihop=yes

    Resultados

    Se agora imprimir a tabela de roteamento no router A, vemos que a rota de Router B está lá, mas é
    não ativo:


    ...
    2 Db dst-address=4.4.4.0/24 gateway=9.9.9.2 interface="" gateway-state=unreachable
    distance=20 scope=40 target-scope=10 bgp-as-path="65001" bgp-origin=igp
    received-from=9.9.9.2
    ...

    Isso ocorre porque as rotas eBGP são instalados com menor target-scope por padrão. Para resolver

    isso, a configuração

    filtro que define de maior escopo de destino de roteamento:

    /routing filter add chain=bgp-in set-target-scope=30
    /routing bgp set peer1 in-filter=bgp-in

    Ou então, modificar atributo âmbito da rota estática:

    /ip route set [find dst-address=9.9.9.2/32] scope=10

    de qualquer a maenira a routa para 4.4.4.0/24 deveria estar ativo agora:
    2 ADb dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2,ether3
    gateway-state=recursive distance=20 scope=40 target-scope=10
    bgp-as-path="65001" bgp-origin=igp received-from=9.9.9.2



  3. #3

    Padrão Re: Bgp com 3 link da mesma operadora

    Mais nesse caso vou ter que usar 3 roteador de borda né? quero usar somente de um pois tenho uma coldcore a 36

    Citação Postado originalmente por parreira13 Ver Post
    Configuração

    No Router A:

    # loopback interface
    /interface bridge add name=lobridge

    # addresses
    /ip address add address=1.1.1.1/24 interface=ether1
    /ip address add address=2.2.2.1/24 interface=ether2
    /ip address add address=3.3.3.1/24 interface=ether3
    /ip address add address=9.9.9.1/32 interface=lobridge

    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2,3.3.3.2

    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.2 remote-as=65000 update-source=lobridge

    No Router B:

    # loopback interface
    /interface bridge add name=lobridge

    # addresses
    /ip address add address=1.1.1.2/24 interface=ether1
    /ip address add address=2.2.2.2/24 interface=ether2
    /ip address add address=3.3.3.2/24 interface=ether3
    /ip address add address=9.9.9.2/32 interface=lobridge

    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.1/32 gateway=1.1.1.1,2.2.2.1,3.3.3.1

    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge

    # a route to advertise
    /routing bgp network add network=4.4.4.0/24

    Resultados

    Checke esta BGP connection se esta estabelicida:

    [[email protected]] > /routing bgp peer print status
    Flags: X - disabled
    0 name="peer1" instance=default remote-address=9.9.9.1 remote-as=65000
    tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no hold-time=3m
    ttl=255 in-filter="" out-filter="" address-families=ip
    update-source=lobridge default-originate=no remote-id=1.1.1.1
    local-address=9.9.9.2 uptime=28s prefix-count=0 updates-sent=1
    updates-received=0 withdrawn-sent=0 withdrawn-received=0 remote-hold-time=3m
    used-hold-time=3m used-keepalive-time=1m refresh-capability=yes
    as4-capability=yes state=established

    Route table no Router A:

    [[email protected]] > /ip route print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC G GATEWAY DISTANCE INTER...
    0 ADC 1.1.1.0/24 1.1.1.1 0 ether1
    1 ADC 2.2.2.0/24 2.2.2.1 0 ether2
    2 ADC 3.3.3.0/24 3.3.3.1 0 ether3
    3 ADb 4.4.4.0/24 r 9.9.9.2 200 ether1
    ether2
    4 ADC 9.9.9.1/32 9.9.9.1 0 lobridge
    5 A S 9.9.9.2/32 r 1.1.1.2 1 ether1
    r 2.2.2.2 ether2
    r 3.3.3.2 ether3

    [[email protected]] > /ip route print detail
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    0 ADC dst-address=1.1.1.0/24 pref-src=1.1.1.1 interface=ether1 distance=0 scope=10

    1 ADC dst-address=2.2.2.0/24 pref-src=2.2.2.1 interface=ether2 distance=0 scope=10

    2 ADC dst-address=3.3.3.0/24 pref-src=3.3.3.1 interface=ether3 distance=0 scope=10

    3 ADb dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2,ether3
    gateway-state=recursive distance=200 scope=40 target-scope=30
    bgp-local-pref=100 bgp-origin=igp received-from=9.9.9.2

    4 ADC dst-address=9.9.9.1/32 pref-src=9.9.9.1 interface=lobridge distance=0 scope=10

    5 A S dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2,3.3.3.2 interface=ether1,ether2,ether3
    gateway-state=reachable,reachable distance=1 scope=30 target-scope=10

    a routa 4.4.4.0./24 esta instalada em Linux kernel agora com tres nexthops: 1.1.1.2 (on ether1) ,

    2.2.2.2 (on ether2) and 3.3.3.2 (on ether3).

    Exemplo com eBGP
    Configuracao

    O exemplo dado acima é desenvolvido para o caso eBGP. Por padrão, os pares eBGP são obrigatórios

    para ser acessado diretamente. Se estamos usando interfaces loopback, que tecnicamente não são, por

    isso, multihop=yes configuração deve ser especificada.

    No Router A:

    /routing bgp instance set default as=65000
    /routing bgp set peer1 remote-address=9.9.9.2 remote-as=65001 update-source=lobridge multihop=yes

    No Router B:

    /routing bgp instance set default as=65001
    /routing bgp set peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge multihop=yes

    Resultados

    Se agora imprimir a tabela de roteamento no router A, vemos que a rota de Router B está lá, mas é
    não ativo:


    ...
    2 Db dst-address=4.4.4.0/24 gateway=9.9.9.2 interface="" gateway-state=unreachable
    distance=20 scope=40 target-scope=10 bgp-as-path="65001" bgp-origin=igp
    received-from=9.9.9.2
    ...

    Isso ocorre porque as rotas eBGP são instalados com menor target-scope por padrão. Para resolver

    isso, a configuração

    filtro que define de maior escopo de destino de roteamento:

    /routing filter add chain=bgp-in set-target-scope=30
    /routing bgp set peer1 in-filter=bgp-in

    Ou então, modificar atributo âmbito da rota estática:

    /ip route set [find dst-address=9.9.9.2/32] scope=10

    de qualquer a maenira a routa para 4.4.4.0/24 deveria estar ativo agora:
    2 ADb dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2,ether3
    gateway-state=recursive distance=20 scope=40 target-scope=10
    bgp-as-path="65001" bgp-origin=igp received-from=9.9.9.2

  4. #4

    Padrão Re: Bgp com 3 link da mesma operadora

    voce coloca as configuracoes na mikrotik ccr36 depois voce vai sair com o link para onde?



  5. #5

    Padrão Re: Bgp com 3 link da mesma operadora

    Tenho sairá para minha rede
    Citação Postado originalmente por parreira13 Ver Post
    voce coloca as configuracoes na mikrotik ccr36 depois voce vai sair com o link para onde?

  6. #6

    Padrão Re: Bgp com 3 link da mesma operadora

    amigo creio lhe entendi errado, entendi que voce queria fazer uma load balance com 3 links subir em uma bgp me diga o que voce tem ai agora, e quais mudancas voce quer fazer, para que eu possa tentar lhe ajudar obrigado....



  7. #7

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por parreira13 Ver Post
    amigo creio lhe entendi errado, entendi que voce queria fazer uma load balance com 3 links subir em uma bgp me diga o que voce tem ai agora, e quais mudancas voce quer fazer, para que eu possa tentar lhe ajudar obrigado....

    Mas a Operadora vai fazer pra voce as 3 seções?

  8. #8

    Padrão Re: Bgp com 3 link da mesma operadora

    Até o momento solicitaram os dados e pronto. não ativamos ainda.

    vai ficar 3 link de 100mb entrando no meu router uma ccr1036. Tenho um de 300mb já ta tranquilo mais esse de 300 vai ser cancelado.




    Citação Postado originalmente por Mephisto Ver Post
    Mas a Operadora vai fazer pra voce as 3 seções?



  9. #9

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por kbca12 Ver Post
    Tenho sairá para minha rede
    Tente fazer por loopback.

    Diga para operadora fazer 1 sessão BGP com os 3 links, ai tanto vc como a operadora utilizarão loopback para levantar o link.

  10. #10

    Padrão Re: Bgp com 3 link da mesma operadora

    Como seria tecnicamente falando.
    Citação Postado originalmente por alissonx Ver Post
    Tente fazer por loopback.

    Diga para operadora fazer 1 sessão BGP com os 3 links, ai tanto vc como a operadora utilizarão loopback para levantar o link.



  11. #11

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por kbca12 Ver Post
    Como seria tecnicamente falando.

    Voce levanta uma loopback em seu servidor bgp e a operadora tambem.

    apenas 1 sessão bgp é levantada entre voce e a operadora.

    os 3 links serão balanceados na sua entrada..

    e voce tera que balancear sua saida.

  12. #12

    Padrão Re: Bgp com 3 link da mesma operadora

    Vou deixar eles ativarem o link para fazer os teste. Vamos ver como vai ficar.

    Porque desses 300mb vendo 100mb para um cliente e 200mb dividido em meus concentradores.




    Citação Postado originalmente por alissonx Ver Post
    Voce levanta uma loopback em seu servidor bgp e a operadora tambem.

    apenas 1 sessão bgp é levantada entre voce e a operadora.

    os 3 links serão balanceados na sua entrada..

    e voce tera que balancear sua saida.



  13. #13

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por kbca12 Ver Post
    Vou deixar eles ativarem o link para fazer os teste. Vamos ver como vai ficar.

    Porque desses 300mb vendo 100mb para um cliente e 200mb dividido em meus concentradores.
    certo, aproveite que voce tem bgp com a operadora e entregue os 100 mb via transito para o cliente fechar bgp contigo

  14. #14

    Padrão Re: Bgp com 3 link da mesma operadora

    Já fechei alguns BGP, mais esse tipo de BGP ainda não fiz. Como ficaria as configuração para fazer dessa maneira que vocês falou.
    Citação Postado originalmente por alissonx Ver Post
    certo, aproveite que voce tem bgp com a operadora e entregue os 100 mb via transito para o cliente fechar bgp contigo



  15. #15

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por kbca12 Ver Post
    Já fechei alguns BGP, mais esse tipo de BGP ainda não fiz. Como ficaria as configuração para fazer dessa maneira que vocês falou.

    seu cliente tem BGP?

  16. #16

    Padrão Re: Bgp com 3 link da mesma operadora

    A as Dele ja ta para sair
    Citação Postado originalmente por alissonx Ver Post
    seu cliente tem BGP?



  17. #17

    Padrão Re: Bgp com 3 link da mesma operadora

    Citação Postado originalmente por kbca12 Ver Post
    A as Dele ja ta para sair
    entao faça transito pra ele.