Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por stevefox Ver Post
    Não tem segredo pra usar em Bridge, como o autor disse só a parte do failover que não vai ficar ok...
    "Criar uma interface "PPPoE-Client" e nas configurações do balance, onde se define as interfaces cabeadas dos modens, defina as interfaces "PPPoE-Client"."
    Facilzinho né ?
    Entendi

    O balance que estava utilizando era o do wiki mikrotik, vou fazer o teste em modo bridge e router!
    Caso alguém tenha uma experiência posta ae!

    Obrigado

  2. #42

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    parabéns ótimo post



  3. #43

    Padrão

    Olá Andrio, muito bom o post. Acho que é isso que eu estava procurando.
    Gostaria então, se vc pudesse é claro, que me esclarecesse alguns detalhes do balanceamento:

    1. O fail over funciona somente com pcc ou funciona com balanceamento simples por marcação de pacotes.

    2. Quando vc descreve a parte de rotas, vc coloca um gateway falso, a pergunta é a seguinte: Qual é função desse gateway falso? Pois já vi uma configuração parecida mas não havia o gateway falso.

    Desculpe se falei alguma besteira, mas só somente terei respos se perguntar né...

    Vlw pelo post, muito bom mesmo.

  4. #44

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Citação Postado originalmente por Arthur Bernardes Ver Post
    @AndrioPJ, fiz um Load Balance aqui por rotas estáticas mas tive um problema quando os computadores da LAN tentavam acessar o Winbox por IP.

    Dando um "traceroute" no PC, vi que ele tentava buscar o IP da Routerboard nos gateways de internet.

    Consegui resolver colocando o IP da Routerboard em "dst-address" na marcação de rotas e colocando um negação ("!") e assim consegui resolver.

    Poderia me dizer se será interessante eu fazer isso no PCC, mas na marcação de rotas?

    Veja se da forma abaixo está certo:

    Código :
    [[email protected]] > /ip firewall mangle print
    Flags: X - disabled, I - invalid, D - dynamic 
     0   ;;; ACEITA_REDE
         chain=prerouting action=accept dst-address-list=rotas_rede 
         in-interface=LAN_1 
     
     1   ;;; MARCA_CONEX ES_LINK
         chain=prerouting action=mark-connection new-connection-mark=ISP1_conn 
         passthrough=yes in-interface=ether1 connection-mark=no-mark 
     
     2   chain=prerouting action=mark-connection new-connection-mark=ISP2_conn 
         passthrough=yes in-interface=ether2 connection-mark=no-mark 
     
     3   ;;; POLICY_ROUTING
         chain=prerouting action=jump jump-target=policy_route in-interface=LAN_1 
         connection-mark=no-mark 
     
     4   ;;; DIVIS O_DO_LINK
         chain=policy_route action=mark-connection new-connection-mark=ISP1_conn 
         passthrough=yes per-connection-classifier=both-addresses:2/0 
     
     5   chain=policy_route action=mark-connection new-connection-mark=ISP2_conn 
         passthrough=yes per-connection-classifier=both-addresses:2/1 
     
     6   ;;; MARCA_ROTAS
         chain=prerouting action=mark-routing new-routing-mark=to_ISP1 
         passthrough=yes dst-address-list=!rotas_rede connection-mark=ISP1_conn 
     
     7   chain=prerouting action=mark-routing new-routing-mark=to_ISP2 
         passthrough=yes dst-address-list=!rotas_rede connection-mark=ISP2_conn 
     
     8   chain=output action=mark-routing new-routing-mark=to_ISP1 passthrough=yes 
         dst-address-list=!rotas_rede connection-mark=ISP1_conn 
     
     9   chain=output action=mark-routing new-routing-mark=to_ISP2 passthrough=yes 
         dst-address-list=!rotas_rede connection-mark=ISP2_conn

    Ou seria ideal eu deixar uma porta da routerboard somente para o gerenciamento dela?

    Obrigado.
    Estranho, nunca tive esse problema no Winbox, principalmente de dentro da rede.
    Estou caindo de sono aqui, nesse FDS dou uma olhada no seu code.

    Citação Postado originalmente por dulio2002 Ver Post
    Olá Andrio, muito bom o post. Acho que é isso que eu estava procurando.
    Gostaria então, se vc pudesse é claro, que me esclarecesse alguns detalhes do balanceamento:

    1. O fail over funciona somente com pcc ou funciona com balanceamento simples por marcação de pacotes.

    2. Quando vc descreve a parte de rotas, vc coloca um gateway falso, a pergunta é a seguinte: Qual é função desse gateway falso? Pois já vi uma configuração parecida mas não havia o gateway falso.

    Desculpe se falei alguma besteira, mas só somente terei respos se perguntar né...

    Vlw pelo post, muito bom mesmo.
    1 - funciona com marcação de rotas tbm.
    Mas o balance PCC, na minha opinião, é melhor.

    2 - Esse Gateway é usado na verificação das rotas.
    Quando o router não consegue pingar o site configurado, então esse Gateway falso é desativado, consequentemente todas as rotas que estavam em cima dele passam para o proximo link.



  5. #45

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    To com um balanceamento em um cliente com modens em bridge / mk discando.
    Porém o faiover não funciona, quando o adsl, (que está muito instável por sinal), o outro pppoe não assume como default, fica travado a conexão e não navega.

    Fazendo uns testes aqui, percebi que o check gateway so funciona com eu desativo a pppoe-out1 ae o out2 assume, mais por queda não vai o que faço?

    Terei que utilizar um script complementar para checar algum ip por ping e depois caso não responda mudar a distance do link defalt de 1 para 3 para dessa forma o pppoe-out2 que é o distance=2 assuma. Alguém tem ideia desse script como seria?

  6. #46

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Muito bom parabéns.



  7. #47

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)


  8. #48

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Amigos é o seguinte, nao tinha tanto problemas com pcc, mas nos ultimos 03 meses to penando, ja testei uns 6 modelos de pcc e sempre tendo o mesmo problema, lentidao de mais em sites, mesmo sem ser sites https, tenho link de 30 MB G8, 30 MB Embratel, e mais 03 Adsl de 10 MB, tenho 02 cload ccr 1016, uma é o concentrador e outra o load ballance, atualmente usando o Hyper Cache mas nao muito satisfeito tambem, ja desabilitei ele pra ver se era o causador mas nao adiantou, entao o que mais ou menos ta me quebrando o galho é usar o link da embratel e G8 em ECMP, e as 03 Adsl em PCC, mas mesmo assim causa alguma lentidao, sites abrem, outra hora tem que dar uns 03 enter pra ele abrir se nao fica buscando o tempo todo e nao abre, alguem ja passou ou passa por isso. Outro detalhe minha Rede é toda em Bridge, uso IP/Mac nada de Hotspot nem PPPoe, mas eliminei o nat do concentrador pra ver se melhorava fazendo OSPF entre ele e o Load, teve um certo ganho sim, mas a lentidao ainda permanece. lembrando que uso no concentrador 03 interface pra clientes, pois tenho varios ips tipo 192..../30, 172.16..../30 , 80..../30, 111..../30 e 01 para entrada do link. se tiver algum pcc que nunca tenha dado problema to cusioso em conhecer.



  9. #49

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Cara, é dificil chutar assim mais eu acredito que primeiro de tudo seria mexer no balance, testar os links separadamente e daí em diante, qualquer coisa tamos aí, vamos tentar te ajudar. Abraço

  10. #50

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Teria como fazer nessa configuração, apenas um IP ter acesso ao Link B quando cair o Link A, pois usei esta configuração como bkp um modem 3G, e apenas uma máquina precisa acessar internet quando cai o link principal, pois se eu deixar para todas as máquinas acessarem vai consumir muito rápido a franquia do plano.
    muito obrigado



  11. #51

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    como faço pra tirar um ranger de clintes do balance explo 192.168.10.0/24

  12. #52

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Citação Postado originalmente por claudinhohw Ver Post
    como faço pra tirar um ranger de clintes do balance explo 192.168.10.0/24
    https://under-linux.org/showthread.php?t=177732

    da uma olhadinha no item opcional 8~9



  13. #53

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Citação Postado originalmente por AndrioPJ Ver Post
    https://under-linux.org/showthread.php?t=177732

    da uma olhadinha no item opcional 8~9
    vlw vou dar uma olhadinha.

  14. #54

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Meus parabens e muito obrigado pelo post. Voce mostrou o espírito de cooperação o qual esse forum tem proposito. Acredito que falo pelos frequentadores que tambem foram ajudados por esse material. Muito obrigado.



  15. #55

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Bom trabalho AndrioPJ. Acabei de configurar minha RB para testar com estas regras e esta funcionando perfeitamente. Muito obrigado por compartilhar seus conhecimentos.

  16. #56

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    bom dia senhores, alguem poderia me ajudar, fiz esse balance numa rb, porem dentro da rb tem net mas nao navega de maneira alguma.


    MikroTik RouterOS 6.34.3 (c) 1999-2015 http://www.mikrotik.com/
    /ip pool
    add name="P00L _DHCP" ranges=192.168.66.2
    add name=dhcp_pool1 ranges=0.0.0.2-255.255.255.254
    add name=dhcp_pool2 ranges=192.168.66.2
    /ip address
    add address=192.168.66.1/30 interface="wi-fi zone" network=192.168.66.0
    add address=192.168.1.2/24 interface="link 50mb modem roteado" network=192.168.1.0
    /ip dhcp-server
    add address-pool="P00L _DHCP" disabled=no interface="wi-fi zone" name=dhcp1
    /ip dhcp-server network
    add address=192.168.1.0/30 dns-server=192.168.1.1,208.67.222.222 gateway=192.168.1.1
    add address=192.168.66.0/30 gateway=192.168.66.1
    /ip dns
    set allow-remote-requests=yes cache-size=10240KiB max-udp-packet-size=512 servers=208.67.222.222,189.38.95.95
    /ip firewall filter
    add action=drop chain=output comment="XXX NAO ACETAR CONEX\D5ES INVALIDAS XXX" connection-state=invalid
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="XXX MARCA\C7\D5ES DE CONEXA\C7\D5ES XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_CONN \
    per-connection-classifier=both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_CONN per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_CONN per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-connection chain=prerouting comment="XXX ENTRADA E SAIDA CLIENTES PELO MESMO LINK XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_OUT
    add action=mark-routing chain=prerouting comment="XXX MARCA\C7\D5ES ROTAS XXX" connection-mark=LINK1_CONN in-interface="wi-fi zone" new-routing-mark=LINK1_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK2_CONN in-interface="wi-fi zone" new-routing-mark=LINK2_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK3_CONN in-interface="wi-fi zone" new-routing-mark=LINK3_ROUT
    /ip firewall nat
    add action=masquerade chain=srcnat comment=NAT out-interface="!wi-fi zone"
    /ip route
    add distance=1 gateway=192.168.1.1 routing-mark=LINK1_ROUT
    add distance=1 gateway=pppoe-out15mb routing-mark=LINK2_ROUT
    add distance=1 gateway=pppoe-out10mb routing-mark=LINK3_ROUT
    add check-gateway=ping distance=1 gateway=192.168.1.1
    add check-gateway=ping distance=2 gateway=pppoe-out15mb
    add check-gateway=ping distance=3 gateway=pppoe-out10mb
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set ssh disabled=yes
    set api disabled=yes
    set api-ssl disabled=yes
    [[email protected] NOVO] /ip>



  17. #57

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Pessoal, eu to com dois links roteados, um de 10 mega e outro de 3 mega, eu fiz
    3 marcações para o link de 10 e 1 marcação para o link de 3 mega, para o balance eu usei uma regra que eu peguei hoje no site da mikrotik, o meu problema é que só ta usando a carga do link 1 e o link 2 só entra em ação se eu irar o cabo do link 1

    abaixo esta minha configuração do balance PCC:

    /interface ethernet
    set [ find default-name=ether1 ] name=ISP1
    set [ find default-name=ether2 ] name=ISP2
    set [ find default-name=ether3 ] name=LAN


    /ip pool
    add name=dhcp_pool1 ranges=192.168.20.2-192.168.20.254
    /ip dhcp-server
    add address-pool=dhcp_pool1 disabled=no interface=LAN name=dhcp1


    /ip address
    add address=192.168.20.1/24 interface=LAN network=192.168.20.0
    add address=172.0.0.2/24 interface=ISP1 network=172.0.0.0
    add address=10.0.0.2/24 interface=ISP2 network=10.0.0.0


    /ip dhcp-server network
    add address=192.168.20.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.20.1


    /ip firewall mangle
    add chain=prerouting comment="****** FORA DO BALANCE ******" dst-port=443 in-interface=LAN protocol=tcp
    add chain=prerouting comment="****** ACEITAR TRAFEGO DA REDE INTERNA ******" dst-address=172.0.0.0/24 in-interface=LAN
    add chain=prerouting dst-address=10.0.0.0/24 in-interface=LAN
    add action=mark-connection chain=prerouting comment="****** MARCA\C7\C3O LINK1 E LINK2 ******" connection-mark=no-mark in-interface=ISP1 new-connection-mark=ISP1_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ISP2 new-connection-mark=ISP2_conn
    add action=mark-connection chain=prerouting comment="****** DIVISAO DE CARGAS LINK 10MEGA ******" connection-mark=no-mark dst-address-type=!local in-interface=LAN new-connection-mark=ISP1_conn \
    per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=LAN new-connection-mark=ISP1_conn per-connection-classifier=both-addresses:4/1
    add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local in-interface=LAN new-connection-mark=ISP1_conn per-connection-classifier=both-addresses:4/2
    add action=mark-connection chain=prerouting comment="****** DIVISAO DE CARGAS LINK 3MEGA ******" connection-mark=no-mark dst-address-type=!local in-interface=LAN new-connection-mark=ISP2_conn \
    per-connection-classifier=both-addresses:4/3
    add action=mark-routing chain=prerouting comment="******MARCA\C7\C3O DE ROTAS DE ENTRADA ******" connection-mark=ISP1_conn in-interface=LAN new-routing-mark=to_ISP1
    add action=mark-routing chain=prerouting connection-mark=ISP2_conn in-interface=LAN new-routing-mark=to_ISP2
    add action=mark-routing chain=output comment="******MARCA\C7\C3O DE ROTAS DE SA\CDDA ******" connection-mark=ISP1_conn new-routing-mark=to_ISP1
    add action=mark-routing chain=output connection-mark=ISP2_conn new-routing-mark=to_ISP2


    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ISP1
    add action=masquerade chain=srcnat out-interface=ISP2


    /ip route
    add check-gateway=ping distance=1 gateway=172.0.0.1 routing-mark=to_ISP1
    add check-gateway=ping distance=1 gateway=10.0.0.1 routing-mark=to_ISP2
    add check-gateway=ping distance=1 gateway=172.0.0.1
    add check-gateway=ping distance=2 gateway=10.0.0.1


    o que tem de errado que nao ta acontecendo a divisao dos links ?

  18. #58

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Citação Postado originalmente por telthebest Ver Post
    bom dia senhores, alguem poderia me ajudar, fiz esse balance numa rb, porem dentro da rb tem net mas nao navega de maneira alguma.


    MikroTik RouterOS 6.34.3 (c) 1999-2015 http://www.mikrotik.com/
    /ip pool
    add name="P00L _DHCP" ranges=192.168.66.2
    add name=dhcp_pool1 ranges=0.0.0.2-255.255.255.254
    add name=dhcp_pool2 ranges=192.168.66.2
    /ip address
    add address=192.168.66.1/30 interface="wi-fi zone" network=192.168.66.0
    add address=192.168.1.2/24 interface="link 50mb modem roteado" network=192.168.1.0
    /ip dhcp-server
    add address-pool="P00L _DHCP" disabled=no interface="wi-fi zone" name=dhcp1
    /ip dhcp-server network
    add address=192.168.1.0/30 dns-server=192.168.1.1,208.67.222.222 gateway=192.168.1.1
    add address=192.168.66.0/30 gateway=192.168.66.1
    /ip dns
    set allow-remote-requests=yes cache-size=10240KiB max-udp-packet-size=512 servers=208.67.222.222,189.38.95.95
    /ip firewall filter
    add action=drop chain=output comment="XXX NAO ACETAR CONEX\D5ES INVALIDAS XXX" connection-state=invalid
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="XXX MARCA\C7\D5ES DE CONEXA\C7\D5ES XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_CONN \
    per-connection-classifier=both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_CONN per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_CONN per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-connection chain=prerouting comment="XXX ENTRADA E SAIDA CLIENTES PELO MESMO LINK XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_OUT
    add action=mark-routing chain=prerouting comment="XXX MARCA\C7\D5ES ROTAS XXX" connection-mark=LINK1_CONN in-interface="wi-fi zone" new-routing-mark=LINK1_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK2_CONN in-interface="wi-fi zone" new-routing-mark=LINK2_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK3_CONN in-interface="wi-fi zone" new-routing-mark=LINK3_ROUT
    /ip firewall nat
    add action=masquerade chain=srcnat comment=NAT out-interface="!wi-fi zone"
    /ip route
    add distance=1 gateway=192.168.1.1 routing-mark=LINK1_ROUT
    add distance=1 gateway=pppoe-out15mb routing-mark=LINK2_ROUT
    add distance=1 gateway=pppoe-out10mb routing-mark=LINK3_ROUT
    add check-gateway=ping distance=1 gateway=192.168.1.1
    add check-gateway=ping distance=2 gateway=pppoe-out15mb
    add check-gateway=ping distance=3 gateway=pppoe-out10mb
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set ssh disabled=yes
    set api disabled=yes
    set api-ssl disabled=yes
    [[email protected] NOVO] /ip>
    ja conseguiu por pra navegar ?



  19. #59

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    Citação Postado originalmente por telthebest Ver Post
    bom dia senhores, alguem poderia me ajudar, fiz esse balance numa rb, porem dentro da rb tem net mas nao navega de maneira alguma.


    MikroTik RouterOS 6.34.3 (c) 1999-2015 http://www.mikrotik.com/
    /ip pool
    add name="P00L _DHCP" ranges=192.168.66.2
    add name=dhcp_pool1 ranges=0.0.0.2-255.255.255.254
    add name=dhcp_pool2 ranges=192.168.66.2
    /ip address
    add address=192.168.66.1/30 interface="wi-fi zone" network=192.168.66.0
    add address=192.168.1.2/24 interface="link 50mb modem roteado" network=192.168.1.0
    /ip dhcp-server
    add address-pool="P00L _DHCP" disabled=no interface="wi-fi zone" name=dhcp1
    /ip dhcp-server network
    add address=192.168.1.0/30 dns-server=192.168.1.1,208.67.222.222 gateway=192.168.1.1
    add address=192.168.66.0/30 gateway=192.168.66.1
    /ip dns
    set allow-remote-requests=yes cache-size=10240KiB max-udp-packet-size=512 servers=208.67.222.222,189.38.95.95
    /ip firewall filter
    add action=drop chain=output comment="XXX NAO ACETAR CONEX\D5ES INVALIDAS XXX" connection-state=invalid
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="XXX MARCA\C7\D5ES DE CONEXA\C7\D5ES XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_CONN \
    per-connection-classifier=both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_CONN per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_CONN per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-connection chain=prerouting comment="XXX ENTRADA E SAIDA CLIENTES PELO MESMO LINK XXX" in-interface="wi-fi zone" new-connection-mark=LINK1_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK2_OUT
    add action=mark-connection chain=prerouting in-interface="wi-fi zone" new-connection-mark=LINK3_OUT
    add action=mark-routing chain=prerouting comment="XXX MARCA\C7\D5ES ROTAS XXX" connection-mark=LINK1_CONN in-interface="wi-fi zone" new-routing-mark=LINK1_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK2_CONN in-interface="wi-fi zone" new-routing-mark=LINK2_ROUT
    add action=mark-routing chain=prerouting connection-mark=LINK3_CONN in-interface="wi-fi zone" new-routing-mark=LINK3_ROUT
    /ip firewall nat
    add action=masquerade chain=srcnat comment=NAT out-interface="!wi-fi zone"
    /ip route
    add distance=1 gateway=192.168.1.1 routing-mark=LINK1_ROUT
    add distance=1 gateway=pppoe-out15mb routing-mark=LINK2_ROUT
    add distance=1 gateway=pppoe-out10mb routing-mark=LINK3_ROUT
    add check-gateway=ping distance=1 gateway=192.168.1.1
    add check-gateway=ping distance=2 gateway=pppoe-out15mb
    add check-gateway=ping distance=3 gateway=pppoe-out10mb
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set ssh disabled=yes
    set api disabled=yes
    set api-ssl disabled=yes
    [[email protected] NOVO] /ip>
    desculpa por nao ter respondido antes, é que eu só fui entrar hoje no under linux
    enquanto ao seu balance eu nao vou poder te ajudar, pois eu também to aprendendo a fazer balanceamento, mas enquanto a navegação, tente fazer isso pra ver se navega:

    vai em ip address e apague o ip que ta na interface que vai distribuir o dhcp na sua rede

    e depois em new terminal, acrecente essa regra:
    só que voce precisa editar a regra abaixo, onde esta "LAN", voce coloca o nome que ta na interface que vai distribuir o dhcp

    /ip address
    add address=192.168.66.1/24 interface=LAN network=192.168.20.0

    em ip pool voce apaga os pool que voce tem e depois vai em new terminal e jogue essa regra:


    /ip pool
    add name=dhcp_pool1 ranges=192.168.66.2-192.168.66.254

    em ip dhcp-server voce apaga os servidor que voce tem criado e joga essa regra em new terminal:
    lembrando de editar antes de jogar em new terminal. onde ta "LAN", voce cola o nome da interface que vai distribuir o seu dhcp


    /ip dhcp-server
    add address-pool=dhcp_pool1 disabled=no interface=LAN name=dhcp1

    em ip dhcp-server network voce apaga o que voce tem aí e depois joga essa regra em new terminal:


    /ip dhcp-server network
    add address=192.168.66.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.66.1



    depois vai em ip firewall nat e apague os nat que tiver na sua rb, depois vai em new terminal e joga essa regra:
    lembrando de editar a regra antes de jogar em new terminal, onde ta "ISP1", voce cola o nome da interface onde esta conectado o seu modem 1 e onde ta "ISP2" você cola o nome da interface onde esta conectado o seu modem 2, se for modem em bridge voce tem que coloca o nome que ta no discador pppoe cliente da sua rb
    exemplo "pppoe-out1" para o modem 1 e "pppoe-out2" para modem 2, cada regra com o seu devido nome do pppoe cliente

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ISP1
    add action=masquerade chain=srcnat out-interface=ISP2


    agora por ultimo pra finalizar
    troque os ips, onde ta "192.168.1.1", voce coloca o ip do seu modem 1 e onde ta "192.168.2.1", voce coloca o ip do seu modem 2

    /ip route
    add comment=rota_modem1 distance=1 gateway=192.168.1.1
    add comment=rota_modem2 distance=1 gateway=192.168.2.1

    lembrando que se seu modem tiver em bridge e voce tiver marcado a opçao de default router no pppoe cliente da sua rb, entao esse ultimo passo voce nao precisa fazer.

    comenta aí se isso resolveu o seu problema pra que possamos ajudar em algo mais

  20. #60

    Padrão Re: Balance PCC com Failover Avançado (Sem Script)

    boa tarde pessoal sou novo no forum estou com balance aqui que beguei um becap com um amigo porem o mesmo nao esta funcionando tao bem gostaria de comfigurar um do zero para 4 links velox de 15mb e com modens em bridge se alguem poder da uma força eu agradeço muito