Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Alguem ae sabe fazer um servidor mikrotik pra servir Ovpn
    pra maquinas windows como cliente?

    de preferencia com usario e senha cadastrado nos secrets,
    pra melhor gerencia, mas nao é obrifatorio..

  2. Citação Postado originalmente por mpsnet Ver Post
    Alguem ae sabe fazer um servidor mikrotik pra servir Ovpn
    pra maquinas windows como cliente?

    de preferencia com usario e senha cadastrado nos secrets,
    pra melhor gerencia, mas nao é obrifatorio..

    qualquer rb faz isso marciano



  3. O setup é bem simples, confira no link. Dúvidas só postar...

    http://wiki.mikrotik.com/wiki/OpenVP...n_Step_by_Step

  4. Citação Postado originalmente por felipeandrade55 Ver Post
    O setup é bem simples, confira no link. Dúvidas só postar...

    http://wiki.mikrotik.com/wiki/OpenVP...n_Step_by_Step
    pois é... durante a semana eu tentei fazer baseado neste turorial e encontrei duas dificuldades...
    gerar os certificados via cacert.org, uma vez q nao tenho nenhum dominio publicado na nic.br
    e como nao tenho nem sei usar linux, mesmo q desse pra fazero certificado no cacert no formato
    q a mikrotik aceita... entao gerei as chaves via easy-rsa, porem.. acho q nao estou sabendo talvez
    configurar o openvpn no cliente windows;...


    veja meus logs, no windows... cliente..

    Código :
    Sun May 25 01:55:26 2014 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006Sun May 25 01:55:26 2014 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
    Sun May 25 01:55:26 2014 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
    Sun May 25 01:55:26 2014 Control Channel MTU parms [ L:1543 D:140 EF:40 EB:0 ET:0 EL:0 ]
    Sun May 25 01:55:26 2014 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:4 ET:0 EL:0 ]
    Sun May 25 01:55:26 2014 Local Options hash (VER=V4): 'db02a8f8'
    Sun May 25 01:55:26 2014 Expected Remote Options hash (VER=V4): '7e068940'
    Sun May 25 01:55:26 2014 Attempting to establish TCP connection with 201.22.212.74:1194
    Sun May 25 01:55:26 2014 TCP connection established with 201.22.212.74:1194
    Sun May 25 01:55:26 2014 TCPv4_CLIENT link local: [undef]
    Sun May 25 01:55:26 2014 TCPv4_CLIENT link remote: 201.22.212.74:1194
    Sun May 25 01:55:27 2014 TLS: Initial packet from 201.22.212.74:1194, sid=1609bdad b5ab8a69
    Sun May 25 01:55:27 2014 VERIFY OK: depth=1, /C=BR/ST=RS/L=Brochier/O=Bar/emailAddress=marcianokart@bol.com.br
    Sun May 25 01:55:27 2014 VERIFY OK: depth=0, /C=BR/ST=RS/O=Bar/CN=201.22.212.74/emailAddress=marcianokart@bol.com.br
    Sun May 25 01:56:26 2014 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sun May 25 01:56:26 2014 TLS Error: TLS handshake failed
    Sun May 25 01:56:26 2014 Fatal TLS error (check_tls_errors_co), restarting
    Sun May 25 01:56:26 2014 TCP/UDP: Closing socket
    Sun May 25 01:56:26 2014 SIGUSR1[soft,tls-error] received, process restarting
    Sun May 25 01:56:26 2014 Restart pause, 5 second(s)

    agora veja meu log na mikrotik ovpnserver na outra cidade...
    Código :
    01:57:36 ovpn,info TCP connection established from 186.251.59.50 01:57:38 ovpn,info : using encoding - BF-128-CBC/SHA1 
    01:58:41 ovpn,info TCP connection established from 186.251.59.50 
    01:58:43 ovpn,info : using encoding - BF-128-CBC/SHA1 
    01:59:46 ovpn,info TCP connection established from 186.251.59.50 
    01:59:48 ovpn,info : using encoding - BF-128-CBC/SHA1


    abraço galeraaa!



  5. Uma coisa muito importante quando se usa Openvpn, o servidor e os clientes precisam estar com o fuso-horário configurados. Caso não estejam configurados vai dar erro nos certificados pois não é possivel checar a validade do certificado ( no caso o certificado é considerado expirado ).

    Para configurar o ntp ( atualizacao de hora/data via internet ) no mikrotik:
    /system clock
    set time-zone-name=America/Brasilia
    /system ntp client
    set enabled=yes mode=unicast primary-ntp=200.192.232.8 secondary-ntp=200.160.0.8






Tópicos Similares

  1. Como fazer o cliente windows trocar a senha de acesso do samba?
    Por jbenini no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-09-2008, 08:08
  2. Respostas: 7
    Último Post: 15-08-2008, 09:41
  3. problema com OpenVPN com Client Windows
    Por H_Franzin no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-05-2006, 10:06
  4. Samba - Pedir senha quando o windows carrega
    Por Duca no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-12-2005, 18:01
  5. Respostas: 1
    Último Post: 17-04-2003, 17:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L