+ Responder ao Tópico



  1. @benerofonte Não é DMZ, é direcionamento mesmo. Assim, antes de subir o OSPF, eu tinha que direcionar do balance p/ o concentrador, e do concentrador p/ o ip do pppoe do cliente, correto ? Isso funcionava perfeitamente.

    Agora c/ o OSPF o certo é direcionar do balance direto p/ o ip do pppoe do cliente, por isso postei as duas regras p/ o pessoal entender certinho.

    Veja:
    Regra antes do OSPF (FUNCIONAVA NORMAL)
    add action=dst-nat chain=dstnat comment=\
    "direcionamento camera fulano" disabled=no dst-address=\ip publico dst-port=9012
    protocol=tcp to-addresses=ip concentrador \ to-ports=9012

    Agora a regra depois do OSPF (NÃO TÁ FUNCIONANDO).
    add action=dst-nat chain=dstnat comment=\
    "direcionamento camera fulano" disabled=no dst-address=\ip publico
    dst-port=9012 protocol=tcp to-addresses=172.16.x.x \
    to-ports=9012

    Detalhe: o ip 172.16.x.x é o ip do pppoe-cliente. Esse ip tá fixo no cadastro dele, sempre que autenticar pega o mesmo ip. E também está fora do Pool de endereço, então não corre o risco de outro cliente estar pegando o mesmo ip.

    Outra coisa, do balance consigo pingar normalmente no ip do pppoe-cliente.

  2. Citação Postado originalmente por benerofonte Ver Post
    No caso o bom seria:


    No PCC fazer a regra direcionando a porta do cliente para o ip dele no pool do concentrador. E no cliente concentrador desativar qualquer regra de NAT ou Mascaramento.


    Ou seja, que nem eu faço aqui com os edge router. Na central tem o que faz o nat, e nas outras torres tenho o que faço o OSPF entre eles. Nao é preciso fazer um segundo NAT. Assim lá na central eu pego o ip publico, falo a porta e o ip de destino, depois ele se vira no OSPF para encontrar o cliente no outro roteador e fazer e repassar a porta.


    Nat no principal, qualquer outro que conecte via OSPF, sem NAT ou Mascaramento.


    Agora se o NAT no PCC que voce estiver fazendo está englobando todo o range ao inves de excluir em um nat separado o do cliente que voce quer acessar a camera nao vai adiantar.

    Um nat para o cliente da camera, e outro nat para o restante do pool que nao precisa de redirecionamento.
    Então benerofonte é assim mesmo que tá configurado aqui. Não tem NAT no concentrador, e a regra no balance aponta exatamente p/ o ip do cliente, digo ip do cliente poisé o ip da autenticação dele, ip do pppoe. Então não tem erro nessa parte.

    Na minha outra resposta, onde eu disse: detalhe o ip 172.16.x.x é exatamente o ip do pppoe do cliente (a autenticação que falo).
    Já a regra no balance, também é conforme você disse, veja bem minha ultima resposta.

    Abraço amigo, vou continuar tentando aqui.



  3. Citação Postado originalmente por benerofonte Ver Post
    Dá ultima vez que tive um problema assim, foi uma regra sobrepondo outra nat. E outra, voce reiniciou as duas rbs, primeiro a do pcc e depois a do concentrador depois de ativar o ospf? Porque pode ter alguma regra presa por causa disso.


    Testa com um usuario conectado ao concentrador e faz um redicionamento para ele, só para ter certeza mesmo.... qualquer coisa estamos ai :-)
    Sim, já reiniciei conforme você falou. Outra coisa, o teste que fiz é exatamente o que você sugeriu, ou melhor, é isso mesmo que precisa funcionar, então: Testa com um usuario conectado ao concentrador e faz um redicionamento para ele, só para ter certeza mesmo.... qualquer coisa estamos ai :-)

    Isso já foi testado varias vezes.

    Abraço amigo, obrigado pela força.

  4. Citação Postado originalmente por benerofonte Ver Post
    Pois é amigo, se fosse edge router ou freebsd eu te daria uma força maior. Mas, Mikrotik tenho pouca experiencia nele, mas com certeza é alguma regra de NAT que está sobrepondo alguma outra ou se perdendo no meio do caminho. Talvez analisando os pacotes com o wireshack voce tenha alguma noçao do que possa tá acontecendo.
    Poisé, NAT no concentrador não tem. Desativei tudo pra testar. Unico NAT agora é no balance p/ os links.

    Abraço.



  5. Adicione a interface de saida na regra.






Tópicos Similares

  1. Problemas com acesso externo no PROFTPD
    Por perucio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-02-2013, 10:24
  2. problema com acesso a nat em clientes...
    Por fpmazzi no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-05-2005, 00:33
  3. problemas com acesso de root via ssh
    Por roggy no fórum Servidores de Rede
    Respostas: 16
    Último Post: 11-04-2005, 06:27
  4. Problemas com acesso a terminal service
    Por vfigueiredo no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-02-2005, 18:21
  5. Problemas com Acesso
    Por black_burn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-08-2004, 21:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L