Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Post BKP em FTP

    Olá amigos trabalho em um provedor e eu estou precisando que vocês me ajudem em fazer um script para que o Winbox faça backup automático toda a sexta feira e mande para um FTP que irei criar ainda.
    será que vc's poderiam me ajudar com este probleminha que estou tendo?.

    OBS: uso sistema PPPOE (gerenciamento feito pelo Winbox e tbm uso o Thedude e o Aircontrol-2 para visualisar sinal e se tem algum problema ou não na minha rede!..

    desde já Agradeço!.

  2. #2

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Olá amigos trabalho em um provedor e eu estou precisando que vocês me ajudem em fazer um script para que o Winbox faça backup automático toda a sexta feira e mande para um FTP que irei criar ainda.
    será que vc's poderiam me ajudar com este probleminha que estou tendo?.

    OBS: uso sistema PPPOE (gerenciamento feito pelo Winbox e tbm uso o Thedude e o Aircontrol-2 para visualisar sinal e se tem algum problema ou não na minha rede!..

    desde já Agradeço!.
    Ja utilizei assim, porem preferi fazer com que o servidor acesse todos os mikrotiks e copie os backups.

    funciona perfeitamente.



  3. #3

    Padrão Re: BKP em FTP

    Citação Postado originalmente por alissonx Ver Post
    Ja utilizei assim, porem preferi fazer com que o servidor acesse todos os mikrotiks e copie os backups.

    funciona perfeitamente.

    Olá alison.

    se poder me ajudar a como fazer este procedimento que vc fez por favor.
    ficarei muito agradecido.

    só mais uma pergunta ai os backup ficam salvos no seu servidor de BKP correto?
    Última edição por Guilhermealonso1; 15-12-2014 às 13:02. Razão: esqueci de uma pergunta!.

  4. #4

    Padrão Re: BKP em FTP

    por que FTP por que nao email ? tem varios post aqui no forum usando email

    abraço



  5. #5

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Olá alison.

    se poder me ajudar a como fazer este procedimento que vc fez por favor.
    ficarei muito agradecido.

    só mais uma pergunta ai os backup ficam salvos no seu servidor de BKP correto?
    Primeiramente você teria que ter um servidor de backup em sua rede,

    e um script que escaneia sua rede e acessa os equipamentos via ssh ou ftp.

  6. #6

    Padrão

    Citação Postado originalmente por alissonx Ver Post
    Primeiramente você teria que ter um servidor de backup em sua rede,

    e um script que escaneia sua rede e acessa os equipamentos via ssh ou ftp.

    Ok, o servidor backup eu ja tenho
    mas o script eu nao sei criar sera que vc poderia me ajudar a faze-lo?

    grato desde ja!.



  7. #7

    Padrão Re: BKP em FTP

    Por varios motivos amigo
    eu acho que etéticamente fica melhor
    acho que fica mais proficional e mais fácil de abrir quando eu precusar de algo.
    e no modo email ele cria um arquivo
    se fosse para fazer email gostaria que ele viasse no corpo da mensagem para mais facil visualização!.

  8. #8

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Ok, o servidor backup eu ja tenho
    mas o script eu nao sei criar sera que vc poderia me ajudar a faze-lo?

    grato desde ja!.
    Você vai ter que fazer em shellscript, passando um loop pelos ips da sua rede...

    acessando equipamento por equipamento via ftp ou ssh

    e depois copiando o arquivo de backup do mikrotik.

    utilizo pastas por data, exemplo:

    2014/12/15/rede10/192.168.10.1.backup
    2014/12/15/rede10/192.168.10.1.rst
    2014/12/15/rede11/192.168.11.1.backup
    2014/12/15/rede11/192.168.11.1.rst



  9. #9

    Padrão Re: BKP em FTP

    Amigo, faça usando o fetch do proprio mikrotik, e bem facil...

  10. #10



  11. #11

    Padrão Re: BKP em FTP

    Citação Postado originalmente por alissonx Ver Post
    Você vai ter que fazer em shellscript, passando um loop pelos ips da sua rede...

    acessando equipamento por equipamento via ftp ou ssh

    e depois copiando o arquivo de backup do mikrotik.

    utilizo pastas por data, exemplo:

    2014/12/15/rede10/192.168.10.1.backup
    2014/12/15/rede10/192.168.10.1.rst
    2014/12/15/rede11/192.168.11.1.backup
    2014/12/15/rede11/192.168.11.1.rst
    Desculpa amigo sera que poderia detalhar um pouco mais como faço?

    =/

    grato desde já!.

  12. #12

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Desculpa amigo sera que poderia detalhar um pouco mais como faço?

    =/

    grato desde já!.
    Uma pergunta, você entende de shellscript? programação e etc?



  13. #13

    Padrão Re: BKP em FTP

    Não amigo não tenho conhecimento. =/

  14. #14

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Não amigo não tenho conhecimento. =/
    Amigo, quantos dispositivos voce tem em sua rede?



  15. #15

    Padrão Re: BKP em FTP

    Citação Postado originalmente por alissonx Ver Post
    Amigo, quantos dispositivos voce tem em sua rede?

    Tenho um MK só.

    ai tenho um servidor de backup
    servidor de dados (Arquivos)

    aqui dentro da empresa eu tenho 6 maquinas.

    seria isso que vc quer saber?
    :s

  16. #16

    Padrão Re: BKP em FTP

    Citação Postado originalmente por Guilhermealonso1 Ver Post
    Tenho um MK só.

    ai tenho um servidor de backup
    servidor de dados (Arquivos)

    aqui dentro da empresa eu tenho 6 maquinas.

    seria isso que vc quer saber?
    :s
    Achei que você tivesse vários Mikrotiks em sua rede e por isso estaria preocupado com backup.

    O script de backup no servidor eu utilizava pra mais de mil ativos mikrotik na rede.

    No seu caso, faça backup por e-mail... ou na mão mesmo.



  17. #17

    Padrão Re: BKP em FTP

    Citação Postado originalmente por alissonx Ver Post
    Achei que você tivesse vários Mikrotiks em sua rede e por isso estaria preocupado com backup.

    O script de backup no servidor eu utilizava pra mais de mil ativos mikrotik na rede.

    No seu caso, faça backup por e-mail... ou na mão mesmo.
    como eu faria backup por email?

  18. #18



  19. #19

    Padrão Re: BKP em FTP

    Citação Postado originalmente por alissonx Ver Post

    :d
    muito obrigado alisson sou muito grato pela sua ajuda!.

  20. #20

    Padrão Re: BKP em FTP

    Boa tarde Galera gostaria de Agradecer a todos que se propuseram a me ajudar aqui na minha dúvida e em especialmente o alisson que desde o começo vem me ajudando e se dedicando para que eu consiga fazer o que precisava.

    vou deixar o Script para que as pessoas que precisem usem tbm

    só alterar algumas coisas no script e pronto.

    ::

    :log warning "Iniciando Backup . . ."
    :global arquivo configbackup
    :global mikrotikexport mtexport_backup
    :global sub1 ([/system identity get name])
    :global sub2 ([/system clock get time])
    :global sub3 ([/system clock get date])
    :global para email para onde vai o backup
    :global usuario email para onde vai o backup
    :global senha senha do email
    :global servidor
    :global porta 587
    :set servidor [:resolve "nome do servidor"];
    :log warning "Criando o backup. . . "
    /system backup save name=$arquivo
    /export file=$mikrotikexport
    :log warning "Pausa o processo para completar o Backup …"
    :delay 10s
    :log info "Envia os arquivos por e-mail. . ."
    /tool e-mail send to=$para password=$senha subject="$sub3 $sub2 $sub1 file backup" from=$usuario user=$usuario file=$arquivo server=$servidor port=$porta start-tls=no
    /tool e-mail send to=$para password=$senha subject="$sub3 $sub2 $sub1 file rsc" from=$usuario user=$usuario file=$mikrotikexport server=$servidor port=$porta start-tls=no
    :delay 10s
    # Deleta automaticamente
    /file remove $arquivo
    /file remove $mikrotikexport
    :log warning "Backup completo."


    ::