+ Responder ao Tópico



  1. #1
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.114
    Posts de Blog
    15

    Padrão [DICA] 29 - Mikrotik - Monitorar velocidade da interface e mandar alerta por e-mail

    [DICA] 29 - Mikrotik - Monitorar velocidade da interface e mandar alerta por e-mail

    2 de dezembro de 2013 às 16:05

    Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail



    ABRA O NEW TERMINAL, COPIAR E COLAR.


    #Script ETHERNET-Check v0.2
    #
    #Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
    #
    # Autor: Andre Andrade <[email protected]>
    # 15/08/2012 - 23:25pm
    #Colaborador Maurício de lima <[email protected]>
    #20/08/2012 - 10:52am
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma interface.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- Testado nas versoes 5.13
    #
    #Informacoes:
    #
    #Variável v -> valor que sera usado para rastreamento entre as interfaces ATIVAS.

    :global v
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global host [/system identity get name]
    :foreach i in=[ /interface ethernet find running] do={
    :local intname [ / interface ethernet get $i name ];
    #:log warning (" Interface: " . $intname);

    /interface ethernet monitor $intname once do={ :set v $rate }
    :if ($v = "10Mbps") do={
    :log error message="interface $intname esta em 10Mbps";
    /tool e-mail send subject="Interface em 10Mbps em $host em $data ($hora)" [email protected] body="Corrigir interface LAN ($intname) que esta em 10Mbits" tls=yes
    };
    };
    https://www.facebook.com/notes/mikro...57052187716382

  2. #2

    Padrão

    Boa tarde. estou tentando implementar esse script na minha rede mas o mesmo não funciona, imagino que seja pelas versões mais novas das rb´s. teria como disponibilizar alguma atualizada? desde já agradeço. abraço