Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá amigos alguem de vcs ja passaram por problema de autenticação com WebMikrotik? Aqui meus clientes muitos estao reclamando dando senha invalida e a questao de ips, o webmikrotik manda um Ip e a maquina recebe outro , alguem poderia mim ajudar

    detalhe uso hotspot

    Abraços Felipe

  2. Citação Postado originalmente por benerofonte Ver Post
    Pode ser problema de comunicaçao com o servidor deles, dar um ping da sua rede para o servidor de autenticacao deles, pode ser que atrasa demais a comunicacao e ocorre alguma duplicidade nos dados ....

    vc ja usou ou usa ele amigo



  3. Citação Postado originalmente por benerofonte Ver Post
    Pode ser problema de comunicaçao com o servidor deles, dar um ping da sua rede para o servidor de autenticacao deles, pode ser que atrasa demais a comunicacao e ocorre alguma duplicidade nos dados ....
    Ping 60 a 74 ms

  4. Citação Postado originalmente por netline Ver Post
    Olá amigos alguem de vcs ja passaram por problema de autenticação com WebMikrotik? Aqui meus clientes muitos estao reclamando dando senha invalida e a questao de ips, o webmikrotik manda um Ip e a maquina recebe outro , alguem poderia mim ajudar

    detalhe uso hotspot

    Abraços Felipe
    Um detalhe a mais para poder entender o problema:
    Isso começou a acontecer de repente? Faz algum tempo que vinha trabalhando normalmente?

    Não me parece ser problema com o webmikrotik, uma vez que a autenticação não depende do servidor webmikrotik estar ativo ou não.
    O webmikrotik não é um servidor de autenticação. A autenticação é feita diretamente no mikrotik.
    Tenho salientado isso inúmeras vezes. A vantagem que vejo em relação a outros sistemas que ficam hospedados localmente, é que o serviço não depende do gerenciador. O que o gerenciador faz é escrever algumas poucas regras no mikrotik, de autenticação, escrever os planos, manter os cadastros de Users atualizado e ler informações do log do mikrotik para formar os relatórios de conexão. Mesmo se o servidor webmikrotik estiver fora, o que é raro, quando retorna ele vai atualizar o que for preciso.

    E também não dever ser erro de comunicação do gerenciador com o mikrotik pois quando isso ocorre retorna uma mensagem de erro do ajax.

    Uma pergunta que cabe aqui: você usa o hotspot com dhcp?
    Pois este tipo de erro acontecia conosco quando usavamos o mk-auth com dhcp. Depois que passamos para if fixo, nunca mais aconteceu com o mk-auth.

    O que acontece? Com o dhcp ativado, cada cliente pode ter variação do IP que recebe. O hotspot dá sempre preferencia para o mesmo ip que o cliente já pegou anteriormente, o que fica registrado em Leases.
    Mas por algum problema que não conseguimos identificar, o Leases do Mikrotik não trabalhava corretamente ou alguma configuração que fazíamos não permitia este trabalho de forma adequada.
    Então acontecia de muito "rolo" nas autenticações.
    E a culpa não era do mk-auth mas do próprio mikrotik

    Por isso acho que o problema está no mikrotik

    Outra situação que pode estar ocorrendo é falta de sincronismo entre o que está no cadastro do webmikrotik e o que está no User do mikrotik.
    Isto pode ocorrer quando se faz muita manutenção de clientes diretamente no mikrotik. Obviamente pode ocorrer uma discrepância entre os dois cadastros.
    Por isso a recomendação é que sempre se use o webmikrotik para atualizar as informações do mikrotik, principalmente nunca ficar cadastrando Users diretamente no winbox. Se fizer isso, o usuário vai estar no User do mikrotik mas não no cadastro do webmikrotik

    Se for isso, você pode facilmente resolver a situação mandando fazer a sincronização do webmikrotik com o mikrotik. Mas se o problema está acontecendo com clientes cadastrados só no mikrotik daí vai ter que cadastra-los no webmikrotik.

    Uma situação que tem ocorrido aqui é algumas vezes um cliente autenticar mas não conseguir sair da central do cliente. Dá um erro de redirecionamento. Mas notamos que ao abrir com outro navegador ele consegue. Ou então escrever diretamente o ip do servidor mikrotik na barra de navegação.
    Normalmente uma limpeza básica na máquina do cliente resolve o problema. Mas pouco tempo depois retorna, o que nos leva a crer que é algum tipo de vírus ou spyware que modifica alguma coisa no navegador.



  5. Bom dia amigo, eu uso webmikrotik e aconteceu a mesma coisa comigo mas, o problema é como o amigo 1929 falou. Eu usava hotspot com dhcp ativo e todo dia era esse problema... mais ai eu desativei o dhcp e coloquei ip fixo e nunca mais esses problemas voltaram. Esquece DHCP e mude para IP FIXO que voce tem um controle bem melhor acesso remoto etc... etc...






Tópicos Similares

  1. Problemas com webmikrotik :(
    Por Reinan no fórum Servidores de Rede
    Respostas: 3
    Último Post: 14-03-2014, 21:44
  2. Problemas com Thunder + Webmikrotik
    Por Reinan no fórum Servidores de Rede
    Respostas: 13
    Último Post: 21-11-2013, 20:37
  3. Problemas com ip Real!! muito sério!
    Por DirectNet no fórum Redes
    Respostas: 6
    Último Post: 21-11-2008, 20:13
  4. Respostas: 3
    Último Post: 15-10-2006, 15:46
  5. Amigos estou com sérios problemas no squid(RunCache)
    Por bandlinux no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-03-2005, 06:07

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L