+ Responder ao Tópico



  1. Hoje fiz um teste de redundância de VPN e felizmente deu certo e decidi postar na comunidade !

    Neste tutorial vou explicar de forma conceitual, sem muitos detalhes de configuração por questão de tempo, posteriormente irei criar um tópico de como criar uma VPN com conectividade para a rede interna das duas redes sem nenhuma bridge, totalmente roteada, e com detalhes de configuração.

    Na matriz tenho dois link de operadoras diferentes Link1 e Link2 (com failOver configurado) e um servidor VPN pptp
    Na Filial tenho somente o Link1 e o cliente pptp

    É comum criar apenas um cliente pptp apontado para o Link1 da matriz, faremos com que quando o Link1 da matriz cair o cliente conecta automaticamente no link2 (somente se o failOver estiver configurado na matriz) quando o Link1 voltar ele conecta novamente no Link1.
    Uma breve configuração de Failover:

    Link1 na eth1
    Link2 na eth2

    Criando Rotas Default:

    /ip route
    add check-gateway=ping comment="Gateway Link1" distance=1 gateway=Link1
    add check-gateway=ping comment="Gateway Link2" distance=1 gateway=Link2
    Deste modo, caso o Link1 cair o Link2 ira assumir a rota padrão.

    Na filial:

    Crie 2 clientes pptp um apontando para o Link1 e outro para Link2 da matriz

    Agora vamos usar a ferramenta Netwatch para testar o Link1 e caso ele venha a cair ele ativa um script para ativar
    o pptp que aponta para o Link2 da matriz.

    Tools>Netwatch>add:
    Host: coloque o IP do Link1 da matriz
    Interval: 00:00:30 (Tempo que o mikrotik irá testar a VPN)
    Timeout: 1000

    Up, colocaremos o script:
    #desativa pptp - Link2
    /interface pptp-client disable "PPTP - Link2"

    #Ativa pptp - Link1
    /interface pptp-client enable "PPTP - Link1"

    Down, colocaremos o script:
    #desativa pptp - Link1
    /interface pptp-client disable "PPTP - Link1"

    #ativa pptp - Link2
    /interface pptp-client enable "PPTP - Link2"


    Depois disso só realizar os teste para ver se esta conectando automaticamente, qualquer duvida ou sugestão é bem vinda, afinal alem de ajudar, estou aqui para aprender!

  2. Citação Postado originalmente por josenunesti Ver Post
    Hoje fiz um teste de redundância de VPN e felizmente deu certo e decidi postar na comunidade !

    Neste tutorial vou explicar de forma conceitual, sem muitos detalhes de configuração por questão de tempo, posteriormente irei criar um tópico de como criar uma VPN com conectividade para a rede interna das duas redes sem nenhuma bridge, totalmente roteada, e com detalhes de configuração.

    Na matriz tenho dois link de operadoras diferentes Link1 e Link2 (com failOver configurado) e um servidor VPN pptp
    Na Filial tenho somente o Link1 e o cliente pptp

    É comum criar apenas um cliente pptp apontado para o Link1 da matriz, faremos com que quando o Link1 da matriz cair o cliente conecta automaticamente no link2 (somente se o failOver estiver configurado na matriz) quando o Link1 voltar ele conecta novamente no Link1.
    Uma breve configuração de Failover:

    Link1 na eth1
    Link2 na eth2

    Criando Rotas Default:



    Deste modo, caso o Link1 cair o Link2 ira assumir a rota padrão.

    Na filial:

    Crie 2 clientes pptp um apontando para o Link1 e outro para Link2 da matriz

    Agora vamos usar a ferramenta Netwatch para testar o Link1 e caso ele venha a cair ele ativa um script para ativar
    o pptp que aponta para o Link2 da matriz.

    Tools>Netwatch>add:
    Host: coloque o IP do Link1 da matriz
    Interval: 00:00:30 (Tempo que o mikrotik irá testar a VPN)
    Timeout: 1000

    Up, colocaremos o script:
    #desativa pptp - Link2
    /interface pptp-client disable "PPTP - Link2"

    #Ativa pptp - Link1
    /interface pptp-client enable "PPTP - Link1"

    Down, colocaremos o script:
    #desativa pptp - Link1
    /interface pptp-client disable "PPTP - Link1"

    #ativa pptp - Link2
    /interface pptp-client enable "PPTP - Link2"


    Depois disso só realizar os teste para ver se esta conectando automaticamente, qualquer duvida ou sugestão é bem vinda, afinal alem de ajudar, estou aqui para aprender!
    Pergunta 1-
    Na Matriz ficam os dois links Ativos ao mesmo tempo ?

    Pergunta 2-
    A filial fica tentando discar para os dois links em simultaneo ?
    E daí ela só consegue se conectar em 1 link por vez ?






Tópicos Similares

  1. Fechando VPN com Mikrotik
    Por leanddrro no fórum Servidores de Rede
    Respostas: 6
    Último Post: 26-08-2009, 00:15
  2. Ajuda com VPN entre 2 MikroTiks - EoIP Tunnel
    Por Jonatanmcc no fórum Redes
    Respostas: 2
    Último Post: 20-12-2008, 09:24
  3. usar VPN com Mikrotik X Win2003
    Por chacha0022 no fórum Redes
    Respostas: 0
    Último Post: 18-08-2008, 15:49
  4. VPN com Mikrotik
    Por chacha0022 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-08-2008, 10:35
  5. VPN com Mikrotik
    Por jrctec no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-07-2008, 14:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L