Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Eu uso a técnica do amigo Andrio. Rota estática entre concentrador e balance. Assim os IPs chegam na RB de balance. Lá posso tratar algum eventual problema, como escolher por qual link o cliente irá sair.

  2. Mesmo que você mascare no NAS e tenha um load-balance externo, ainda assim da pra fazer. É só criar uma rede diferente para os clientes PPPoE que você quer fixar em um link, e usar o mesmo load-balance com essa rede diferente saindo sempre pela mesma rota.

    Caso você faça o load-balance na mesma RB que autentica os clientes PPPoE (NAS), fica mais facil ainda, como ja foi comentado. Uma coisa interessante que tem no user-manager é o campo Address-list no limitation de cada profile. Se você usa um pool de ip pro PPPoE, o IP do cliente, ao conectar, é adicionar automaticamente a address-list informada lá no cadastro do profile dele, e você pode fazer marcação de rotas, no mangle, utilizando essa address-list como base. Mesmo que você use outro servidor Radius, você pode implementar esse parametro radius da mikrotik, é só dar uma pesquisada no wiki da mikrotik que tem as especificações dos parametros radius próprios da mikrotik e adicionar no seu servidor radius.

    num caso assim, direcionar o cliente para um link em específico é simples assim:
    digamos que o link 1 o gateway é: 10.1.1.1/24
    digamos que o link 2 o gateway é: 10.2.1.1/24

    então adiciona uma rota com com um nome, assim:

    adicionar uma tabela de roteamento de nome "route_link1" para o primeiro link
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=route_link1

    adicionar uma tabela de roteamento de nome "route_link2" para o segundo link
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=10.2.1.1 routing-mark=route_link2

    Agora basta no mangle você fazer a marcação para uma conexão sair por uma tabela de roteamento específica. Digamos que você tenha uma address-list com os IPs dos clientes que tem que sair pelo primeiro link um chamada "addr-toLink1", e outra para os clientes que tem que sair pelo segundo link chamada "addr-toLink2" então, adiciona:

    Para marcar a conexão do cliente para a tabela de roteamento específica do primeiro link:
    Código :
    /ip firewall mangle add chain=prerouting src-address-list=addr-toLink1 action=mark-routing new-mark-routing=route_link1

    Para marcar a conexão do cliente para a tabela de roteamento específica do segundo link:
    Código :
    /ip firewall mangle add chain=prerouting src-address-list=addr-toLink2 action=mark-routing new-routing-mark=route_link2

    Tem que enxugar essas configurações para o seu cenário, para as suas configurações específicas, mas um dos caminhos é esse.

    Se os IPs dos seus clientes PPPoE são fixos, você pode simplesmente adicionar uma routing rule para o IP dele marcando para uma tabela de roteamento em específico, nesse caso, as routing rule acontecem antes mesmo do mangle, deve funcionar. Além disso, você pode usar as routing rule a nível de interface se não me engano, então daria pra adicionar uma interface pppoe server binding para os clientes específicos que tu quer rotear para um link em específico e adicionar uma regra para essa interface.



  3. Olhe aqui vc vai ter um noção rsrs http://wiki.mikrotik.com/wiki/Load_B...tiple_Gateways


    Porém se vc se tiver um concentrador muda um pouco tenta ai.

  4. Sim tente adaptar as regras não tem muito o que fazer. =P






Tópicos Similares

  1. Respostas: 1
    Último Post: 07-12-2016, 11:12
  2. Respostas: 21
    Último Post: 02-12-2011, 10:03
  3. Respostas: 4
    Último Post: 12-07-2011, 00:53
  4. Liberar Mac para apenas um cliente
    Por VALTERTERABYTE no fórum Redes
    Respostas: 4
    Último Post: 18-07-2010, 11:48
  5. bloquear site para apenas um cliente
    Por Skool no fórum Redes
    Respostas: 3
    Último Post: 29-10-2008, 14:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L