Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. Failover amigo tem que ter script.

  2. @flavioleonel, no meu primeiro poste tem as regras completas, tanto de entrada para o ros quanto para roteamento pra lan, além das regras para roteamento de saida tanto do ros quando da lan. E questão das rotas vindas do PPPoE que você fala, acho que você se refere ao IP que o cliente recebe ao criar o tunel pppoe, não é? Pois bem, essa rota só pode ser adicionada na hora da formação do tunel, e ela é criada dinamicamente usando a opção "add-default-route=yes" na interface pppoe-client, pois geralmente você recebera um IP dinamico na formação do tunel dessas operadoras.

    O que tem que se notar, é que o tunel PPPoE identifica 2 pontas de um tunel bidirecional com um IP, esses IPs não tem nem mesmo uma "rede" digamos assim, não tem mascara. Portanto, quando você adicionar uma rota para qual o gateway seja a própria interface pppoe, seria o mesmo resultado que configurar um gateway com o IP remoto do túnel.


    @zamorabott você pode ter varios "níveis" de fail-over. A principio você pode tentar implementar essas regras e fazer funcionar, se funcionar e depois de funcionar, ai você faz o fail over que quiser. Uma forma simples, seria usando 3 itens em cada tabela de roteamento, assim, quando um link pppoe-client cair, ele vai ficar "unrecheable", e a rota com a menor distancia assume aquela tabela. Assim ó:


    Código :
    /ip route
        add dst-address=0.0.0.0/0 distance=1 gateway=pppoe-assim routing-mark=link1_routing
        add dst-address=0.0.0.0/0 distance=2 gateway=pppoe-out1 routing-mark=link1_routing
        add dst-address=0.0.0.0/0 distance=3 gateway=pppoe-out2 routing-mark=link1_routing
     
     
        add dst-address=0.0.0.0/0 distance=1 gateway=pppoe-out1 routing-mark=link2_routing
        add dst-address=0.0.0.0/0 distance=2 gateway=pppoe-assim routing-mark=link2_routing
        add dst-address=0.0.0.0/0 distance=3 gateway=pppoe-out2 routing-mark=link2_routing
     
     
        add dst-address=0.0.0.0/0 distance=1 gateway=pppoe-out2 routing-mark=link3_routing
        add dst-address=0.0.0.0/0 distance=2 gateway=pppoe-assim routing-mark=link3_routing
        add dst-address=0.0.0.0/0 distance=3 gateway=pppoe-out1 routing-mark=link3_routing

    Assim, sempre que o link 1 cair, o link 2 vai assumir o lugar do link 1 pois é o próximo na distancia. Se o link 1 e o link 2 cair, o link 3 assume o lugar do link 1 e do link 2, pois no link 2 o proximo da distancia é o link 1 mas também vai estar unreacheable, assumindo o link 3. E assim por diante.O problema dessa simplicidade é que, se der algum problema na rota que o seu link pppoe-client não cair, mas ficar sem acesso a internet, o tunel continua reacheable e você não será direicionado para outro link. Um fail-over mais complexo, somente com scripts mesmo.

    Referente a você ter 3 links assimetricos, um de 20mb e 2 de 8mb, o que você pode fazer no PCC e usar então 4 regras, sendo que 2 delas você usa a mesma rota, assim, o link de 20mb ficaria de teoricamente "metade" da carga (2/4), e cada um de 8mb com 25% da carga (1/4). O problema é que PCC é a nível de conexão, ou seja, se você tentar se conectar muitas vezes ao mesmo IP destino e/ou Porta (depende da opção que você selecionar no pcc), você vai estar saindo pelo mesmo link.

    Código :
    /ip firewall mangle
        add chain=prerouting in-interface=ether5-lan per-connection-classifier=both-addresses-and-ports:4/0 action=mark-routing new-connection-mark=link1_routing
        add chain=prerouting in-interface=ether5-lan per-connection-classifier=both-addresses-and-ports:4/1 action=mark-routing new-connection-mark=link1_routing
        add chain=prerouting in-interface=ether5-lan per-connection-classifier=both-addresses-and-ports:4/2 action=mark-routing new-connection-mark=link2_routing
        add chain=prerouting in-interface=ether5-lan per-connection-classifier=both-addresses-and-ports:4/3 action=mark-routing new-connection-mark=link3_routing[COLOR=#333333][/COLOR]



  3. Isso mesmo amigo @inquiery, certinho.

  4. Show de bola amigos, vou tentar aplicar essa configuração e posto resultado.









Tópicos Similares

  1. mikrotik pinga, porém pc não navega.....
    Por SalvadorDanczuk no fórum Redes
    Respostas: 9
    Último Post: 06-05-2015, 08:59
  2. Mikrotik em modo cliente não navega!!!
    Por SalvadorDanczuk no fórum Redes
    Respostas: 1
    Último Post: 27-07-2010, 07:42
  3. Radio APRouter WISP + MK pppoe nao navega !!!
    Por paulojrandrade no fórum Redes
    Respostas: 2
    Último Post: 09-03-2009, 09:00
  4. Mikrotik PPPOE - Windows Vista não navega!
    Por Marzio no fórum Redes
    Respostas: 13
    Último Post: 16-06-2008, 09:39
  5. Seu Speedy é PPPOE ? Não conecta? Não navega??
    Por zerocoolll no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-03-2003, 09:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L