Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    É rapaz...pela minha limitação em redirecionamento tentei,tentei,tentei e não conseguir. De qualquer lugar desse mundo, eu estou conseguindo acessar minha página de bloqueio, que eu fiz e coloquei dentro do programa easyphp que está no meu PC...

    Meu PC. IP local 192.168.1.100
    IP que vem do servidor pppoe mikrotik.. 192.168.50.19
    Porta do servidor apache que está rodando no próprio PC. 39.

    Onde estou errando....
    Última edição por ruanserver; 25-06-2015 às 08:52.

  2. #22

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    @ruanserver, a forma que você se conecta na internet ou mesmo ter ou não conectividade com a internet não importa pro seu caso. Pois o que você quer é mostrar uma pagina de bloqueio para um cliente seu, ou seja, a requisição HTTP vai vir de DENTRO da sua rede.

    O seu PC é IP 192.168.1.100 ? E ele ta ligado direto na RB ?

    Se sim, não tem erro, naquelas regras que eu postei, basta vc colocar o IP do seu PC lá, 192.168.1.100, e a porta que o apache está rodando, o padrão é 80, se vc alterou ela, coloca a porta alterada.



  3. #23

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Se você não tem regra de filtro nenhuma, tem que liberar o DNS antes do bloqueio do trafego, pois a requisição DNS vai vir ANTES da requisição HTTP (óbviamente). E se o browser não conseguir resolver o nome, ele não vai nem iniciar uma requisição HTTP pois não vai saber pra onde.

    Código :
    /ip firewall nat add chain=dstnat src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-address=192.168.1.100 to-port=80
    /ip firewall filter add chain=forward in-interface=ETHER_CLIENTES protocol=udp dst-port=53 action=accept
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=!tcp action=drop
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=!80 action=drop

    Não esquece de criar um profile no PPP e colocar "CLIENTE_BLOQUEADO" no campo "Address List". No hotspot a mesma coisa; só criar um profile e colocar "CLIENTE_BLOQUEADO" no campo "Address List". Os clientes, tanto PPPoE ou Hotspot, que tu quiser bloquear e mostrar mensagem, é só alterar para esse profile.

  4. #24
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Regra 1 = trocar o to-port= Pela porta do apache.
    Regra 2 = Não precisa.
    Regra 3 = Ok.
    Regra 4 = Ok.
    Apesar de entender que DROP deve ser feito no Filter.



  5. #25

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Respondendo a dúvida de inquiery, esse IP 192.168.1.100 quem está me dando é o meu roteador. Sai um cabo da rb e conecta na porta wan do meu roteador, no roteador o IP wan é 192.168.50.19.

    Vou tentar fazer de novo colegas.

    Devo dizer a vocês que também fico pesquisando, lendo entendeu? Não fico só querendo tudo mastigado.

    Devo dizer que no hotspot eu consigo normalmente... Sempre tjve minha página de bloqueio no hotspot...

  6. #26

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Bom dia @ruanserver

    Pelo que eu andei lendo uns posts anteriores, você alterou a porta do Apache para 81, é isso?
    Se o seu servidor Apache está atraz do seu router local, então a regra que redireciona para o Apache, deve redirecionar para o IP da WAN do seu roteador, que é um IP conhecido pelo Mikrotik.
    Depois disso, você precisa ir nas configurações do seu roteador, e criar uma regra de "Port Forwarding", e redirecionar a porta 81 para o IP local do seu PC. Para facilitar a sua vida, configura uma regra estática no DHCP do seu roteador, para o MAC do seu PC pegar sempre o mesmo IP, 192.168.1.100 no caso.

    Outra coisa é o seguinte, se o seu roteador ta conectando no seu mikrotik por PPPoE, está com IP dinamico, vai deixar a sua vida um pouco mais complicada. Bota um IP fixo fora do pool que você usa no seu PPPoE para o usuário do seu roteador, e usa esse IP nas regras.

    Depois disso, basta você trocar os IPs la nas regras, o "to-address=" é o IP do roteador; por enquanto ele é 192.168.50.19, se esse IP é fixo ta tranquilo, mas se ele mudar, ja vai parar de funcionar as regras, então ele tem que ser fixo (conforme comentei anteriormente, se precisar colocar fixo, escolha um IP fora do range do pool que você usa no PPPoE). No "to-port=" é a porta que o servidor Apache está escutando, que aparentemente é 81.

    Quanto a regra que o nosso amigo disse que não precisa, deixa ela por enquanto, pois como comentei nos posts anteriores, não sei se você usa DNS externo, pois caso use, o forward das requisições DNS vão ser bloqueados pela regra logo abaixo daquela que libera o DNS, e dai não vai funcionar tb.



  7. #27

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    caro colega, so para finalizar, eu desistir de por o bloqueio. tenho certeza que estava errando em na regra no firewal..

    pois eu tenho um servidor ftp rodando em meu pc, na porta ex: 21 . como eu tenho o roteador com dhcp ligado , eu abrir a porta no mikrotik para meu ip wan que o mikrotik reconhece, depois eu abrir fiz uma dmz no meu roteador para meu ip local que o roteador está me dando. traduzindo. a questão do redirecionamento de portas inquiery, eu sei como fazer. agora devo está errando no firewal... mais deixa pra lah.. desisto...

  8. #28
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Ultimamente não tenho tido tempo para pegar mais trabalho. Como disse que lhe ajudaria. Entre em contato pelo Skype inter-homesolucoes amanhã a tarde. Que colocamos para funcionar.



  9. #29

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Beleza irmão... Viajei a trabalho não pude. Vou te add aqui