+ Responder ao Tópico



  1. #1

    Padrão Ajuda, Rede cabeada para de pingar depois volta

    Boa tarde aos amigos aqui,

    estou quebrando cabeça aqui, minha rede é wireless e cabo, minha rede cabeada funciona normal com ping´s estáveis 1ms, porem de vez em quando para de pingar e passa em media 60 segundos depois volta a pingar normalmente, porem isso acontece varias vezes por dia.

    ja troque todos os equipamento Switch, cabo etc..

    aguem ja passou por isso pra me dar uma luz pois ja nao sei o que fazer, obrigado

  2. #2

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Geralmente isso é conflito de endereços de IP.

    Você usa IPs fixos? Se sim, você usa somente switchs gerenciáveis (ou desses chamados "vlan fixa")? Se sim, você pode ir cadastrando no ARP do seu router os IP/MAC dos dispositivos de clientes. Isso evitaria que um segundo cliente com o mesmo endereço IP conseguisse se comunicar por IP com o router, evitando esse intercalamento de atividade entre dispositivos com o mesmo IP. Porém, se você usa switchs normais ao longo da rede, não tem muito o que fazer, se tem conflito de IP, vai ter que descobrir onde ta e trocar para resolver o problema.

    Se a sua rede é puramente cabeada até o gateway e perde pacotes, pode ser isso. Se tem um PTP no meio do caminho, pode ser problema no PTP.



  3. #3

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Desconfie também de mac clonado.
    (Intencionalmente ou por acidente)

    Numa empresa encontrei algo do tipo, do nada a rede parava por uns minutos, foi trocado o switch Intelbras 24p por um Cisco e o problema diminuiu mas não parou, rodando software de scan na rede notei 2 roteadores com o mesmo MAC, provavelmente usaram o backup de um pra "configurar" o outro, foi só trocar o mac de um e tudo milagrosamente se resolveu. Como eram roteadores wifi só pra funcionário usar whatsapp e cia ninguém dava bola pra eles.

    E desconfie também de malwares nos micros. Já ví micro com tanto, mas tanto, mas tanto, malware que o switch gerenciado travava!
    Em empresa é mais fácil ver isso, é só bater o olho em cada micro que se detecta fácil o culpado, senão o jeito é sair desplugando cada um até achar o culpado.

    Algo menos intrusivo (Fisicamente intrusivo) seria monitorar a rede pra ver se tem trafego demais de algum IP (Malware faz isso), digamos usando o wireshark ou o net scanner da MS:
    https://www.wireshark.org/download.html
    ou
    http://www.microsoft.com/en-us/downl...s.aspx?id=4865
    ou
    http://www.colasoft.com/capsa-free/

    Malware que trava switch gera muuuuuuuito trafego, é fácil perceber no Wireshark, 50 pacotes vindo do IP 192.168.1.x em sequencia, 2 ou 3 rumo aos outros IP's, aquele cheio de pacotes só pode ter um malware mandando uma rajada de pacotes pra rede, é só remover o antivírus desse usuário e usar ferramentas de segurança eficientes (Algemas, chicotes, tapas na orelha... e antipsywares).

  4. #4

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Citação Postado originalmente por inquiery Ver Post
    Geralmente isso é conflito de endereços de IP.

    Você usa IPs fixos? Se sim, você usa somente switchs gerenciáveis (ou desses chamados "vlan fixa")? Se sim, você pode ir cadastrando no ARP do seu router os IP/MAC dos dispositivos de clientes. Isso evitaria que um segundo cliente com o mesmo endereço IP conseguisse se comunicar por IP com o router, evitando esse intercalamento de atividade entre dispositivos com o mesmo IP. Porém, se você usa switchs normais ao longo da rede, não tem muito o que fazer, se tem conflito de IP, vai ter que descobrir onde ta e trocar para resolver o problema.

    Se a sua rede é puramente cabeada até o gateway e perde pacotes, pode ser isso. Se tem um PTP no meio do caminho, pode ser problema no PTP.
    uso pppoe e hotspot



  5. #5

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Citação Postado originalmente por rubem Ver Post
    Desconfie também de mac clonado.
    (Intencionalmente ou por acidente)

    Numa empresa encontrei algo do tipo, do nada a rede parava por uns minutos, foi trocado o switch Intelbras 24p por um Cisco e o problema diminuiu mas não parou, rodando software de scan na rede notei 2 roteadores com o mesmo MAC, provavelmente usaram o backup de um pra "configurar" o outro, foi só trocar o mac de um e tudo milagrosamente se resolveu. Como eram roteadores wifi só pra funcionário usar whatsapp e cia ninguém dava bola pra eles.

    E desconfie também de malwares nos micros. Já ví micro com tanto, mas tanto, mas tanto, malware que o switch gerenciado travava!
    Em empresa é mais fácil ver isso, é só bater o olho em cada micro que se detecta fácil o culpado, senão o jeito é sair desplugando cada um até achar o culpado.

    Algo menos intrusivo (Fisicamente intrusivo) seria monitorar a rede pra ver se tem trafego demais de algum IP (Malware faz isso), digamos usando o wireshark ou o net scanner da MS:
    https://www.wireshark.org/download.html
    ou
    http://www.microsoft.com/en-us/downl...s.aspx?id=4865
    ou
    http://www.colasoft.com/capsa-free/

    Malware que trava switch gera muuuuuuuito trafego, é fácil perceber no Wireshark, 50 pacotes vindo do IP 192.168.1.x em sequencia, 2 ou 3 rumo aos outros IP's, aquele cheio de pacotes só pode ter um malware mandando uma rajada de pacotes pra rede, é só remover o antivírus desse usuário e usar ferramentas de segurança eficientes (Algemas, chicotes, tapas na orelha... e antipsywares).
    ok rubens vou tentar fazer um monitoramento se não o jeito vai ser desplugar um por um,''vai dar um trabalho'' mas valeu

  6. #6

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Se você usa PPPoE e não tem regras para controle de ICMP tirando esse trafego do queue principal da interface pppoe, caso o usuário esteja fazendo uso extremo da banda dele (mtas conexões, como baixando algo por torrent ou gerenciador), toda a banda vai estar sendo consumida, e os ICMP costumam se perder sim, durante um bom tempo, mas não porque a rede deu problema, mas porque não tem espaço no queue para os pacotes ICMP.

    Eu aqui costumo usar queues com tamanho bem grande, para evitar um pouco os drops. Almenta a latencia quando tem uso da banda e causa ainda mais perde desses pacotes pelo fato do queue ser grande pra caralho e geralmente o tempo de timeout do ping, no ROS é de 1s.

    Uma coisa que você pode fazer pra testar, é algo assim:

    Código :
    /ip firewall mangle add chain=prerouting connection-mark=no-mark protocol=icmp action=mark-connection new-connection-mark=ICMP
    /ip firewall mangle add  chain=output connection-mark=ICMP packet-mark=no-mark src-address-type=local action=mark-packet new-packet-mark=ICMP_Packet
    /ip firewall mangle add chain=prerouting connection-mark=ICMP packet-mark=no-mark dst-address-type=local action=mark-packet new-packet-mark=ICMP_Packet
     
    /queue simple add target=0.0.0.0/0 max-limit=100M/100M packet-marks=ICMP_Packet

    (eu escrevo mtas regras de cabeça aqui no fórum, as vezes fica alguma coisa errada, qualquer coisa da uma verificada, usando a lógica da pra entender e arrumar se ficou algo errado).

    Essas regras, de mangle, coloca ela no inicio da sua lista de regras de mangle, move elas pelo Winbox. A mesma coisa com a regra de queue, deixa ele como a primeira regra.

    Desse jeito, você vai marcar os pacotes ICMP e eles vão cair nessa regra que você criou do Queue, não indo pro queue da interface do PPPoE nem do IP do hotspot. Da uma testada, se for isso, você ja vai descobrir que não é problema na rede, mas só no queue mesmo.



  7. #7

    Padrão Re: Ajuda, Rede cabeada para de pingar depois volta

    Citação Postado originalmente por isaquebrumel Ver Post
    Boa tarde aos amigos aqui,

    estou quebrando cabeça aqui, minha rede é wireless e cabo, minha rede cabeada funciona normal com ping´s estáveis 1ms, porem de vez em quando para de pingar e passa em media 60 segundos depois volta a pingar normalmente, porem isso acontece varias vezes por dia.

    ja troque todos os equipamento Switch, cabo etc..

    aguem ja passou por isso pra me dar uma luz pois ja nao sei o que fazer, obrigado

    Seria bom se você pudesse explicar sua topologia com mais detalhes, seria mais fácil pra a gente ter um embasamento e dar essa força, de qual local da rede você está pingando? Usa algum ptp no caminho? Acontece sempre ou somente quando há maior tráfego?.