Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Segue as Regras Berghetti;

    ip firewall mangle
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link1_conn per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link2_conn per-connection-classifier=\
    both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=link1_conn \
    in-interface=ether5 new-routing-mark=link1_routing
    add action=mark-routing chain=prerouting connection-mark=link2_conn \
    in-interface=ether5 new-routing-mark=link2_routing
    add action=mark-connection chain=prerouting in-interface=pppoe-out1 \
    new-connection-mark=link1Down_conn
    add action=mark-connection chain=prerouting in-interface=pppoe-out2 \
    new-connection-mark=link2Down_conn
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=Up_conn
    add action=mark-packet chain=prerouting connection-mark=link1Down_conn \
    new-packet-mark=down_1_packet
    add action=mark-packet chain=prerouting connection-mark=link2Down_conn \
    new-packet-mark=down_2_packet
    add action=mark-packet chain=prerouting connection-mark=Up_conn \
    new-packet-mark=Up_packet
    add action=mark-packet chain=prerouting connection-bytes=5242880-41943040 \
    new-packet-mark=TrafegoMedio_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=0-5242880 \
    new-packet-mark=TrafegoLeve_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=41943040-734003200 \
    new-packet-mark=TrafegoMedio2_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=734003200-3221225472 \
    new-packet-mark=TrafegoPesado_conn protocol=tcp
    /ip firewall nat
    add action=masquerade chain=srcnat
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=9622
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=8829

    /ip route
    add distance=1 gateway=pppoe-out1 routing-mark=link1_routing
    add distance=1 gateway=pppoe-out2 routing-mark=link2_routing

    /queue tree
    add max-limit=20M name=Download packet-mark=down_1_packet,down_2_packet \
    parent=global priority=1 queue=default
    add max-limit=1M name=Up packet-mark=Up_packet parent=global priority=1 \
    queue=default
    add name=TrafegoLeve packet-mark=TrafegoLeve_conn parent=Download priority=1 \
    queue=default
    add name=TrafegoMedio packet-mark=TrafegoMedio_conn parent=Download priority=\
    2 queue=default
    add name=TrafegoMedio2 packet-mark=TrafegoMedio2_conn parent=Download \
    priority=3 queue=default
    add name=TrafegoPesado packet-mark=TrafegoPesado_conn parent=Download queue=\
    default

  2. Segue as regras Berghetti, tenho um balance com QoS;

    /ip firewall mangle
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link1_conn per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link2_conn per-connection-classifier=\
    both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=link1_conn \
    in-interface=ether5 new-routing-mark=link1_routing
    add action=mark-routing chain=prerouting connection-mark=link2_conn \
    in-interface=ether5 new-routing-mark=link2_routing
    add action=mark-connection chain=prerouting in-interface=pppoe-out1 \
    new-connection-mark=link1Down_conn
    add action=mark-connection chain=prerouting in-interface=pppoe-out2 \
    new-connection-mark=link2Down_conn
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=Up_conn
    add action=mark-packet chain=prerouting connection-mark=link1Down_conn \
    new-packet-mark=down_1_packet
    add action=mark-packet chain=prerouting connection-mark=link2Down_conn \
    new-packet-mark=down_2_packet
    add action=mark-packet chain=prerouting connection-mark=Up_conn \
    new-packet-mark=Up_packet
    add action=mark-packet chain=prerouting connection-bytes=5242880-41943040 \
    new-packet-mark=TrafegoMedio_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=0-5242880 \
    new-packet-mark=TrafegoLeve_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=41943040-734003200 \
    new-packet-mark=TrafegoMedio2_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=734003200-3221225472 \
    new-packet-mark=TrafegoPesado_conn protocol=tcp
    /ip firewall nat
    add action=masquerade chain=srcnat
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=9622
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=8829

    /ip route
    add distance=1 gateway=pppoe-out1 routing-mark=link1_routing
    add distance=1 gateway=pppoe-out2 routing-mark=link2_routing

    /queue tree
    add max-limit=20M name=Download packet-mark=down_1_packet,down_2_packet \
    parent=global priority=1 queue=default
    add max-limit=1M name=Up packet-mark=Up_packet parent=global priority=1 \
    queue=default
    add name=TrafegoLeve packet-mark=TrafegoLeve_conn parent=Download priority=1 \
    queue=default
    add name=TrafegoMedio packet-mark=TrafegoMedio_conn parent=Download priority=\
    2 queue=default
    add name=TrafegoMedio2 packet-mark=TrafegoMedio2_conn parent=Download \
    priority=3 queue=default
    add name=TrafegoPesado packet-mark=TrafegoPesado_conn parent=Download queue=\
    default



  3. Obrigado pela dica inquiery, mais como disse sou novato, rsrsrsrs... onde e como seria feita essa marcação para não marcar quando o destino for o Gateway???

  4. você usa uma RB para fazer o balanceamento e a distribuição interna, ou usa duas RB, uma para balance outra para distribuir para a rede?
    Código :
     ip firewall mangle add action=accept chain=prerouting disabled=no src-address=COLOQUE A FAIXA DE IP DA SUA REDE
    tenta coloca essa regra no topo do mangle.



  5. Uso uma Rb para balanceamento e distribuição interna através de DHCP...
    Então cara coloquei essa regra e permanece sem resposta... o estranho é que quando desativo as rotas das ADSL a RB volta a responder os ping's... Segue o print como fica com as rotas ativas e com ela desativadas, e gateway é esse mesmo 172.16.10.5.

    Clique na imagem para uma versão maior

Nome:	         com rota.png
Visualizações:	42
Tamanho: 	87,1 KB
ID:      	59940Clique na imagem para uma versão maior

Nome:	         sem rotas.png
Visualizações:	28
Tamanho: 	95,8 KB
ID:      	59941






Tópicos Similares

  1. Problema com LOAD BALANCE
    Por AndersonBruno no fórum Redes
    Respostas: 5
    Último Post: 27-10-2015, 20:10
  2. problema com load balance jogos on line
    Por robertopc95 no fórum Redes
    Respostas: 5
    Último Post: 12-02-2014, 19:10
  3. problemas com load balance 2 links em brigde
    Por maxelldj no fórum Redes
    Respostas: 4
    Último Post: 23-10-2012, 20:22
  4. Respostas: 1
    Último Post: 19-06-2009, 21:45
  5. Preciso de ajuda com Load Balance no mikrotik
    Por JeanGutemberg no fórum Redes
    Respostas: 7
    Último Post: 13-11-2007, 18:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L