+ Responder ao Tópico



  1. #1

    Padrão Acessar dispositivos através do mikrotik.

    Olá. Praticando e treinando com uma rb750 me deparei com uma questão que não consegui resolver até hoje. Já pesquisei em fóruns, e não encontrei. Acredito que por ser um caso bem específico não tenha encontrado registro de alguém que tenha passado pelo mesmo.

    A questão é bem simples, e espero que alguém possa me dar alguma "luz". Tenho um nanostation que está conectado na porta5 da minha rb, e eu atras de um roteador na porta4. Quero poder acessá-lo, pelo menos pela minha rede interna. Não tenho ip válido, e já tenho a internet funcionando. Quando eu digito o ip da antena, 192.168.88.222, ele abre a tela de autenticação do mikrotik. Já tentei de tudo.
    Desde Já agradeço pela atenção de todos.

  2. #2

    Padrão Re: Acessar dispositivos através do mikrotik.

    Parece ser alguma configuração DMZ ou redirecionamento de porta que você configurou. Ou então a rede não está roteada corretamente.



  3. #3

    Padrão Re: Acessar dispositivos através do mikrotik.

    Tem pouca informação sobre as configurações.
    Este nanostation está configurado como Station e como bridge? Se estiver como bridge, passa ele para roteado. Como station bridge ele não permite acesso remoto.

  4. #4

    Padrão Re: Acessar dispositivos através do mikrotik.

    Rimaraujo, eu não fiz essas configurações. Tentei criar uma regra no firewall>Nat, mas não funcionou.

    1929, ele está como AP. Serve para autenticação pppoe de qualquer rádio que se conectar a ele. Está funcionando, já testei e consigo me autenticar corretamente, mas não consigo acessar rádio algum pelo mikrotik. Já tentei criar regra no firewall, adicionar o ip do AP no ip adress, criar rota, mas nada funcionou.
    Quais outras informações podem ser úteis para matarmos essa charada?

    Desde já agradeço pela gentileza dos senhores.



  5. #5

    Padrão Re: Acessar dispositivos através do mikrotik.

    Me adiciona Skype [email protected]

  6. #6

    Padrão Re: Acessar dispositivos através do mikrotik.

    OK, ele está como AP Bridge... Mas e os rádios dos clientes estão como bridge? Se estiverem você não vai acessa-los



  7. #7

    Padrão Re: Acessar dispositivos através do mikrotik.

    Acessa.. ele só precisa de uma rede roteada..

  8. #8

    Padrão Re: Acessar dispositivos através do mikrotik.

    Adicionado. Qualquer novidade vou postar aqui para compartilhar com os outros.



  9. #9

    Padrão Re: Acessar dispositivos através do mikrotik.

    Citação Postado originalmente por 1929 Ver Post
    OK, ele está como AP Bridge... Mas e os rádios dos clientes estão como bridge? Se estiverem você não vai acessa-los
    O cliente eu ponho em modo cliente, router, com autenticação em pppoe.

  10. #10

    Padrão Re: Acessar dispositivos através do mikrotik.

    Alguém pode me dar alguma dica? Preciso muito conseguir realizar esse acesso.



  11. #11

    Padrão Re: Acessar dispositivos através do mikrotik.

    Citação Postado originalmente por 1929 Ver Post
    Tem pouca informação sobre as configurações.
    Este nanostation está configurado como Station e como bridge? Se estiver como bridge, passa ele para roteado. Como station bridge ele não permite acesso remoto.
    Citação Postado originalmente por rimaraujo Ver Post
    Acessa.. ele só precisa de uma rede roteada..
    Por isso que eu disse antes que tinha que ser roteado... Todos os clientes nós acessamos com cliente roteado. Se deixar o cliente em bridge não acessa.
    @harpia, coloca uns prints das configurações... pois se está como cliente roteado tinha que acessar... a não ser que voce tenha mudado a porta padrão que é 80.

    Nós usavámos por algum tempo em 2.4 os Smartlan e eles vem como default 8080. Se o instalador não mudasse a porta não tinha acesso mesmo roteado... Daí era só colocar o ip :8080. E remotamente eu mudava para a 80 que é utilizado na maioria dos firmwares.

  12. #12

    Padrão Re: Acessar dispositivos através do mikrotik.

    Da um export nas configurações do seu mk e cola aqui. Fica mais fácil. Ou se preferir posso tentar te ajudar com um acesso remoto. E colocamos aqui o resultado. Por este pode ser o problema de outros também.



  13. #13

    Padrão Re: Acessar dispositivos através do mikrotik.

    Toda vez que tento acessar o rádio cai nessa página
    Clique na imagem para uma versão maior

Nome:	         Sem título-1.jpg
Visualizações:	50
Tamanho: 	97,3 KB
ID:      	60978

    E essa é a minha configuração:

    [[email protected]] > export
    # sep/16/2015 09:41:07 by RouterOS 6.30.1
    # software id = 1A6A-RRN5
    #
    /interface ethernet
    set [ find default-name=ether1 ] name=NET1
    set [ find default-name=ether2 ] name=NET2
    set [ find default-name=ether5 ] name=TORRE
    /ip hotspot profile
    add dns-name=google hotspot-address=192.168.129.2 name=hsprof1
    /ip pool
    add name=pool.PPPOE ranges=192.168.88.2-192.168.88.253
    add name=dhcp_pool1 ranges=2.168.88.221-192.168.88.2
    add name=hs-pool-3 ranges=192.168.129.1,192.168.129.3-192.168.129.254
    add name=vpn ranges=192.168.88.2-192.168.88.221
    /ip dhcp-server
    add address-pool=hs-pool-3 disabled=no interface=ether3 lease-time=1h name=\
    dhcp1
    add address-pool=dhcp_pool1 disabled=no interface=TORRE name=dhcp2
    /ip hotspot
    add address-pool=hs-pool-3 disabled=no interface=ether3 name=hotspot1 profile=\
    hsprof1
    /ppp profile
    add local-address=192.168.88.1 name=PPPOE-CLIENTE-IP remote-address=pool.PPPOE
    add name=5mega rate-limit=50000k/5000k
    add name=1mega rate-limit=10000k/1000k
    add local-address=192.168.88.5 name=perfilvpn only-one=yes remote-address=vpn
    /interface pppoe-server server
    add default-profile=PPPOE-CLIENTE-IP disabled=no interface=TORRE max-mru=1480 \
    max-mtu=1480 mrru=1600 service-name=SERVIDOR.PPPOE
    add default-profile=PPPOE-CLIENTE-IP disabled=no interface=ether4 max-mru=1480 \
    max-mtu=1480 mrru=1600 service-name=service1
    /interface pptp-server server
    set authentication=pap,chap,mschap1,mschap2 default-profile=perfilvpn enabled=\
    yes
    /ip address
    add address=192.168.0.2/30 interface=NET1 network=192.168.0.0
    add address=192.168.1.2/30 interface=NET2 network=192.168.1.0
    add address=192.168.88.1/24 interface=TORRE network=192.168.88.0
    add address=192.168.88.2/24 interface=ether4 network=192.168.88.0
    add address=192.168.129.1/24 comment="hotspot network" interface=ether3 \
    network=192.168.129.0
    add address=192.168.88.222 interface=TORRE network=192.168.88.222
    /ip arp
    add address=192.168.88.254 interface=TORRE
    /ip cloud
    set ddns-enabled=yes
    /ip dhcp-server network
    add address=10.5.50.0/24 comment="hotspot network" gateway=10.5.50.1
    add address=192.168.88.0/24 gateway=192.168.88.1
    add address=192.168.129.0/24 comment="hotspot network" gateway=192.168.129.2
    /ip dns
    set servers=8.8.8.8,8.8.4.4
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add chain=prerouting comment="================" dst-address=192.168.88.0/30 \
    src-address=192.168.88.0/30
    add chain=prerouting dst-address=192.168.0.0/30 src-address=192.168.88.0/30
    add chain=prerouting dst-address=192.168.1.0/30 src-address=192.168.88.0/30
    add action=mark-connection chain=prerouting comment="================" \
    connection-mark=no-mark in-interface=NET1 new-connection-mark=\
    NET1_CONEXOES
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=NET2 new-connection-mark=NET2_CONEXOES
    add action=jump chain=prerouting comment="==============" connection-mark=\
    no-mark in-interface=TORRE jump-target=POLITICA_DE_ROTEAMENTO
    add action=jump chain=prerouting connection-mark=no-mark in-interface=ether4 \
    jump-target=POLITICA_DE_ROTEAMENTO
    add action=mark-routing chain=prerouting comment="==================" \
    connection-mark=NET1_CONEXOES new-routing-mark=NET1_TRAFICO src-address=\
    192.168.88.0/30
    add action=mark-routing chain=prerouting connection-mark=NET2_CONEXOES \
    new-routing-mark=NET2_TRAFICO src-address=192.168.88.0/30
    add action=mark-routing chain=output comment="=================" \
    connection-mark=NET1_CONEXOES new-routing-mark=NET1_TRAFICO
    add action=mark-routing chain=output connection-mark=NET2_CONEXOES \
    new-routing-mark=NET2_TRAFICO
    add action=mark-connection chain=POLITICA_DE_ROTEAMENTO comment=\
    "====================" dst-address-type=!local new-connection-mark=\
    NET1_CONEXOES per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=POLITICA_DE_ROTEAMENTO dst-address-type=\
    !local new-connection-mark=NET2_CONEXOES per-connection-classifier=\
    both-addresses:2/1
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat out-interface=NET1
    add action=masquerade chain=srcnat out-interface=NET2
    add action=masquerade chain=srcnat comment="pppoe net" src-address=\
    192.168.88.0/30
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    src-address=192.168.129.0/24
    add action=masquerade chain=srcnat comment="nat vpn" src-address=\
    192.168.88.0/24
    add action=dst-nat chain=dstnat comment="acesso radio" dst-address=\
    192.168.88.1 dst-port=4040 protocol=tcp to-addresses=192.168.88.222 \
    to-ports=80
    add action=dst-nat chain=dstnat comment="acesso radio" dst-address=\
    192.168.88.1 dst-port=4040 protocol=udp to-addresses=192.168.88.222 \
    to-ports=80
    add action=dst-nat chain=dstnat comment="acesso radio" dst-address=\
    192.168.88.222 dst-port=80 protocol=tcp to-addresses=192.168.88.222 \
    to-ports=80
    /ip hotspot user
    add name=harpia password=1234
    /ip route
    add distance=1 gateway=192.168.0.1 routing-mark=NET1_TRAFICO
    add distance=1 gateway=192.168.1.1 routing-mark=NET2_TRAFICO
    add distance=2 gateway=192.168.0.1
    add distance=3 gateway=192.168.1.1
    add distance=1 dst-address=192.168.88.0/24 gateway=TORRE
    add distance=1 dst-address=192.168.88.0/24 gateway=ether3 pref-src=\
    192.168.88.1 scope=10
    /ppp secret
    add name=david.teste password=123 profile=5mega service=pppoe
    add local-address=192.168.1.253 name=josue.fernandes password=123
    add name=harpia.teste profile=1mega
    add name=carlos.atanazio password=123 profile=5mega service=pppoe
    add name=harpia password=senhaxxx profile=perfilvpn service=pptp
    /system clock
    set time-zone-name=America/Sao_Paulo
    /system script
    add name=dnsomatic owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source="# DNSoMa\
    tic automatic DNS updates\r\
    \n\r\
    \n#--------------- Change Values in this section to match your setup ------\
    ------------\r\
    \n\r\
    \n# User account info of DNSoMatic\r\
    \n\r\
    \n:local maticuser \"jf1889\"\r\
    \n:local maticpass \"senhaxxx\"\r\
    \n\r\
    \n# Set the hostname or label of network to be updated. This is the part af\
    ter the double colon (: on the DNSoMatic services page.\r\
    \n# Hostnames with spaces are unsupported. Replace the value in the quotati\
    ons below with your host names.\r\
    \n# To specify multiple hosts, separate them with commas. \r\
    \n# Use \"all.dnsomatic.com\" for the matichost to update all items in dnso\
    matic with this IP.\r\
    \n\r\
    \n:local matichost \"all.dnsomatic.com,hostname2\"\r\
    \n\r\
    \n#------------------------------------------------------------------------\
    ------------\r\
    \n\r\
    \n# No more changes need\r\
    \n\r\
    \n:global previousIP;\r\
    \n\r\
    \n:log info \"Fetching current IP\"\r\
    \n\r\
    \n# Get the current public IP using DNS-O-Matic service.\r\
    \n/tool fetch url=\"http://myip.dnsomatic.com/\" mode=http dst-path=mypubli\
    cip.txt\r\
    \n\r\
    \n# Read the current public IP into the currentIP variable.\r\
    \n:local currentIP [/file get mypublicip.txt contents]\r\
    \n\r\
    \n:log info \"Fetched current IP as \$currentIP\"\r\
    \n \r\
    \n:if (\$currentIP != \$previousIP) do={\r\
    \n :log info \"DNSoMatic: Update needed\"\r\
    \n :set previousIP \$currentIP\r\
    \n \r\
    \n# The update URL. Note the \"\\3F\" is hex for question mark (\?). Requir\
    ed since \? is a special character in commands.\r\
    \n :local url \"http://updates.dnsomatic.com/nic/update\\3Fmyip=\$curren\
    tIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG\"\r\
    \n :local matichostarray;\r\
    \n :set matichostarray [:toarray \$matichost];\r\
    \n :foreach host in=\$matichostarray do={\r\
    \n :log info \"DNSoMatic: Sending update for \$host\"\r\
    \n /tool fetch url=(\$url . \"&hostname=\$host\") user=\$maticuser p\
    assword=\$maticpass mode=http dst-path=(\"dnsomaticupdate-\" . \$host . \".\
    txt\")\r\
    \n :log info \"DNSoMatic: Host \$host updated on DNSoMatic with IP \
    \$currentIP\"\r\
    \n }\r\
    \n} else={\r\
    \n :log info \"DNSoMatic: Previous IP \$previousIP and current IP equal,\
    \_no update need\"\r\
    \n}"

  14. #14

    Padrão Re: Acessar dispositivos através do mikrotik.

    Citação Postado originalmente por rimaraujo Ver Post
    Da um export nas configurações do seu mk e cola aqui. Fica mais fácil. Ou se preferir posso tentar te ajudar com um acesso remoto. E colocamos aqui o resultado. Por este pode ser o problema de outros também.
    Já te adicionei no skype. [email protected]



  15. #15

    Padrão Re: Acessar dispositivos através do mikrotik.

    Graças a ajuda do amigo rimaraujo conseguimos acessar o rádio como pretendido.
    Meu erro foi acrescentar o ip do rádio no adress list, o que fazia com que o mesmo desse acesso a tela de configuração do mikrotik.
    Obrigado a todos.

  16. #16

    Padrão Re: Acessar dispositivos através do mikrotik.

    Encerrado.