Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #7
    Avatar de Treme
    Ingresso
    Jan 2015
    Localização
    Linhares / Espirto Santo
    Posts
    67

    Padrão Re: Monitora a quantidade de estações conectadas em um AP

    Só os que estiveram ativos em tempo real, a intenção mesmo e saber quando devemos coloca um nova painel, não temos a intenção de coloca mais que 30 clientes em uma painel, isto é para ter um controle mais fácil.

  2. #8
    Avatar de Treme
    Ingresso
    Jan 2015
    Localização
    Linhares / Espirto Santo
    Posts
    67

    Padrão Re: Monitora a quantidade de estações conectadas em um AP

    Citação Postado originalmente por 1929 Ver Post
    Entendo...vai depender de para que finalidade as informações serão utilizadas.

    Mas se fosse eu, me interessaria em quantos estão ativos... senão a leitura poderia ser falsa, ou não?

    Por exemplo, é comum alguém dizer que tem 30 50 ou mais usuários num rádio. Mas na realidade quantos estão realmente consumindo banda e processamento do rádio?
    E uma coisa a sí pensa, mais a nivel de provedor não seria tão importante, o consumo total da AP ja bastaria



  3. #9

    Padrão Re: Monitora a quantidade de estações conectadas em um AP

    Citação Postado originalmente por Treme Ver Post
    E uma coisa a sí pensa, mais a nivel de provedor não seria tão importante, o consumo total da AP ja bastaria
    para o consumo total do AP não ficaria mais fácil um gráfico gerado pelo próprio Mikrotik?

  4. #10

    Padrão

    Eu coloquei no The Dude com o comando:
    /interface pppoe-server print count-only
    Eu tenho um PPPoE server por painel então poderia fazer:
    /interface pppoe-server print count-only where service="PainelA"

    Mas com certeza usar snmp é melhor que SSH ou API.

    Eu a algum tempo queria avaliar o quanto de banda entre as torres eu ganharia se centraliza-se as queues.

    pra isso fiz o seguinte script:

    Código :
    /queue simple
    :global downpackets 0
    :global downdropped 0
    :set downpackets 0
    :set downdropped 0
    :foreach i in=[find] do={:set downdropped ($downdropped + [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:set downpackets ($downpackets + [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:put [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ]}
    :put $downdropped
    :foreach i in=[find] do={:put [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ]}
    :put $downpackets
    :put (((($downdropped * 1000) / $downpackets )))

    Acho que isso pode ser adaptado pra saber quantos clientes estão realmente consumindo.



  5. #11

  6. #12

    Padrão Re: Monitora a quantidade de estações conectadas em um AP

    @eduardomazolini, fiz os procedimentos e não deu certo. Alguma sugestão?