Página 5 de 10 PrimeiroPrimeiro 123456789 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #81

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Boa tarde.
    AndrioPJ, quando pegar um conteúdo alheio para publicar em um fórum e querer se engrandecer sobre o assunto, pelo menos tenha a decência de dar os mérito ao autor e no caso sou eu Caio Fabeni.
    Vc copiou ate mesmo oque eu falo no vídeo.
    Já que vc fez esse QoS Individual explica ai para os membros o motivo de nao funcionar o UPload.

    Para que não fique duvidas da uma olhada no vídeo,

    Só procurar no meu canal que tem esse conteúdo com data bem mais antiga.

    No minimo comprou meu treinamento em vídeo e veio aqui tentar ganhar moral.

    Para que saiba quem escreveu sou eu o dono do conteúdo CAIO FABENI.

  2. #82

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Eu até pensei em falar que esse conteúdo era do Caio Fabeni (pois eu vi você postando no Facebook), sendo que até o presente momento o único que produziu esse QoS via script é você.

    Mas para evitar criar atritos nesse fórum, eu preferi ficar quieto.

    Eu já tentei publicar materiais aqui para ajudar o pessoal mas foi tanta cópia e venda do meu material que renderia um processo para um monte aqui, então abandonei. Esse fórum está virando um lixo, estou com pena.



  3. #83

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Alem de copiar, ainda fala que ele que desenvolveu. rsrs
    É para acabar um cara desse.
    E ainda esta como Moderador do Forum.
    Esse forum ja foi melhor. rsr
    A anos eu não participo, só me cadastrei novamente que achei uma sacanagem do cidadão, na maior cara de pau.

  4. #84
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.963
    Posts de Blog
    44

    Padrão Re: PPoE - QoS Dinâmico e Individual

    acho melhor esperarem o @AndrioPJ falar e dar suas versões dos fatos.



  5. #85
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.963
    Posts de Blog
    44

    Padrão Re: PPoE - QoS Dinâmico e Individual

    E adicionando O Vídeo em si não prova nada. Até porque, eu já fazia algo parecido com iptables , HTB/CBQ 18 anos atrás, logo não tem nada de inovador no que o @AndrioPJ fez ou no que o @redecompleta fez.

    Outro ponto é, se o que foi feito não foi patenteado ou é uma tecnologia inovadora que nunca foi usada por ninguém no mundo não sei nem pq estamos tendo essa discussão aqui.

    De toda forma vamos esperar o @AndrioPJ se pronunciar se de fato ele copiou algo ele vai falar

    Quer ver outro exemplo ?

    no Ano de 2000 eu fiz esse artigo
    http://www.abusar.org.br/PPPOE_RADIUS_BANDLIMIT.html

    Hoje todo mundo usa PPPOE RADIUS e BANDLIMIT, seja no linux, no mikrotik ou etc mas eu fui o primeiro e nem por isso eu fiquei mordido

  6. #86

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Legal, que ate os nomes ele colocou igual.
    O script esta igual ao meu.
    No minimo comprou meu treinamento pegou as regras e jogou aqui, chamei ele no face até o momento não me respondeu.
    Sobre o Video veja que os nomes são iguais ao que esta no post dele. ou vc acho muita coincidência.
    Mas vamos ver oque o mesmo vai falar.



  7. #87

    Padrão Re: PPoE - QoS Dinâmico e Individual

    " Outro ponto é, se o que foi feito não foi patenteado ou é uma tecnologia inovadora que nunca foi usada por ninguém no mundo não sei nem pq estamos tendo essa discussão aqui. "
    Sobre isso , quando compra um treinamento em video meu, tem um contrato onde diz que nao pode vender, compartilhar etc etc etc...
    E o mesmo me parece que fez tudo ao contrario.

    Mas como vc mesmo disse, não sei por que estamos falando disso.

  8. #88
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.963
    Posts de Blog
    44

    Padrão Re: PPoE - QoS Dinâmico e Individual

    @redecompleta, como você disse se até o nome das regras são iguais eu creio que algo duvidoso tenha acontecido, mas temos que esperar o @AndrioPJ se explicar.

    Sobre contrato de treinamento, creio que você esteja se referindo a vídeos ou powerpoints do seu treinamento, pois sintaxe e comandos a serem usados no mikrotik não creio que se aplicam a nenhum contrato.

    Você pode até ter feito um treinamento legal e ensinado alguém, mas você não criou o Mikrotik, você não criou QoS, você não criou limitação de banda logo você não tem direito intelectual sobre nada nesse sentido desta forma.

    O @AndrioPJ pode ter copiado e se fez deveria ter citado a fonte em suas referências como fez com várias outras ocasiões, mas você NUNCA pode limitar ninguem de compartilhar comandos/sintaxes de Mikrotik com ninguém simplesmente por que você não tem autoridade sobre o mesmo, mas como disse se fosse um vídeo ou um powerpoint iria concordar com você completamente no seu último comentário.

    De toda forma acho legal que você de e crie treinamentos e mesmo sem lhe conhecer lhe admiro.

    Sobre o @AndrioPJ ser moderador, isso não é relevante, pois qualquer um pode ser moderador até o @avatar52 era, e ficou bravo com algo e falou que nunca mais iria voltar, pediu para deletar sua conta e está ai de volta usando o nick @avatar52 ne não Arthur ?

    O mundo dá voltas e muitas pessoas vão, voltam outras já até morreram nos 17 anos de underlinux, mas o principal que peço a todos é profissionalismo e paz.



  9. #89

    Padrão PPoE - QoS Dinâmico e Individual

    Tentei dar uma chance pra esse fórum, porque como moderador levei mais pauladas que os outros.

    Como viu acima, pelo Andrio ser moderador já virou motivo.

  10. #90
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.963
    Posts de Blog
    44

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Você levou mais paulada que os outros devido a forma que se dirigia às pessoas.

    Existem pessoas que aprendem rápido, outras devagar e outras nunca vão aprender. O que você precisa aprender é tratar todos com respeito, educação ou então apenas ficar calado.

    Mas não vamos poluir o tópico com isso, só quero que o mundo seja melhor



  11. #91

    Padrão PPoE - QoS Dinâmico e Individual

    Não sou obrigado a mudar a minha forma de falar ou de me dirigir aos sujeitos aqui por causa de alguns que ficam choramingando, estou pouco me lixando para eles como eles pouco se preocupam comigo.

    A minha luta sempre será de acabar com receitinhas de bolo e provedores de fundo de quintal, e sempre manterei minha fala, não vou abaixar meu tom pra ninguém.

    Não leve nada pro lado pessoal, também quero que o mundo seja melhor, mas com pessoas melhores, não com um bando de preguiçosos em pleno 2017.

    Se para participar desse fórum tem que ficar alisando as pessoas, por favor me exclua e eu desisto de ajudar nesse fórum.

    Novamente, não leve nada pro lado pessoal como uma meia dúzia de bebês aqui.

  12. #92

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Citação Postado originalmente por avatar52 Ver Post
    Não sou obrigado a mudar a minha forma de falar ou de me dirigir aos sujeitos aqui por causa de alguns que ficam choramingando, estou pouco me lixando para eles como eles pouco se preocupam comigo.

    A minha luta sempre será de acabar com receitinhas de bolo e provedores de fundo de quintal, e sempre manterei minha fala, não vou abaixar meu tom pra ninguém.

    Não leve nada pro lado pessoal, também quero que o mundo seja melhor, mas com pessoas melhores, não com um bando de preguiçosos em pleno 2017.

    Se para participar desse fórum tem que ficar alisando as pessoas, por favor me exclua e eu desisto de ajudar nesse fórum.

    Novamente, não leve nada pro lado pessoal como uma meia dúzia de bebês aqui.
    Triste fala.



  13. #93

    Padrão Re: PPoE - QoS Dinâmico e Individual

    e esse aki é de quem?


    # REGRAS MANGLE
    /ip firewall mangle
    add action=mark-packet chain=forward comment=PRIO4-QoS_512k connection-bytes=1-512000 new-packet-mark=PRIO4-QoS_512k passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment=PRIO5-QoS_5M connection-bytes=512000-5000000 new-packet-mark=PRIO5-QoS_5M passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment=PRIO6-QoS_20M connection-bytes=5000000-20000000 new-packet-mark=PRIO6-QoS_20M passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment=PRIO7-QoS_50M connection-bytes=20000000-50000000 new-packet-mark=PRIO7-QoS_50M passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment=PRIO8-QoS_Infinity connection-bytes=50000000-0 new-packet-mark=PRIO8-QoS_Infinity passthrough=yes protocol=tcp

    # SCRIPTS
    /system script
    add name=on_down policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="##########################################\r\
    \n# QoS Dinamico Individual PPPoE\r\
    \n# Remover Queue Tree PPPoE\r\
    \n# By Jonas Oliveira\r\
    \n##########################################\r\
    \n:delay 1s;\r\
    \n/queue tree remove [find where invalid];\r\
    \n##########################################"
    add name=on_up policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="##########################################\r\
    \n# QoS Dinamico Individual PPPoE\r\
    \n# Adiciona Queue Tree PPPoE\r\
    \n# By Jonas Oliveira\r\
    \n# Versao: 2.0\r\
    \n##########################################\r\
    \n#================== VARIAVEIS ==================\r\
    \n# Plano Maximo Para o QoS ( em M )\r\
    \n:local PLANOMAXIMO 5;\r\
    \n#\r\
    \n# Plano Minimo Para o QoS ( em k )\r\
    \n:local PLANOMINIMO 1024;\r\
    \n#\r\
    \n##########################################\r\
    \n:delay 3s;\r\
    \n:foreach i in=[/queue simple find where name=\"<pppoe-\$user>\"] do={\r\
    \n:local queuename [/queue simple get \$i name];\r\
    \n:local rate [/queue simple get \$i max-limit];\r\
    \n:local down [ick \"\$rate\" \"\$([:find \"\$rate\" \"/\" -1 ] + 1)\" \"\$([:len \"\$rate\"] - 1)\" ]; \r\
    \n:local unidade [ick \"\$rate\" \"\$([:len \"\$rate\"] - 1)\"];\r\
    \n:local maxlimit \"\$down\";\r\
    \n:if (\"\$unidade\" = \"k\") do={\r\
    \n:set maxlimit \"\$down\"; \r\
    \n} else={\r\
    \n:set maxlimit [:tonum \"\$(\$down * 1024)\"];\r\
    \n:set unidade \"k\";\r\
    \n}\r\
    \n:if ((\$maxlimit <= \"\$(\$PLANOMAXIMO * 1024)\") && (\$maxlimit >= \$PLANOMINIMO)) do={ \r\
    \n/queue tree \r\
    \nadd name=\"QoS_\$queuename\" max-limit=\"\$maxlimit\$unidade\" parent=\"\$queuename\" queue=\"default\";\r\
    \nadd name=\"PRIO4-QoS_512k_\$queuename\" max-limit=\"\$maxlimit\$unidade\" limit-at=\"\$(\$maxlimit * 50 / 100)\$unidade\" packet-mark=\"PRIO4-QoS_512k\" parent=\"QoS\
    _\$queuename\" priority=\"4\" queue=\"default\";\r\
    \nadd name=\"PRIO5-QoS_5M_\$queuename\" max-limit=\"\$maxlimit\$unidade\" limit-at=\"\$(\$maxlimit * 20 / 100)\$unidade\" packet-mark=\"PRIO5-QoS_5M\" parent=\"QoS_\$q\
    ueuename\" priority=\"5\" queue=\"default\";\r\
    \nadd name=\"PRIO6-QoS_20M_\$queuename\" max-limit=\"\$maxlimit\$unidade\" limit-at=\"\$(\$maxlimit * 15 / 100)\$unidade\" packet-mark=\"PRIO6-QoS_20M\" parent=\"QoS_\
    \$queuename\" priority=\"6\" queue=\"default\";\r\
    \nadd name=\"PRIO7-QoS_50M_\$queuename\" max-limit=\"\$maxlimit\$unidade\" limit-at=\"\$(\$maxlimit * 10 / 100)\$unidade\" packet-mark=\"PRIO7-QoS_50M\" parent=\"QoS_\
    \$queuename\" priority=\"7\" queue=\"default\";\r\
    \nadd name=\"PRIO8-QoS_Infinity_\$queuename\" max-limit=\"\$maxlimit\$unidade\" limit-at=\"\$(\$maxlimit * 5 / 100)\$unidade\" packet-mark=\"PRIO8-QoS_Infinity\" pare\
    nt=\"QoS_\$queuename\" priority=\"8\" queue=\"default\";\r\
    \n};\r\
    \n};\r\
    \n##########################################"

    # SETAR SCRIPTS NO PROFILE PPPOE
    /ppp profile set on-down=on_down on-up=on_up [find];


    Esse é do fórum MK-Auth

  14. #94

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Muito bom! Esse qos. Mas pra quem tem link sobrando!
    Eu coloquei um cache, e esta sempre pegando o windows update e avast. rsrsrsrs....
    Até nem era pra fazer isso, cliente que se vire com a banda que tem!!!



  15. #95

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Citação Postado originalmente por redecompleta Ver Post
    Legal, que ate os nomes ele colocou igual.
    O script esta igual ao meu.
    No minimo comprou meu treinamento pegou as regras e jogou aqui, chamei ele no face até o momento não me respondeu.
    Sobre o Video veja que os nomes são iguais ao que esta no post dele. ou vc acho muita coincidência.
    Mas vamos ver oque o mesmo vai falar.
    Opa... Estava mto corrido aqui e não percebi esses comentários, só fui tomar conhecimento depois que me procuraram no facebook, mas vamos lá...:

    As regras que postei aqui são EXATAMENTE IGUAIS AS SUAS?
    pois então achei parte delas no forum da mikrotik, do mkauth e outros, datado em 2014~2015 (se observar, até citei algumas fontes, mas n todas), E se procurar mais a fundo, acha regras ou trechos "parecidos" em outros locais... E elas não eram suas, agora virando o feitiço contra o feiticeiro: "então você copiou de outro e não citou fontes no seu curso???"

    De qualquer forma, essas regras que achei em outros locais, n possuía suporte a burst, nem fazia o calculo do tempo.
    algo que criei na unha.

  16. #96

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Segue a vida, vamos que vamos.



  17. #97

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Como citei acima, cheguei a pesquisar esse assunto em vários locais, vi vários tópicos e videos, não cheguei a citar todos os fontes pq alguns acabei perdendo enquanto estudava o assunto (mas se quiser, posso editar o tópico inicial e adicionar seu video como fonte? pra mim n tem problema).

    Me recordo de ter visto seu vídeo de demonstração (esse mesmo que vc postou ai), ele me deu umas ideias tbm.

    De qualquer forma, me mandaram no privado (facebook) seu script e Acabei de analisar.... tem varias diferenças:
    1- As variáveis não são as mesmas.
    2 - nas suas regras de firewall, vc faz marcação em uma interface, e nesse script que postei faz marcação em outra interface.
    3 - Seu script não verifica se o usuário possui burst ou não, nem adiciona nenhuma regra de burst.
    4 - Seu script não faz a conversão do tempo recebido para um valor que o mikrotik aceite, alias, nem sequer menciona parte disso. Por exemplo, se o Burst Time do cliente é 80s, o script ao buscar esse dado, o mikrotik retorna o valor de 1m20... se pegar esse valor e adicionar a regra, dá erro.... Esse script que postei pega esse valor e converte de volta para 80.

    PS: esse script postado aqui já está 2 versão atrás, tenho novas regras nele.
    Inclusive, tem uma versão que criei que faz do upload tbm, mas ai as regras quase que duplicam, e acaba não compensando, consome mto recurso da RB.

  18. #98

    Padrão Re: PPoE - QoS Dinâmico e Individual

    Citação Postado originalmente por AndrioPJ Ver Post
    Como citei acima, cheguei a pesquisar esse assunto em vários locais, vi vários tópicos e videos, não cheguei a citar todos os fontes pq alguns acabei perdendo enquanto estudava o assunto.

    Me recordo de ter visto seu vídeo de demonstração (esse mesmo que vc postou ai), ele me deu umas ideias tbm.

    De qualquer forma, me mandaram no privado (facebook) seu script e Acabei de analisar.... tem varias diferenças:
    1- As variáveis não são as mesmas.
    2 - nas suas regras de firewall, vc faz marcação em uma interface, e nesse script que postei faz marcação em outra interface.
    3 - Seu script não verifica se o usuário possui burst ou não, nem adiciona nenhuma regra de burst.
    4 - Seu script não faz a conversão do tempo recebido para um valor que o mikrotik aceite, alias, nem sequer menciona parte disso. Por exemplo, se o Burst Time do cliente é 80s, o script ao buscar esse dado, o mikrotik retorna o valor de 1m20... se pegar esse valor e adicionar a regra, dá erro.... Esse script que postei pega esse valor e converte de volta para 80.

    PS: esse script postado aqui já está 2 versão atrás, tenho novas regras nele.
    Inclusive, tem uma versão que criei que faz do upload tbm, mas ai as regras quase que duplicam, e acaba não compensando, consome mto recurso da RB.
    @AndrioPJ Gostei bastante do script. Tô usando aqui.



  19. #99

    Padrão Re: PPoE - QoS Dinâmico e Individual

    @AdrianoPJ acho que deve, como você se propôs citar ele, já que lembra de ter usado. O cara foi infeliz na forma de expor principalmente em justificar. A inversão sua é válida. Eu ainda não tô usando, nem sei se vou, mas tô seguindo que gostei da iniciativa. Você expôs uma forma de fazer em cima de regras que todos tem acesso e conhecem, o que vai permitir colaboração pra sua melhoria.

    Dizer que vai banir as receitas de bolo é ridículo. Seguindo a idéia da receita de bolo todos nós sabemos fazer bolo, conhecemos os ingredientes, mas as vezes pegamos na receita dos outros a dica da pitada de sal o pulinho que faz toda a diferença. Agora pode alguém pegar a receita e se queimar no forno, falta de prática e conhecimento mínimo. Culpa de quem escreveu a receita, dela existir?
    Por isso a partir de agora só admitirmemos comer de cozinheiros formados.

  20. #100

    Padrão Re: PPoE - QoS Dinâmico e Individual

    kkkkkkkk .... isso aê!!! ok... blz! Mas não digo de cozinheiros formados, mas de grande estrada, grandes anos!!!!!!