+ Responder ao Tópico



  1. #1

    Padrão Ola, pessoal

    estou com um problema com a minha vpn.
    criei da seguinte forma.
    Criação de VPN entre matriz e filial de uma empresa usando servidores Mikrotik nas duas pontas.

    Levando em consideração a seguinte estrutura:

    Matriz:

    • Rede Local: 192.168.0.X/24
    • Ip local do Servidor: 192.168.0.1
    • Ip Internet do Servidor: 201.200.200.200


    Filial:

    • Rede Local: 192.168.10.X/24
    • Ip local do Servidor: 192.168.10.1
    • Ip Internet do Servidor: 189.50.1.200


    VPN:

    • Faixa IPs: 10.0.0.X/24


    Configurações

    Partindo do ponto de que os dois servidores já estão devidamente configurados e navegando na Internet repassando a navegação para rede Interna e seus clientes via NAT, iremos configurar o Server VPN na matriz.

    Antes de mais nada, devemos habilitar duas opções no menu Ip > firewall > Service Ports, clique com o botão direito e selecione enable em "GRE" e "PPTP".

    Abra o servidor Mikrotik pelo winbox, acesse o menu ppp. Na primeira guia Interfaces clique na opção L2TP Server marque a opção enable.

    Na segunda guia, "secrets", crie um usuário para conectar ao Server pela VPN:

    Usuário: teste
    Senha: teste
    Local address: 10.0.0.1
    Remote address: 10.0.0.2

    Dessa forma seu servidor estará preparado para ouvir e autenticar requisições L2TP. Ainda falta configurar as rotas nesse servidor para que as máquinas internas possam ver a outra rede e vice-versa. Vá em Ip > routes e crie as duas rotas abaixo:

    Primeira Rota: 10.0.0.0/24 > gateway 192.168.0.1
    Segunda Rota: 192.168.10.0/24> Gateway 10.0.0.2

    A rota 10.0.0.0/24 apontando para o gateway 192.168.0.1 indica que a rede usada pela vpn será roteada pelo ip 192.168.0.1 que é da placa interna do servidor e a rota 192.168.10.0/24 indica que a rede interna do servidor da filial será roteada pelo ip remoto que o servidor da filial receberá quando conectar.

    Configuramos o servidor da matriz, agora vamos para o servidor da Filial:

    Vá em PPP, na aba Interfaces crie o usuário para se conectar conforme abaixo:

    Server: 201.200.200.200
    user: teste
    password: teste

    Clique em ok e logo o usuário já se conectará ao outro servidor, dessa forma você já poderá testar do próprio servidor Mikrotik se está pingando para o IP de alguma maquina na rede interna da matriz.

    Para que suas máquinas na Filial com a faixa 192.168.10.X possam acessar as máquinas da matriz você terá que criar a mesma estrutura de rotas que foi criada para na matriz só que direcionando pra sua rede interna, abaixo:

    Primeira Rota: 10.0.0.0/24 > gateway 192.168.10.1
    Segunda Rota: 192.168.0.0/24> Gateway 10.0.0.1

    esse post eu copie desse forum mais nao consigo acessar minhas maquinas dentro das duas redes nem na matriz e nem na filial.
    por favor agradeço qm poder mim ajudar.

  2. #2

    Padrão

    Simples:

    Suponhamos que o SERVER DA VPN ESTEJA NA MATRIZ

    # MATRIZ REDE 192.168.10.0/24
    /ip route
    add distance=111 dst-address=192.168.10.0/24 gateway=10.0.0.2



    # FILIAL REDE 192.168.0.0/24
    /ip route
    add distance=111 dst-address=192.168.0.0/24 gateway=10.0.0.1



    Desabilite o snat no prefixo 10.0.0.0 /30 em ambos roteadores.



  3. #3