+ Responder ao Tópico



  1. #1

    Lightbulb Roteamento cgnat

    Boa noite.
    Recentemente, resolvi separar o serviços por router, então dessa forma, vou colocar somente um mikrotik (CCR1036-8G-2S+) para fazer o serviço de CGNAT, até ai ok. Porém ainda não encontrei uma forma de fazer o roteamento chegar até o concentrador, pois neste mesmo concentrador, tenho clientes com IP Fixo. Abaixo a topologia.

    Clique na imagem para uma versão maior

Nome:	         Desenho1.png
Visualizações:	15
Tamanho: 	16,2 KB
ID:      	69939

    Acima, representei o meu bloco válido como 192.168.x.x.

    BGP, fecha uma conexão direta com o concentrador: 192.168.0.1/28 BGP - 192.168.0.2/28 Concentrador

    CGNAT, fecha uma conexão direta com o BGP: 192.168.1.0/30 BGP - 192.168.1.2/30 CGNAT. Fiz uma rota estática no BGP, aonde envio a classe que fiz o CGNAT, o serviço do CGNAT está OK. Usei a classe 100.127.0.0/19 para o meu serviço.

    Porém a minha dúvida, está sendo em questão ao roteamento até o concentrador, lembrando que, eu ainda tenho porta disponível no equipamento de CGNAT ou posso fazer via VLAN mesmo pela porta UP de 10G entre BGP x CGNAT.
    No meu BGP, eu também tenho uma fatia de IP que uso para clientes que tem IP fixo, aonde aponto o bloco estaticamente, direto para o Concentrador, atualmente o serviço está funcionando normal.

    Tentei dentro do CGNAT apontar a classe 100.127.0.0/19 para o IP do concentrador, porém não deu certo, já que o concentrador tem o gateway do IP do BGP.

    Não queria apontar todo o tráfego para o router do CGNAT, se possível. Tentei fazer por mangle na marcação de rota, mas não deu muito certo também, pois não consigo acessar os clientes, e também eles não conseguem acessar alguns serviços da nossa empresa.

    CGNAT
    Código :
    /ip route
    add comment="CGNAT --> ROUTER" distance=1 dst-address=100.127.0.0/19 gateway=192.168.1.1



    Como a classe entre o CGNAT e Concentrador é diferente, eu apontei para o BGP, e no BGP, eu apontei para o Concentrador.

    BGP
    Código :
    /ip route
    add comment="CGNAT --> ROUTER" distance=1 dst-address=100.127.0.0/19 gateway=192.168.0.2


    Gostaria de saber se alguém tem alguma ideia de como eu poderia fazer neste cenário.

  2. #2

    Padrão Re: Roteamento cgnat

    Sobe o concentrador depois do cgnat



  3. #3

    Padrão Re: Roteamento cgnat

    Citação Postado originalmente por Fcnetwork Ver Post
    Sobe o concentrador depois do cgnat
    e usar o cgnat de gateway? e a classe válida que eu preciso passar dos clientes fixo? que na logica seria direto do BGP para o concentrador?

  4. #4

    Padrão Re: Roteamento cgnat

    faz por rota



  5. #5

    Padrão Re: Roteamento cgnat

    Citação Postado originalmente por Fcnetwork Ver Post
    faz por rota
    na sua opinião, como ficaria melhor este cenário a topologia? e como faria o roteamento? Pode dar sua opinião um pouco melhor? senão for incomodo.

  6. #6

    Padrão Re: Roteamento cgnat

    Eu colocaria um suite gerenciável para fazer vlans na saida do bgp e ligaria cgnat e concentrador no suite.
    Outra forma mais simples seria mesmo bgp-cgnat-concentrador , e ai sim vc faria rota do bgp pra cgnat e do cgnat para concentrador, para usar os ips públicos.



  7. #7

    Padrão Re: Roteamento cgnat

    Citação Postado originalmente por Fcnetwork Ver Post
    Eu colocaria um suite gerenciável para fazer vlans na saida do bgp e ligaria cgnat e concentrador no suite.
    Outra forma mais simples seria mesmo bgp-cgnat-concentrador , e ai sim vc faria rota do bgp pra cgnat e do cgnat para concentrador, para usar os ips públicos.
    entendi, tenho as duas possibilidades de fazer.. no caso, queria passar o bloco do IP fixo direto para o concentrador, sem passar tráfego dentro do cgnat.

  8. #8

    Padrão Re: Roteamento cgnat

    Liga um cabo do cgnat ao concentrado aí neste caso vc teria uma rota para cgnat e uma para IP público.
    Quem for do IP público vai direto ao bgp e quem for cgnat passa pelo cgnat e depois ao bgp.
    Faz o teste e nos conta.



  9. #9

    Padrão

    Citação Postado originalmente por deson00 Ver Post
    Liga um cabo do cgnat ao concentrado aí neste caso vc teria uma rota para cgnat e uma para IP público.
    Quem for do IP público vai direto ao bgp e quem for cgnat passa pelo cgnat e depois ao bgp.
    Faz o teste e nos conta.
    Boa tarde, fiz da seguinte maneira, uma conexão direta com BGP e uma conexão com o cgnat, porém apontei a rota default para o gateway do cgnat, da seguinte maneira: CGNAT 10.0.127.1/30 -> CONCENTRADOR 10.0.127.2/30 rota default 10.0.127.1.
    Já a conexão entre BGP e Concentrador ficou dessa maneira, ex.: BGP 10.0.128.1/30 -> Concentrador 10.0.128.2/30 porém não fiz rota default.

    Clique na imagem para uma versão maior

Nome:	         Rede 2020 - Modificação.png
Visualizações:	6
Tamanho: 	15,9 KB
ID:      	69969

  10. #10

    Padrão Re: Roteamento cgnat

    Boa noite. Não consegui ainda obter o que precisava.



  11. #11

    Padrão Re: Roteamento cgnat

    Quantidade de IPs públicos é grande o suficiente para justificar criar um novo enlace só para eles? Pelo menos aqui é tão pequeno que não justifica eu criar rotas separadas, na caixa cgnat deixo passar direto sem fazer nat os IPs públicos.

    Conheço gente que tem uma proporção grande de IPs publicos alocados, aí realmente faz toda a diferença. Mas como os novos blocos são pequenos, em geral a proporção também é baixa.