+ Responder ao Tópico



  1. #1

    Padrão Load Balance Link Dedicado e dhcp

    Fala galera!

    Estou precisando de ajuda, tentei seguir alguns vídeos como o do Wissam, porém sem sucesso.
    Estou fazendo um balance de um link dedicado de 200/200mb com um link dhcp de 500/150mb, segui o vídeo certinho, porém fiquei um pouco confuso na hora de calcular as marcações, pois ele não tem nenhum exemplo com dois link assimétricos, porém até ai tudo certo, eu fiz as marcações 3 pra 1. Porém o balance não funciona, não usa os dois links ao mesmo tempo, apenas o que estiver com rota setada mais perto, estou quebrando a cabeça já faz alguns dias.

    Não sei qual informações mandar para me ajudarem!

    Alguém poderia me dar um caminho para seguir?

  2. #2

    Padrão Re: Load Balance Link Dedicado e dhcp

    Posta as regras aí, e também se existe alguma rota default. Mas já adianto 3x1 não vai ficar bom.. você vai ter que arrumar um divisor para os dois links. Eu faria em 50mb.



  3. #3

    Padrão

    Então o melhor seria 5x1? 7x1?

    Mangle:

    Código :
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Bancos (Sites Seguros)" \
        dst-port=443 new-routing-mark=Bancos passthrough=no protocol=tcp
    add action=mark-connection chain=prerouting comment="ENTRADA CONEXAO LINK 1" \
        connection-mark=no-mark in-interface=LINK_RES new-connection-mark=\
        Link1-Conexao passthrough=yes
    add action=mark-connection chain=prerouting comment="ENTRADA CONEXAO LINK 2" \
        connection-mark=no-mark in-interface=ether2 new-connection-mark=\
        Link2-Conexao passthrough=yes
    add action=mark-routing chain=output comment="SAIDA CONEXAO LINK 1" \
        connection-mark=Link1-Conexao new-routing-mark=Link1-Rota passthrough=yes
    add action=mark-routing chain=output comment="SAIDA CONEXAO LINK 2" \
        connection-mark=Link2-Conexao new-routing-mark=Link2-Rota passthrough=yes
    add action=mark-connection chain=prerouting dst-address-type=!local \
        new-connection-mark=Link1-Conexao passthrough=yes \
        per-connection-classifier=both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting dst-address-type=!local \
        new-connection-mark=Link1-Conexao passthrough=yes \
        per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting dst-address-type=!local \
        new-connection-mark=Link2-Conexao passthrough=yes \
        per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-routing chain=prerouting connection-mark=Link1-Conexao \
        new-routing-mark=Link1-Rota passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=Link2-Conexao \
        new-routing-mark=Link2-Rota passthrough=yes

    Route:
    Código :
    add check-gateway=ping distance=1 gateway=1x7.xxx.1x4.xx routing-mark=\
        Link1-Rota
    add check-gateway=ping distance=2 gateway=192.168.0.1 routing-mark=Link2-Rota
    add check-gateway=ping distance=1 gateway=1x7.xx.1x4.xx
    add check-gateway=ping distance=2 gateway=192.168.0.1

  4. #4

    Padrão Re: Load Balance Link Dedicado e dhcp

    vc quer um programa para vc fazer...ja vem com manual..



  5. #5

    Padrão Re: Load Balance Link Dedicado e dhcp

    Citação Postado originalmente por wondernetwork Ver Post
    vc quer um programa para vc fazer...ja vem com manual..
    Não, apenas quero saber onde foi o meu erro!