+ Responder ao Tópico



  1. #1

    Lightbulb Problema rede FTTH

    Boa noite.

    Recentemente peguei um caso em uma rede FTTH, aonde o cliente está com PPPoE conectado, dá pra acessar a ONU normalmente remoto, e fazer diagnostico de ping, porém o mesmo não consegue navegar, ao reiniciar a ONU (fiberhome), o mesmo volta a ter conexão. Cheguei achar que poderia ser um problema de DNS, aonde uso o BIND9 com Debian9, mas setei o do Google, e mesmo assim não existe navegação, porém algo curioso acontece, se você pinga um endereço, o mesmo responde, mas não acessa.

    Resumo da topologia da rede

    Clique na imagem para uma versão maior

Nome:	         Untitled Diagram.png
Visualizações:	25
Tamanho: 	21,6 KB
ID:      	70117

    1. CGNAT, equipamento CCR1036-8G-2S+. Configuração NETMAP 1:32, fasttrack desativo. IP válidos, todos em loopback.
    2. Server PPPoE, equipamento CCR1036-8G-2S+. Configuração, uma vlan para cada PON do fiberhome. Tracking desativo. Max MTU e MRU 1496, já testei com 1980 também e o problema persiste.
    3. ONU, modelo AN5506-02-B, modo router e modo bridge, ambos apresenta mesmo problema. Já usei tanto do modelo branco, quanto do preto. Hardware B7G. Já testei as versões RP2603, 2604 e 2610. Eu deixo apenas a porta 1 liberada, a porta 2 sempre deixo desativa para um futuro projeto de TV. A ONU é comprada na flytec e na casa da internet, ambas o mesmo problema.

    Outro detalhe é que não é possível navegar nem via IPv4 nem via IPv6.

    Configurações servidor PPPoE

    Clique na imagem para uma versão maior

Nome:	         1.PNG
Visualizações:	22
Tamanho: 	12,6 KB
ID:      	70118

    Configuração profile

    Clique na imagem para uma versão maior

Nome:	         2.PNG
Visualizações:	27
Tamanho: 	19,9 KB
ID:      	70119Clique na imagem para uma versão maior

Nome:	         3.PNG
Visualizações:	24
Tamanho: 	10,1 KB
ID:      	70120

    IP do Local Address do profile, estou usando o IP de loopback do server.

    Em relação aos clientes, tem caso que o cliente tá com -19 até uns -25 de sinal, outro detalhe é que existe alguns cliente com sinal fora de padrão, acima de -25 na PON, aonde ocorre o problema.

    Em um suporte foi realizado, como disse anteriormente, a troca do DNS direto no computador, o mesmo estava conectado direto na ONU. Tanto com o DNS do Google, quanto com o local, o ping responde, porém o site solicitado não funciona.
    Clique na imagem para uma versão maior

Nome:	         6.jpeg
Visualizações:	31
Tamanho: 	93,1 KB
ID:      	70121 Clique na imagem para uma versão maior

Nome:	         7.jpeg
Visualizações:	26
Tamanho: 	107,8 KB
ID:      	70122
    Teste realizado no local.

    O navegador acusa o erro: ERR_EMPTY_RESPONSE.

    Alguém já passou pelo mesmo?

    Obrigado desde já caros colegas.

  2. #2

    Padrão Re: Problema rede FTTH

    Bom dia.
    Tudo indica que não seja problema na rede ftth ou onu.
    Aparentemente seu problema está nas configurações de seus servers.
    Tem poucas informações, mas pelo relatado verifique as configurações do seu CGNAT ,rotas que entram e saem do seu bgp vindas de seus concentradores.Pode ser que tenha cliente pegando o mesmo IP nateado(repetindo ip) da faixa interna.



  3. #3

    Padrão

    Citação Postado originalmente por brunocemeru Ver Post
    Bom dia.
    Tudo indica que não seja problema na rede ftth ou onu.
    Aparentemente seu problema está nas configurações de seus servers.
    Tem poucas informações, mas pelo relatado verifique as configurações do seu CGNAT ,rotas que entram e saem do seu bgp vindas de seus concentradores.Pode ser que tenha cliente pegando o mesmo IP nateado(repetindo ip) da faixa interna.
    Bom dia Bruno.
    Eu faço tudo via rota estática para evitar "problemas", então no BGP eu envio um /24 para o CGNAT, e do CGNAT eu envio /19 para o BRAS. Também cheguei a achar que o cliente estava com IP duplicado, verifiquei e não constava como duplicado.
    Eu fiz a setei Change TCP MSS como yes, ativei no mangle o seguinte item.

    Código :
    /ip firewall mangle
    add action=change-mss chain=forward new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn

    Vou testar durante alguns dias para ver como vai se comportar.

  4. #4

    Padrão Re: Problema rede FTTH

    Então amigo.
    Aqui eu uso ospf,não foi eu quem configurei.Meu conhecimento em rede vai na casa do intermediário.Mas dou meus pitacos.
    Aqui quando instalamos o BGP e comecei a usar ips válidos tive alguns problemas de ip duplicado.
    Eu uso MK-auth como ERP e coloquei o pool no mk-auth,resultado.Quando o mk-auth perdia conexão com os BRAS o ips se repetiam,pois as referencias eram perdidas.
    Sempre usei ips fixos nos clientes,por isso perdi um tempinho.Mas consegui resolver pondo o pool direto no Mikrotik.
    Quando coloquei o CGNAT para rodar aqui deu um problema parecido.Não sei porque motivo o MK-auth permitiu que cliente com o mesmo ip fosse cadastrado,antes não dava problema,mas depois que coloquei o CGNAT todo ip nateado ia dentro do CGNAT fazendo conexão, o ip repetido deixava dava ping mas não navegava.Como já estava meio familiarizado com o problema consegui resolver rapidamente.
    Por isso acho que seu problema ai seja isso.Contudo,cada caso é um caso rs.



  5. #5

    Padrão Re: Problema rede FTTH

    Muda o MTU para 1452 no pppoe do roteador do cliente e testa.
    Tive um problema parecido com esse na minha rede como cliente FTTH, pingava em qualquer site mas não abria no navegador. Foi só mudar o MTU. Num computador conectado ao roteador que disca o pppoe abra um terminal e digite "ping [URL] [-f] [-l] [valor MTU]"
    Ex: ping www.uol.com.br -f -l 1462
    Ai vai testando até achar o maior valor sem perda de pacotes. Geralmente é 1452 quando tem PPPOE.
    Espero ter ajudado

  6. #6

    Padrão Re: Problema rede FTTH

    você disse que fez testes de ping etc, no caso você só fez os testes pela ONU ou fez em algum dispositivo da rede do cliente?, onu da fiberhome tem problemas de fazer proxy-dns, tente setar o dns (da sua preferencia) no dhcp dado pela ONU/roteador, para que o dispositivo pegue o ip de dns diretamente, ao invés de pegar o ip do roteador/onu como dns server. outra coisa, no cgnat, se você fizer por netmap, lembre-se de setar as portas de saída, pois netmap é para roteamento 1:1, então podem haver conflitos de uso de portas, caso não faça controle das portas, utilize o src-nat em action ao invés de netmap.



  7. #7

    Padrão

    Citação Postado originalmente por edsong Ver Post
    você disse que fez testes de ping etc, no caso você só fez os testes pela ONU ou fez em algum dispositivo da rede do cliente?, onu da fiberhome tem problemas de fazer proxy-dns, tente setar o dns (da sua preferencia) no dhcp dado pela ONU/roteador, para que o dispositivo pegue o ip de dns diretamente, ao invés de pegar o ip do roteador/onu como dns server. outra coisa, no cgnat, se você fizer por netmap, lembre-se de setar as portas de saída, pois netmap é para roteamento 1:1, então podem haver conflitos de uso de portas, caso não faça controle das portas, utilize o src-nat em action ao invés de netmap.
    Bom dia.

    O teste foi realizado sim em um dispositivo, saindo da fiberhome, o roteador do cliente sempre uso em bridge para repassar o IPv6. O teste foi realizado direto no nosso notebook aonde setamos o DNS direto na placa, teste com o do Google para tirar a dúvida.

    As configurações dentro da ONU
    Clique na imagem para uma versão maior

Nome:	         1.png
Visualizações:	18
Tamanho: 	52,9 KB
ID:      	70130Clique na imagem para uma versão maior

Nome:	         2.png
Visualizações:	18
Tamanho: 	67,9 KB
ID:      	70131Clique na imagem para uma versão maior

Nome:	         3.png
Visualizações:	16
Tamanho: 	81,6 KB
ID:      	70132Clique na imagem para uma versão maior

Nome:	         4.png
Visualizações:	16
Tamanho: 	44,6 KB
ID:      	70133

    O CGNAT é realizado fora da caixa do PPPoE e tem uma rota default dentro do BRAS para o CGNAT.

    Código :
    /ip firewall nat
    add action=jump chain=srcnat jump-target=CGNAT-0 src-address=100.127.0.0/24
    add action=jump chain=srcnat jump-target=CGNAT-1 src-address=100.127.1.0/24
    add action=jump chain=srcnat jump-target=CGNAT-2 src-address=100.127.2.0/24
    add action=jump chain=srcnat jump-target=CGNAT-3 src-address=100.127.3.0/24
    add action=jump chain=srcnat jump-target=CGNAT-4 src-address=100.127.4.0/24
    add action=jump chain=srcnat jump-target=CGNAT-5 src-address=100.127.5.0/24
    add action=jump chain=srcnat jump-target=CGNAT-6 src-address=100.127.6.0/24
    add action=jump chain=srcnat jump-target=CGNAT-7 src-address=100.127.7.0/24
    add action=jump chain=srcnat jump-target=CGNAT-8 src-address=100.127.8.0/24
    add action=jump chain=srcnat jump-target=CGNAT-9 src-address=100.127.9.0/24
    add action=jump chain=srcnat jump-target=CGNAT-10 src-address=100.127.10.0/24
    add action=jump chain=srcnat jump-target=CGNAT-11 src-address=100.127.11.0/24
    add action=jump chain=srcnat jump-target=CGNAT-12 src-address=100.127.12.0/24
    add action=jump chain=srcnat jump-target=CGNAT-13 src-address=100.127.13.0/24
    add action=jump chain=srcnat jump-target=CGNAT-14 src-address=100.127.14.0/24
    add action=jump chain=srcnat jump-target=CGNAT-15 src-address=100.127.15.0/24
    add action=jump chain=srcnat jump-target=CGNAT-16 src-address=100.127.16.0/24
    add action=jump chain=srcnat jump-target=CGNAT-17 src-address=100.127.17.0/24
    add action=jump chain=srcnat jump-target=CGNAT-18 src-address=100.127.18.0/24
    add action=jump chain=srcnat jump-target=CGNAT-19 src-address=100.127.19.0/24
    add action=jump chain=srcnat jump-target=CGNAT-20 src-address=100.127.20.0/24
    add action=jump chain=srcnat jump-target=CGNAT-21 src-address=100.127.21.0/24
    add action=jump chain=srcnat jump-target=CGNAT-22 src-address=100.127.22.0/24
    add action=jump chain=srcnat jump-target=CGNAT-23 src-address=100.127.23.0/24
    add action=jump chain=srcnat jump-target=CGNAT-24 src-address=100.127.24.0/24
    add action=jump chain=srcnat jump-target=CGNAT-25 src-address=100.127.25.0/24
    add action=jump chain=srcnat jump-target=CGNAT-26 src-address=100.127.26.0/24
    add action=jump chain=srcnat jump-target=CGNAT-27 src-address=100.127.27.0/24
    add action=jump chain=srcnat jump-target=CGNAT-28 src-address=100.127.28.0/24
    add action=jump chain=srcnat jump-target=CGNAT-29 src-address=100.127.29.0/24
    add action=jump chain=srcnat jump-target=CGNAT-30 src-address=100.127.30.0/24
    add action=jump chain=srcnat jump-target=CGNAT-31 src-address=100.127.31.0/24
    add action=netmap chain=CGNAT-0 out-interface=vlan127 protocol=tcp src-address=100.127.0.0/24 to-addresses=45.238.x.0/24 to-ports=1025-3041
    add action=netmap chain=CGNAT-0 out-interface=vlan127 protocol=udp src-address=100.127.0.0/24 to-addresses=45.238.x.0/24 to-ports=1025-3041
    add action=netmap chain=CGNAT-0 out-interface=vlan127 src-address=100.127.0.0/24 to-addresses=45.238.x.0/24

    Encurtei o export do CGNAT.

    Um detalhe que havia me esquecido, à navegação via IPv6 também não dá acesso, somente ping.
    Sobre o relato de duplicidade de IP, no meu caso não está ocorrendo.

  8. #8

    Padrão Re: Problema rede FTTH

    Citação Postado originalmente por leandrovaranda Ver Post
    Muda o MTU para 1452 no pppoe do roteador do cliente e testa.
    Tive um problema parecido com esse na minha rede como cliente FTTH, pingava em qualquer site mas não abria no navegador. Foi só mudar o MTU. Num computador conectado ao roteador que disca o pppoe abra um terminal e digite "ping [URL] [-f] [-l] [valor MTU]"
    Ex: ping www.uol.com.br -f -l 1462
    Ai vai testando até achar o maior valor sem perda de pacotes. Geralmente é 1452 quando tem PPPOE.
    Espero ter ajudado
    Questão de ping é relativo....... se por exemplo seu mikrotik tiver setado no L2 1580... vc pode setar seu PPPOE servidor com MTU1500 tranquilo.. e setar os roteadores ou ONU dos clientes com MTU 1492 de boa.. que com 1580 L2 disponivel pode setar VLAN, OSPF e muito mais em cima da interface...até mesmo em roteadores que aceitem MTU 1500 dá pra setar.. porém são pouquissimos maior partes das marcas o limite é 1492 os mais antigos 1472