+ Responder ao Tópico



  1. #1

    Unhappy Oi Fibra + IPTV - Mikrotik como roteador

    Recentemente recebi um novo link de internet residencial da Oi, chamado Oi Fibra, que é um link FTTH normal, porém usa um modem próprio que roda sobre ele duas VLAN´s, uma para internet outra para IPTV. Mas não quero usar o modem da Oi como roteador principal, usei uma RB hAP Lite para testes como roteador principal e não consigo fazer com que os dispositivos IPTV funcionem sob o DHCP do Mikrotik. Usei o script básico da RB, à partir de um reset, liberei as entradas para IGPM e UDP na porta ether1 (WAN com dhcp-client ligado no modem Oi), removi todas as regras de firewall e nada ...


    Só consegui fazê-lo funcionar com uma bridge simples interligando todas as portas físicas e colocando o dhcp-client na bridge, como na imagem abaixo.
    Clique na imagem para uma versão maior

Nome:	         WhatsApp Image 2021-05-04 at 16.23.05.jpeg
Visualizações:	22
Tamanho: 	81,8 KB
ID:      	70396
    Queria porém, não utilizar o endereçamento IP do modem Oi, muito menos ele como roteador principal da minha rede.

  2. #2

    Padrão Re: Oi Fibra + IPTV - Mikrotik como roteador

    Pelo pouco que conheço o padrão ftth como um todo tem controle mais rígido com relação a alterações e liberações nos roteadores.
    Não tenho de ideia do padrão usado hoje na Oi fibra ,porém acredito que seja um pouco complicado de efetuar alterações no roteador sem de alguma forma prejudicar sua navegação.



  3. #3
    Avatar de Nilton Nakao
    Ingresso
    Sep 2013
    Localização
    Carlos Chagas, Minas Gerais
    Posts
    1.285

    Padrão Re: Oi Fibra + IPTV - Mikrotik como roteador

    Grandes provedores sempre fornecem seu modem próprio e muitas vezes sem acesso pelo usuário, por isso ao assinar o contrato o modem é gratuito.
    Pequenos e micro provedores já sofrem com isso, o cliente compra o modem o provedor libera autenticação mas o cliente assiste a um you tube e faz um reset e pronto sem internet de vez; migra para o médio ou grande e posteriormente cobrando por cada visita técnica.
    Aqui com planos a partir do plano controle da rede de celular( 1 MB ou 2 MB) ou R$ 55,00, é raro não ter uma casa sem internet e os que não tem acha vantajoso "roubar" do vizinho mesmo com sinal fraco e ainda paga. Nesta região ainda vai demorar para termos IPTV liberado 100%, assistimos sim mas baseado como capital e não como cidade em questão.

  4. #4

    Padrão

    Obrigado pela atenção, mas lendo meu texto novamente, vi que me expressei mal. O que eu gostaria e de "transpassar" o modem Oi pelo Mikrotik de maneira que eu use o Routerboard como roteador e não como switch.

    Clique na imagem para uma versão maior

Nome:	         oi_iptv.png
Visualizações:	17
Tamanho: 	44,0 KB
ID:      	70397
    Última edição por wilpeterson; 05-05-2021 às 13:09. Razão: acréscimo de imagem



  5. #5
    Avatar de andersonfire
    Ingresso
    Mar 2011
    Localização
    Rio Grande do Sul-Alvorada(cidade sem lei)
    Posts
    299

    Padrão

    Clique na imagem para uma versão maior

Nome:	         01.png
Visualizações:	10
Tamanho: 	91,3 KB
ID:      	70403

    Oi sabe qual a VLAN a Oi usa na sua regia para Voip?

  6. #6



  7. #7

    Padrão

    Bom dia, eu consegui fazer funcionar, de maneira muito satisfatória, dois pontos de IPTV da Oi usando o modem que me foi fornecido pela empresa Oi apenas como um roteador de entrada, usando o script de desbloqueio HTML fui nas configurações do modem Oi Fibra e desabilitei o IPV6 e as opções de Wi-FI, mas deixei o IP padrão desse modelo Nokia que é 192.168.1.254. Usei uma RB 750GL (Gigabit) para testes, abaixo o script das configurações, que estão basicamente no padrão de "reset" deste modelo.

    As modificações importantes para o funcionamento são a instalação do pacote "multicast", que é encontrado no repositório de pacotes do site https://www.mikrotik.com/downloads, que dever ser instalado de acordo com a versão do routerboard, na Bridge (ponte) habilitar a função de "Igmp snooping", no Firewall liberar o tráfego IGPM e UDP nas interfaces e configurar as rotas do IGPM Proxy, onde efetivamente ocorre a transição entre os pacotes da IPTV.

    Meu próximo desafio, assim que possível, é tentar habilitar estas funções de forma funcional num estrutura com Load Balance PCC.

    # may/13/2021 09:25:41 by RouterOS 6.48.2
    # software id =
    #
    # model = 750GL
    # serial number =
    /interface bridge
    add admin-mac=D4:CA:6D:90:50:0A auto-mac=no comment=defconf igmp-snooping=yes name=bridge
    /interface ethernet
    set [ find default-name=ether1 ] comment="Link Oi"
    set [ find default-name=ether2 ] comment="LAN | Rede Interna"
    /interface list
    add comment=defconf name=WAN
    add comment=defconf name=LAN
    /ip pool
    add name=default-dhcp ranges=192.168.88.10-192.168.88.254
    /ip dhcp-server
    add address-pool=default-dhcp disabled=no interface=bridge name=defconf
    /interface bridge port
    add bridge=bridge comment=defconf interface=ether2
    add bridge=bridge comment=defconf interface=ether3
    add bridge=bridge comment=defconf interface=ether4
    add bridge=bridge comment=defconf interface=ether5
    /ip neighbor discovery-settings
    set discover-interface-list=LAN
    /interface list member
    add comment=defconf interface=bridge list=LAN
    add comment=defconf interface=ether1 list=WAN
    /ip address
    add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
    /ip dhcp-client
    add add-default-route=yes use-peer-dns=yes use-peer-ntp=yes comment=defconf disabled=no interface=ether1
    /ip dhcp-server network
    add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
    /ip dns
    set allow-remote-requests=yes
    /ip dns static
    add address=192.168.88.1 comment=defconf name=router.lan
    /ip firewall filter
    add action=accept chain=forward protocol=udp
    add action=accept chain=input protocol=udp
    add action=accept chain=input protocol=igmp
    add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
    add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
    add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
    add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
    add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
    add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
    add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
    add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
    add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
    add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
    /ip firewall nat
    add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
    /ip firewall service-port
    set ftp disabled=yes
    set tftp disabled=yes
    set irc disabled=yes
    set h323 disabled=yes
    set pptp disabled=yes
    set udplite disabled=yes
    set dccp disabled=yes
    set sctp disabled=yes
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set www disabled=yes
    set ssh disabled=yes
    set api port=8888
    set api-ssl disabled=yes
    /routing igmp-proxy
    set quick-leave=yes
    /routing igmp-proxy interface
    add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
    add interface=bridge
    /system clock
    set time-zone-name=America/São Paulo
    /system identity
    set name=MikroTik-IPTV
    /tool mac-server
    set allowed-interface-list=LAN
    /tool mac-server mac-winbox
    set allowed-interface-list=LAN