+ Responder ao Tópico



  1. #1
    Visitante

    Padrão ncsa_auth Squid

    Olá Pessoal,

    Estou com problemas na autenticação de usuarios utilizando o programa de autenticação "ncsa_auth".

    Qdo eu digito usuario/senha no navegador do cliente, nao aceita, segui todos os passos corretamente na configuração do squid.conf mas nao sei o q está acontecendo.
    A versao do Squid instalada eh 2.4.STABLE7 (RedHat 8.0).

    obs.: sem as regras de autenticação, os cliente acessam o Squid sem problemas.

    Se alguem puder me ajudar eu agradeço,
    Valew, Elvis
    Segue abaixo configuração do Squid:

    http_port 3128
    cache_mem 32 MB

    authenticate_program /usr/bin/ncsa_auth /web/squid.pw

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Conf_ports port 901 98

    acl CONNECT method CONNECT
    acl acesso proxy_auth REQUIRED
    acl minharede src 192.168.1.0/24

    http_access allow manager localhost
    http_access deny manager

    http_access allow localhost
    http_access allow minharede acesso
    http_access deny all

  2. #2
    paulogrifo
    Visitante

    Padrão ncsa_auth Squid

    ((
    Ficou faltando informar se vc cadastrou os usuários pelo htpasswd

    # htpasswd -c /web/squid.pw usuario1

    Aparentemente seu script está correto!




  3. #3
    Visitante

    Padrão ncsa_auth Squid

    Olá Paulo,

    Sim, ja havia cadastrado os usuarios com o htpasswd e em seguida verifiquei digitando na linha de comando:

    /usr/bin/ncsa_auth /web/squid.pw
    [Username] [Password]

    Fazendo este teste ele me reporta "OK"

    Realmente nao sei mais o q fazer... to pensando em tirar o RedHat 8 daki e instalar o Mandrake.

    Mas de qualquer forma, Obrigado pela ajuda,
    Valew,
    Elvis

  4. #4
    Visitante

    Padrão ncsa_auth Squid

    Olá Paulo,
    Olha eu aki di novo <IMG SRC="images/forum/smilies/icon_smile.gif">

    Kra... testei a mesma configuração do Squid no Mandrake 9 e funcionou blz !!!

    Realmente naum sei o q eh q faltou no RedHat 8, pois a autenticação naum funciona nem a PAU!!!
    Se vc descobrir qual o problema do Squid no RedHat me da um toque Please!!

    o meu e-mail eh: <a href="mailto:[email protected]">[email protected]</a>

    Valew
    Obrigado,
    Elvis



  5. #5

    Padrão ncsa_auth Squid

    Faltou essa linha:

    http_access allow acesso

  6. #6
    Visitante

    Padrão ncsa_auth Squid

    Fala ae Ice,

    eh o seguinte kra, naum funcionou o script q vc me enviou <IMG SRC="images/forum/smilies/icon_frown.gif">

    funciona tudo no script, bloqueio de portas, paginas e etc e tal... mas a autenticação naum funciona de jeito nenhum !!! soh funciona no Mandrake que eu testei.

    kra realmente naum sei qual o problema com essa versao do Red Hat 8.0... vou esperar e ver se pinta mais alguem com este mesmo problema nesta versao 8.

    De qualquer forma, valew a ajuda
    Obrigado,
    Elvis



  7. #7

    Padrão ncsa_auth Squid

    Eh realmente não entendo oq acontece... mas foi bom saber que num ta funcionando legal, pq eu ia atualizar todos os meus 7.3 pra 8.... e eu ia ter uma dor de cabeça que vc num imagina se o squid num rodasse....

  8. #8
    Squid-Newbie
    Visitante

    Padrão ncsa_auth Squid

    Aproveitando esta pergunta, se eu apenas copiar o arquivo de senhas para um novo servidor o squid reconhecerá ?

    tipo assim eu instalei um novo server e para nao cadastra todos os usuarios novamente eu copiei o antigo arquivo que fiz com o httpaswd, vai ter algum problema ?

    obrigado