+ Responder ao Tópico



  1. #1
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    Instalei o samba 2.2.6, peguei minha configuração do 2.2.0 e funciona, o smb.conf

    é bem simples, apenas quero compartilhar uma pasta..
    mas quando eu rosto o nmbd roda e smbd da erro.. o log é esse

    [2002/10/31 10:01:16, 0] lib/util_sock.cpen_socket_in(804)
    bind failed on port 139 socket_addr = 0.0.0.0.
    Error = Address already in use


    Obrigado

  2. #2
    Mr_Mind
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    vc ja tem um serviço correndo nessa porta!!!
    podera´ ser o samba antigo, ou o smbd arrancou sem vc saber! corra um nmap no servidor e verifique que tem a porta aberta.

    <IMG SRC="images/forum/smilies/icon_biggrin.gif">



  3. #3
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    NetBios tava rodando na 139
    eu tinha descomentado essa linha no inetd.conf

    quando eu utilizava o slack 7.1 com o samba 2.2.2 eu era obrigado a descomentar essa linha

    agora com o slack 8.1 e samba 2.2.26 nem prcisa
    esta rodando normal

    valeu ae

  4. #4
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    rode o testparm e verifique em qual diretorio ele busca o smb.conf, mova oseu smb.conf para lá eu acho que a versão 2.2.6 usa o smb.conf em outro diretorio



  5. #5

    Padrão NMBD funciona, SMBD nao :(

    Cara da uma olhada na variavel bind interfaces do seu smb.conf.... tem q estar com o IP da sua rede IP/MASCARA

  6. #6
    glasswalk3r
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    vc pode simplesmente não ter removido direito sua instalação anterior... vc provavelmente instalou o tar.gz do 2.2.6 direto na máquina, e talvez tenha ficado um daemon...

    vc roda o samba pelo inetd? raramente isso é necessário, e vc perde performance.



  7. #7
    slyz
    Visitante

    Padrão NMBD funciona, SMBD nao :(

    Voce deve estar com um daemon antigo rodando.

    ps ax | grep smbd
    killall -9 smbd ou service samba stop