Outra situação em que tive algum trabalho.....

Cliente A -----> Servidor A ----|INTERNET|---> IPTABLES ----> TSERVER

obs: Comandos do IPCHAINS nao funcionam no IPTABLES como postado anteiromente

Supondo que o IPTables esteja funcionando perfeitamente


$IPT -> /sbin/iptables
$NET_IF -> Interface de rede ligada a Internet
$LAN_IF -> Interface de rede ligada a rede interna
$NET_IP -> IP da interface ligada a Internet
$REMOTE_IP -> Maquina remota de onde eh iniciada a conexao
$LOCAL_IP -> Maquina interna a que se pretende se ligar

o unico acrescimo que ira precisar no script de configuração do IPTables sera o seguinte...

# NAT para dentro da rede
$IPT -A PREROUTING -t nat -p TCP -i $NET_IF -d $NET_IP --dport 3389 -j DNAT --to-destination $LOCAL_IP

# Regra para a entrada
$IPT -A FORWARD -p TCP -i $NET_IF -s $REMOTE_IP -o $LAN_IF -d $LOCAL_IP --dport 3389 -j ACCEPT

tomar cuidado com o IP da maquina de onde eh iniciada a conexao [Cliente A] (verifique se nao faz NAT)
se fizer por o IP do gateway [Servidor A] no $REMOTE_IP.

tive alguns problemas quanto a conexão ao terminal Server e a maneira que ele tratava os pacotes
fragmentados (quem sabe o que eh o BLACK HOLE!!??), provenientes do IPTABLES, num universo de 10
terminais server ele se conectava perfeitamente com tres deles, e tinha erro nos restantes, depois
de alguma pesquisa e algum trabalho de debugging (via TCPDUMP), constatei que os servidores tinham
respostas diferentes (windows 2000 server/ WIndows XP) <IMG SRC="images/forum/icons/icon_frown.gif"> WINDOWZ.

Na verdade os servidores TServer descartavam todos os pacotes fragmentados..... mais umas pesquisas
e encontrei o patch para o registry...(em anexo)


--begin of file win2000--
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnablePMTUBHDetect"=dword:00000001
--end of file win2000--

apos incluir essa chave no registry todos funcionaram perfeitamente.....
por isso, pode estar sofrendo de problemas que nao necessariamente sao do LINUX

espero ter ajudado.....
Marcelo Correa