Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Ganymede
    Já tentei de tudo e não consigo redirecionar uma porta do meu firewall para uma máquina interna. No final a conexão acaba caindo no próprio firewall. Nem do jeito mais simples funciona: deixei todas as políticas em ACCEPT e apliquei a regra:

    iptables -t nat -A PREROUTING -d $IP_EXTERNO -p TCP --dport http -j DNAT --to 192.168.0.10

    Se eu dou um telnet no ip externo a conexão é recusada(eu tô fazendo isso no próprio firewall... Algum problema nisso?)

    Mudei a porta pra uma que está em listen no firewall, e vi que a conexão está sendo direcionada a ele...

    Alguém pode me ajudar?

  2. #2
    De uma olhada, parece que vc está destinando tudo na porta http do seu firewall DNAT 192......

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2003-01-17 14:52, Ganymede wrote:
    Já tentei de tudo e não consigo redirecionar uma porta do meu firewall para uma máquina interna. No final a conexão acaba caindo no próprio firewall. Nem do jeito mais simples funciona: deixei todas as políticas em ACCEPT e apliquei a regra:

    iptables -t nat -A PREROUTING -d $IP_EXTERNO -p TCP --dport http -j DNAT --to 192.168.0.10

    Se eu dou um telnet no ip externo a conexão é recusada(eu tô fazendo isso no próprio firewall... Algum problema nisso?)

    Mudei a porta pra uma que está em listen no firewall, e vi que a conexão está sendo direcionada a ele...

    Alguém pode me ajudar?

    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE> <IMG SRC="images/forum/icons/icon_confused.gif">



  3. defina o --dport com o numero da porta q eh mais confiavel e naum com o nome do serviço

  4. #4
    Ganymede
    Mais dados:

    IP do meu firewall : 192.168.0.206 (na intranet)
    200.xxx.x.xxx (ip válido)
    IP da máquina com servidor web: 192.168.0.10

    Segue o script que eu tô usando (Só coloquei o ip externo como 200.xxx.xxx.xxx por segurança. Aqui está preenchido de forma correta. Já tentei também com -i eth1 ao invés de -d 200.xxx.xxx.xxx)

    #!/bin/sh

    # vars
    QUINTUM=192.168.0.10
    ME_NET=200.xxx.xxx.xxx
    ME_LAN=192.168.0.206

    iptables -F
    iptables -t nat -F
    iptables -t mangle -F
    iptables -X
    iptables -t nat -X
    iptables -t mangle -X
    iptables -Z
    iptables -t nat -Z
    iptables -t mangle -Z

    echo 1 > /proc/sys/net/ipv4/ip_forward

    iptables -P FORWARD ACCEPT
    iptables -P OUTPUT ACCEPT
    iptables -P INPUT ACCEPT

    iptables -t nat -A PREROUTING -s $ME_NET -p TCP --dport 80 -j DNAT --to $QUINTUM

    # Masquing outgoing and allowing
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE



  5. me parecem estar certas as regras.....

    o ip_forward ta ativo??






Tópicos Similares

  1. Nao consigo fazer Airgrid m5 falar com nano louco
    Por lenimax no fórum Servidores de Rede
    Respostas: 4
    Último Post: 01-02-2014, 07:51
  2. Redirecionamento com iptables, nao estou conseguindo
    Por djhulk no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-04-2006, 16:49
  3. Nao consigo fazer redirecionamento
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2003, 16:15
  4. Não consigo fazer login
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 11-12-2002, 09:09
  5. Não Consigo fazer login
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 10-12-2002, 14:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L