+ Responder ao Tópico



  1. #1

    Padrão Erro 2013 ao conectar-se remotamente.

    Ola...

    Instalei o Red Hat 8.0 com Mysql e inicializei o serviço normalmente...

    Acessei o mesmo pelo server, criei uma database e suas tabelas normalmente... posteriormente criei um usuario com os previlégios para acessar a mesma (como sempre fiz no Red Hat 7.2 e Coinectiva 7.0), só que quando tento conectar-me remotamente pelo Mysql-Front ela dá o seguinte erro:

    ERROR 2013: Lost connection to MySQL server during query

    Já revisei e está tudo correto? Qual a solução?

    Atenciosamente

    [];
    <IMG SRC="images/forum/icons/icon_frown.gif">

  2. #2

    Padrão Erro 2013 ao conectar-se remotamente.

    A query que está executando, ela funciona corretamente local ?
    Qual o tempo de resposta ? Pode estar saindo por timeout ?
    A conecção entre os computadores é de boa qualidade ? (Aqui na empresa a rede é ruim e perde-se a conecção constantemente...)



  3. #3

    Padrão Erro 2013 ao conectar-se remotamente.

    Não, realmente não é problema de rede...

    Também fiz o seguinte teste, criei um pagina em php no server fazendo uma consulta no databases que criei e tambem da o mesmo erro...

    trabalho um bocado com o MySql em outras distribuições e até mesmo versões anteriores do Red Hat e isso nunca me ocorreu...

    Ajudem por favor...

    T+

  4. #4

    Padrão Erro 2013 ao conectar-se remotamente.

    Tenho certeza que é com relacao a algum previlegio...

    A sintaxe que usei (é a mesma que sempre uso em outras versoes e sempre deu certo) é essa:

    mysql> grant all on database.* to usuario identified by &acute;senha&acute; with grant option;

    Cria normalmente o usuario, (ja verifiquei no databases do mysql) so que naum me da permissao...

    ???? Help ????



  5. #5

    Padrão Erro 2013 ao conectar-se remotamente.

    O problema certamente não é de permissão, pois o erro é claro, perda de conecção.
    Não conheço o suficiente de MySQL para te ajudar mais a fundo, mas primeiro de tudo veja o número de usuários conectados, quantidade de memória, espaço em disco.
    Você tem outras aplicações com o MySQL rodando na mesma máquina ? Alguma deu problema ?

  6. #6

    Padrão Erro 2013 ao conectar-se remotamente.

    Não, naum tem nada rodando ainda neste server... Preciso fazer com que isto funcione para botar em uso)

    Conectei diretamente pelo prompt do server, nomermalmente

    # mysql -u usuario -p

    pede a senha, digito-a, logo normalmente, vejo os databases e as tabelas a qual tenho acesso com este usuario... blz

    SÓ, que quando rodo uma aplicaçao tambem diretamente no servidor (sem uso algum de rede) com o mesmo usuario ele da a seguinte mensagem:

    Lost connection to MySQL server during query

    ... dá para entender... e no log (tail -f /var/log/mysql.log) naum registra o erro...


    Atenciosamente...



  7. #7

    Padrão Erro 2013 ao conectar-se remotamente.

    Bom... se não há nenhum erro no log do MySQL, é por que a conecção com o mesmo não foi efetuada, portanto podemos descartar problemas com o banco...
    Você está usando qual versão do PHP ? E qual o WebServer ?
    Quando você compilou o PHP você indicou que ele usaria o MySQL ?
    Para mim, o problema está na comunicação do PHP com o MySQL.
    <IMG SRC="images/forum/icons/icon_eek.gif">

  8. #8

    Padrão Erro 2013 ao conectar-se remotamente.

    Fiz uma instalação padrao do Red HAT 8.0 selecionando na mesma todos os modulos necessarios para o funcionamento...

    No memonto estou usando uma aplicacao em perl para o acesso...
    (so para exemplificar, nesta aplicadao, informo o host, nome de usario, senha e o database para a conexao com o Mysql, quando eu informo eses dados de um outro servidor que tenho com o Red Hat 7.2 beleza, imprime os dados normalemente, agora quando informo o Mysql local do meu server da a mensagem:
    Lost connection to MySQL server during query

    Ou seja, naum é problema da aplicacao, e sim alguma coisa no Mysql do servidor local onde esta aplicacao....

    Desde já agradeço o tempo que esta disponibilizando para torcarmos estas informaçoes... e se puder me ajudar continue postando...



  9. #9

    Padrão Erro 2013 ao conectar-se remotamente.

    Desculpe... eu me perdi...
    Você tem no servidor A o MySQL e o Perl, e quando você executa o Perl no servidor A lendo o banco no servidor A ele dá erro, mas quando você executa no servidor A lendo o banco do servidor B ele funciona ?
    Ou quando você executa o Perl do servidor B ele lê o MySQL do servidor A ?
    <IMG SRC="images/forum/icons/icon_confused.gif">

  10. #10

    Padrão Erro 2013 ao conectar-se remotamente.

    A primeira opçao... ou seja, servidor A o MySQL e o Perl, e quando você executa o Perl no servidor A lendo o banco no servidor A ele dá erro, mas quando você executa no servidor A lendo o banco do servidor B ele funciona



  11. #11

    Padrão Erro 2013 ao conectar-se remotamente.

    hummm... <IMG SRC="images/forum/icons/icon_frown.gif">
    creio que o problema está na forma de conecção.
    você está usando exatamente o mesmo script ? só alterando o IP do servidor destino ?
    tem algum detalhe que está faltando...

  12. #12

    Padrão Erro 2013 ao conectar-se remotamente.

    Ufffaaa...

    consegui conectar com o usuario localmente atraves de perl e php....

    Só que remotamente (Mysql-Front) ainda naum funfa... continua aqule erro 2013...

    Mas, já posso ir trabalhando... obrigado pelo seu tempo...