+ Responder ao Tópico



  1. #1
    Cyber_Punk
    Visitante

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    Quando tento adicionar a senha do usuario com o comando ./mysqladmin -u root -p password password ele retorna o seguinte erro

    ./mysqladmin: connect to server at ´localhost´ failed
    error: ´Access denied for user: ´[email protected]´ (Using password: YES)´

    Quando tento adicionar algum banco novo ele da o mesmo erro. ja tentei de tudo , removi e recompilei várias vezes , ele não me deixa fazer nada. Chequei os direitos sobre as pastas e está tudo ok.
    Estou utilizando o Red Hat 8 , to quase desistindo desse negocio.

    Se alguem puder me ajudar, retorne alguma coisa ae.

    T+


    undefined

  2. #2

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    você não pode executar nenhum comando de banco de dados com o usuário root.
    provavelmente já existe um usuário mysql (criado por default)
    dê o comando su - mysql e depois tente criar o banco... deve funcionar.
    <IMG SRC="images/forum/icons/icon_wink.gif">



  3. #3
    Kernel_Panic
    Visitante

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    Vc ja inicio o daemon do mysql ? ? ? <IMG SRC="images/forum/icons/icon24.gif">

    O que vc esta tentando instalar talves alguem ja tenha alguma experiencia . . ? ? ?

    O que vc ira integrar com mysql ? ? ?

  4. #4
    Cyber_Punk
    Visitante

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    Na verdade o que deve ter acontecido é que eu fiz uma (me desculpem o termo) uma puta cagada com o usuario mysql, pq eu entro com o comando su - mysql e ele pde uma senha que nao to acertando :/

    Acabei de apagar e recriar o usuario mysql do sistema , defini uma senha nova e atribui os direitos nescessários, ainda persiste o erro.

    O que eu to querendo é somente criar um banco de dados pro meu forum.
    Obs: o Daemon ta rodando corretamente aqui

    [ Esta mensagem foi editada por: Cyber_Punk em 22-07-2003 15:23 ]



  5. #5

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    quando você instalou, usou qual usuário ? o root ? é possível que o diretório que o banco esteja indisponível para o usuário mysql.
    quando eu instalei o PostgreSQL, tive que iniciar o processo pelo usuário postgres, e tive que dar permissão 777 no diretório onde ficaria o banco.
    <IMG SRC="images/forum/icons/icon_smile.gif">

  6. #6
    Cyber_Punk
    Visitante

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    Seguinte
    Atribui um 777 na pasta do mysql , parei o serviço e startei de novo mas nada. Quando eu instalei o estava com o usuario root sim, foi esse problema?



  7. #7

    Padrão Cansei dessa porqueira... alguem sabe como resolver?

    quando você faz a sequência ./configure ./make install e ./make você pode fazer com o usuário root. Quando você vai iniciar o banco, não pode ser com o usuário root e sim com um usuário próprio para o banco.
    <IMG SRC="images/forum/icons/icon_wink.gif">
    eu não instalei o MySQL, instalei o PostgreSQL, e não tive dificuldades.
    aqui no UnderLinux tem um tutorial para a instalação do MySQL.