+ Responder ao Tópico



  1. #1
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    Pessoal, ontem configurei servidor RH9..blz...isso no serviço
    consegui colocar estação windows2000 para autenticar no servidor..dhcp..
    tudo normal....

    porém hoje quando cheguei e liguei o servidor...depois a estação..da o seguinte erro: Existe um nome duplicado na rede..

    detalhe: depois de mexer em tudo..após algum tempo, voltou ao normal do nada...

    porém efetuei outro teste, desliguei o servidor e quando vou logar no windows2000...novamente o erro: EXISTE UM NOME DUPLICADO NA REDE..

    nome do servidor: radio02
    estação: cobaia..

    alguém tem uma idéia..

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Samba x Windows2000

    Bom amigo, tem um nome duplicado na rede, ou seja, 2 pcs com mesmo nome, só achar e mudar



  3. #3
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    Fernando, esse é o problema.
    Estou somente com 02 máquinas ponta-a-ponta...o servidor e uma estação conectados via cabo cross....

    detalhe: hoje cedo conectei outra estação usando um hub..
    ficou assim:
    servidor: radio02 - ip: 192.168.1.1
    estação: cobaia - ip via dhcp: 192.168.1.10
    estação: treina01- ip via dhcp: 192.168.1.8

    já vasculhei tudo..tando no RH9 com no 2000, mas não achei nada...
    Sempre fala que o nome ta duplicado na rede..

    + o que não entendo é que ontem funcionou blz...hoje cedo quando liguei o servidor e a estação cobaia começou dar esse erro...até ai so estava com esta estação em rede...COMO NOME DUPLICADO SE ESTOU COM O SERVIDOR E UMA ESTAÇÃO..

  4. #4

    Padrão Samba x Windows2000

    Altum deles está conectado na internet?
    Tente dar um ping com os nomes dos seus micros, sem que eles estejam ligados, algo do tipo:
    ping cobaia

    Sacou?



  5. #5
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    não pinga....
    consigo logar com usuário que cadastrei...+ logo com perfil em cache..
    consigo pingar www.radio02.lab.org que é meu DNS...

    sei que o problema estão no nome..+ no linux ja verifiquei tudo que é do meu conhecimento.

    qual o comando que dou no RH9 para ver máquinas que estão logadas..no servidor....

    e usuários cadastrados no samba..

    to pensando em zerar o server e começar tudo de novo..DNS..DHCP..APACHE..

  6. #6
    Visitante

    Padrão Samba x Windows2000

    Boa noite cara, blz ?

    Tive o mesmo problema com 2000, resolvi da seguinte forma:

    Loguei como administrador local no 2000, retirei da rede (domínio) e reiniciei o micro para pegar dhcp. Funcionou.
    Caso contrário, retire da rede, reinicie e coloque novamente no domínio com o ip estático q vc tem a disposição. Só lembrando, cheguei a ter esse problema com windows e linux na mesma máquina e também da forma cliente/servidor.

    ( )´s

    Beto



  7. #7
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    Pessoa, o problema ainda continua, deêm uma olhada no smb.conf, mesmo mudando nome da máquina win2000 fala que está em duplicidade na rede..isso depois depois de desligar e ligar o servidor..


    global]
    workgroup = linux
    server string = servidor
    hosts allow = all
    printcap name = /etc/printcap
    load printers = yes
    printing = cups
    guest account = nobody
    log file = /var/log/samba/%m.log
    null passwords = no
    max log size = 10
    security = user
    netbios name = linux
    ; password server = <NT-Server-Name>
    ; password level = 8
    ; username level = 8
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    ; ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    pam password change = yes
    ; username map = /etc/samba/smbusers
    ; include = /etc/samba/smb.conf.%m
    obey pam restrictions = yes
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    ; interfaces = 192.168.12.2/24 192.168.13.2/24
    ; remote browse sync = 192.168.3.25 192.168.5.255
    ; remote announce = 192.168.1.255 192.168.2.44
    local master = yes
    os level = 100
    domain master = yes
    preferred master = yes
    domain logons = yes
    logon script = exec.bat
    logon script = exec.bat
    logon path = \\%L\Profiles
    wins support = yes
    [homes]
    comment = Pastas dos Usuáos
    browseable = yes
    writable = yes
    valid users = %S
    create mode = 0664
    directory mode = 0775
    [netlogon]
    comment = Network Logon Service
    path = /usr/local/samba/lib/netlogon
    guest ok = yes
    writable = no
    share modes = yes
    [Profiles]
    path = /usr/local/samba/profiles
    browseable = no
    guest ok = yes
    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = yes
    writable = yes
    printable = yes
    [myshare]
    comment = Mary&acute;s and Fred&acute;s stuff
    path = /usr/somewhere/shared
    valid users = mary fred
    public = yes
    writable = yes
    printable = no
    create mask = 0765

    [wendel]
    copy = myshare


    [admins]
    comment = Grupo suporte
    path = /admins
    only guest = yes
    #valid users = mary
    #writable = yes
    printable = no
    #create mask = 0765
    write list = @suporte

  8. #8

    Padrão Samba x Windows2000

    Cara a principio seu samba parece esta ok , mas para tirar o peso da cabeca pega este arquivo smb.conf e compara com que no site do underlinux , depois tira o dhcp e deixa estacoes todas com IP estatico e e muda dominio muda tambem o nome das maquina a faixa de ip comeca do ZERO !! coloca os cabo comun e plug todo mundo no hub e faz o teste por etapas 1. samba(como dominio) 2. login dos cliente 3. DNS 4. DHCP por parte do inicio acho que assim pode resolver este problema



  9. #9
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    Pessoal, consegui descobrir o erro:
    se verificarem na configuração GLOBAL, netbios name = linux, comentei essa linha, agora tá blz..
    valeu ...

  10. #10

    Padrão Samba x Windows2000

    o problema eh que voce tinha 2 maquinas com o mesmo nome netbios e isso NAO PODE, eh o mesmo que tiver 2 ips ... o windows sempre perde nessas brigas.

    o SCO tambem leva ferro <IMG SRC="images/forum/icons/icon_smile.gif"> sem querer eu tirei um SCO do ar pq eu deixei 2 estacoes com o mesmo ip. (suckxs nao ter dhcp)

    lembre-se nao deixe 2 netbios iguais. verifique exatamente o nome netbios que voce deu, provavelmente uma estacao (ou servidor) tinha o mesmo nome do seu win2k.



  11. #11
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Samba x Windows2000

    Dalhe misty! uheuheuheuhe

  12. #12
    rfdasilva1
    Visitante

    Padrão Samba x Windows2000

    Isso mesmo Better Safe, más valeu...dessa forma aprendi um pouco +..já que sou novato...
    Valeu pela dica...