+ Responder ao Tópico



  1. #1
    marcelloduarte
    Visitante

    Padrão C compiler cannot create executables ???

    Caros Colegas,

    Todo arquivo fonte que vem em tar.gz, não consigo compilar aqui em uma maquina sempre é exibido esse erro:

    loading cache ./config.cache
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... missing
    checking for working autoconf... found
    checking for working automake... missing
    checking for working autoheader... missing
    checking for working makeinfo... missing
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking host system type... i686-pc-linux-gnu
    checking build system type... i686-pc-linux-gnu
    checking for ranlib... ranlib
    checking for gcc... gcc
    checking whether the C compiler (gcc ) works... no
    configure: error: installation or configuration problem: C compiler cannot create executables.

    Alguem sabe como posso solucionar esse problema. Arquivos rpm funcionam normalmente.

    Amd atlhon 1800+
    Conectiva Linux 9 - Kernel 2.4.21-28872cl

    Grato
    :roll:

  2. #2

    Padrão C compiler cannot create executables ???

    ta usando tar -xvzf nomedoarquivo.tar.gz?



  3. #3
    lss
    Visitante

    Padrão C compiler cannot create executables ???

    checking whether the C compiler (gcc ) works... no
    esse e o problema , ou voce nao tem o gcc instalado ou o pacote gcc nao esta completo.
    de uma procurado no seu cd de instalacao.

  4. #4
    marcelloduarte
    Visitante

    Padrão sim

    Sim estou usando assim, até ai tudo normal. Dai entro no diretorio criado e executo o script de instalação, ./configure.

    Mas ele da aquele erro descrevi.



  5. #5
    marcelloduarte
    Visitante

    Padrão gcc

    Ele esta intalado normal, inclusive o gcc2.95, sera que os dois juntos não funcionam, parece que nessa mensagem " ele diz que o gcc não esta trabalhando" pode se que ele esteja corrompido?

  6. #6
    marcelloduarte
    Visitante

    Padrão gcc

    vou disintalar o pacote gcc e instalar de novo. dai posto aqui o resultado.

    valeu.



  7. #7
    marcelloduarte
    Visitante

    Padrão nada

    desintalei e instalei de novo o gcc. e continua com omesmo erro na hora de compilar.
    Tenho outra maquina instalada o conectiva 9 do mesmo cd e com os mesmos pacotes, e nela funciona normal !!!

  8. #8

    Padrão C compiler cannot create executables ???

    será que o seu usuário tem permissão de escrita neste diretório?



  9. #9
    marcelloduarte
    Visitante

    Padrão sim

    Sim, estou fazendo isso como root.

  10. #10
    Kakaroto
    Visitante

    Padrão C compiler cannot create executables ???

    e ae viu no readme se vc não tem q compilar usando o gcc 3 talvez seja isso lê o readme do arquivo tar.gz, porq no erro ele checka o gcc e dá "no" q não axou mas como vc diz q tem ele instalado pode ser q este pacote tem q ser compilado pelo gcc 3, da uma olhada no readme la diz ok qualquer coisa estamos aq

    falow

    kakaroto



  11. #11
    marcelloduarte
    Visitante

    Padrão ok

    Caro KAKAroto, valeu a dica vou dar uma olhada nisso, se for isso terei que instalar o gcc 3 ñé? sabe onde consigo?

  12. #12
    Kakaroto
    Visitante

    Padrão C compiler cannot create executables ???




  13. #13
    superinf
    Visitante

    Padrão gcc

    Caro colega ja tive este problema e foi resolvido instalando-se as lib's glibc-devel e glibc-devel-static , espero que tenha ajudado.

  14. #14
    marcelloduarte
    Visitante

    Padrão Deu Certo!!!

    Valeu suprinf, instalei os pacotes que voce recomendou e deu certo!!! :P



  15. #15
    superinf
    Visitante

    Padrão Beleza

    Beleza Marcello foi bom poder ajudar, precisando disponha.

  16. #16
    meajudem
    Visitante

    Padrão Re: C compiler cannot create executables ???

    bem, uso conectiva 9....
    e eu estou com o mesmo problema do gcc...
    tentei instalar o glibc-devel
    mas ele pede: kernel-headers e glibc-base
    o kernel-headers nao tem nem no ftp da conectiva, nem nos cds, nem no rpmfind
    no rpmfind tem...mas nao pra conectiva...na versao do meu kernel
    já o glibc-base tem...
    mas da esse erro de dependencia:
    erro: falha nas dependências:
    glibc-base = 2.3.1-27264U90_1cl é necessário para glibc-i18n-pt-2.3.1-27264U90_1cl
    glibc-base = 2.3.1-27264U90_1cl é necessário para glibc-i18n-es-2.3.1-27264U90_1cl
    glibc-base = 2.3.1-27264U90_1cl é necessário para glibc-i18n-en-2.3.1-27264U90_1cl
    o engraçado...é que glibc-base = 2.3.1-27264U90_1cl é exatamente o nome do pacote que estou tentando instalar...quer dizer...ele ta pedindo que eu instale antes, ele mesmo...pra depois eu instalar ele...
    final das contas:
    nao consegui instalar o glibc-base, glibc-devel, kernel-headers.
    entao meu gcc ainda nao compila nada....



  17. #17
    marcelloduarte
    Visitante

    Padrão ...

    Bom,

    Realmente não sei, no meu instalou normal esses pacotes, mas tenta instalar esses : task-c++-devel task-c-devel task-kernel-compiling