+ Responder ao Tópico



  1. #1
    marcelloduarte
    Visitante

    Padrão SQUID!!!! SOCOROO!!!!!!!!!!!!!

    Caros colegas,

    Meu squid não esta funcionado....o estranho é que quando mando parar o serviço com service squid stop, ele me da um erro: No Running copy. Mas quando chequo os servicos que estão rodando com CHKCONFIG --LIST |grep sim , ele aparece rodando.................

    A pouco quando tinha acabado de configurar estava funcionado...de uma hora p/ outra parou de funcionar....

    Conectiva 9 , squid 2.5.1

  2. #2

    Padrão SQUID!!!! SOCOROO!!!!!!!!!!!!!

    Talvez ele esteja rodando, mas não funcionando...
    Posta o arquivo de log dele aqui



  3. #3

    Padrão SQUID!!!! SOCOROO!!!!!!!!!!!!!

    Caro Marcelo, boa noite ....
    Passei por esse tipo problema num servidor da empresa que também roda o squid. Só que com o Conectiva 8.
    Colocava no ar e sem mais nem menos ele não estava rodando. Aparecia a mensagem "No running copy" . Aí consultando um amigo que conhece mais de Linux, me pediu para dar um comando netstat -nr e não sei como mas aparecia a interface eth0 com 2 gateways.
    Não me pergunte como, mas aparecia isso.
    Dei um ifconfig eth0 down e reconfigurei novamente a eth0 com a configuração correta, recoloquei o squid no ar e voltou a funcionar novamente. Mas volta e meia isso vem acontecendo com esse nosso servidor. Não sei se problemas em alguma configuração ou problema de máquina.
    Um abraço ......... :wink:

  4. #4

    Padrão SQUID!!!! SOCOROO!!!!!!!!!!!!!

    Outra coisa Marcelo.
    Também já aconteceu que o squid dava a mensagem "No Running copy" com o comando service squid stop, e tinha outro problema. Olhamos as configurações da interface eth0 e descobrimos também que o servidor somente pingava até o modem, mas nunca pingava num ip externo. Chamamos a operadora local que teve que trocar o nosso modem. Mas antes deles trocarem o modem, foi executado através do navegador, um acesso ao modem com endereço 192.168.7.1. Lá tivemos que entrar com usuário e a senha do modem e salvar as configurações do modem. Funcionou legal depois disso. Mas depois a operadora preferiu trocar o modem.
    É cada coisa maluca que venho descobrindo ao longo do tempo em que venho tendo contato com o Linux !!!
    Saudações ........ :wink:



  5. #5
    marcelloduarte
    Visitante

    Padrão .....

    Da uma olhada no arquivo de log"""::::


    2004/01/30 16:12:29| Starting Squid Cache version 2.5.STABLE1 for i686-pc-linux-gnu...
    2004/01/30 16:12:29| Process ID 2910
    2004/01/30 16:12:29| With 1024 file descriptors available
    2004/01/30 16:12:29| Performing DNS Tests...
    2004/01/30 16:12:29| Successful DNS name lookup tests...
    2004/01/30 16:12:29| DNS Socket created at 0.0.0.0, port 1040, FD 5
    2004/01/30 16:12:29| Adding nameserver 200.176.2.10 from /etc/resolv.conf
    2004/01/30 16:12:29| Adding nameserver 200.176.2.12 from /etc/resolv.conf
    2004/01/30 16:12:29| Unlinkd pipe opened on FD 10
    2004/01/30 16:12:29| Swap maxSize 102400 KB, estimated 7876 objects
    2004/01/30 16:12:29| Target number of buckets: 393
    2004/01/30 16:12:29| Using 8192 Store buckets
    2004/01/30 16:12:29| Max Mem size: 8192 KB
    2004/01/30 16:12:29| Max Swap size: 102400 KB
    2004/01/30 16:12:29| Rebuilding storage in /var/cache/squid (DIRTY)
    2004/01/30 16:12:29| Using Least Load store dir selection
    2004/01/30 16:12:29| Set Current Directory to /var/cache/squid
    2004/01/30 16:12:29| Loaded Icons.
    2004/01/30 16:12:29| commBind: Cannot bind socket FD 12 to *:3128: (9 Address already in use
    FATAL: Cannot open HTTP Port
    Squid Cache (Version 2.5.STABLE1): Terminated abnormally.
    CPU Usage: 0.540 seconds = 0.430 user + 0.110 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 467
    Memory usage for squid via mallinfo():
    total space in arena: 11564 KB
    Ordinary blocks: 11555 KB 2 blks
    Small blocks: 0 KB 1 blks
    Holding blocks: 200 KB 1 blks
    Free Small blocks: 0 KB
    Free Ordinary blocks: 8 KB
    Total in use: 11755 KB 102%
    Total free: 9 KB 0%
    2

  6. #6
    marcelloduarte
    Visitante

    Padrão ...

    Agora ele esta assim:


    2004/01/31 08:24:48| Starting Squid Cache version 2.5.STABLE1 for i686-pc-linux-gnu...
    2004/01/31 08:24:48| Process ID 1093
    2004/01/31 08:24:48| With 1024 file descriptors available
    2004/01/31 08:24:48| Performing DNS Tests...
    2004/01/31 08:24:48| Successful DNS name lookup tests...
    2004/01/31 08:24:48| DNS Socket created at 0.0.0.0, port 1024, FD 5
    2004/01/31 08:24:48| Adding nameserver 200.176.2.10 from /etc/resolv.conf
    2004/01/31 08:24:48| Adding nameserver 200.176.2.12 from /etc/resolv.conf
    2004/01/31 08:24:48| Unlinkd pipe opened on FD 10
    2004/01/31 08:24:48| Swap maxSize 102400 KB, estimated 7876 objects
    2004/01/31 08:24:48| Target number of buckets: 393
    2004/01/31 08:24:48| Using 8192 Store buckets
    2004/01/31 08:24:48| Max Mem size: 8192 KB
    2004/01/31 08:24:48| Max Swap size: 102400 KB
    2004/01/31 08:24:48| Rebuilding storage in /var/cache/squid (DIRTY)
    2004/01/31 08:24:48| Using Least Load store dir selection
    2004/01/31 08:24:48| Set Current Directory to /var/cache/squid
    2004/01/31 08:24:48| Loaded Icons.
    2004/01/31 08:24:50| Accepting HTTP connections at 0.0.0.0, port 3128, FD 11.
    2004/01/31 08:24:50| Accepting ICP messages at 0.0.0.0, port 3130, FD 12.
    2004/01/31 08:24:50| Accepting HTCP messages on port 4827, FD 13.
    2004/01/31 08:24:50| Accepting SNMP messages on port 3401, FD 14.
    2004/01/31 08:24:50| WCCP Disabled.


    Ainda não funciona!!!!!!!!!!!!!!!!!!!!!!!!!111 :cry: